Terms & Conditions

Contents

Go to -> Company Details

Go to -> Licensing of Oasys software – Licensing Documentation PDF

Go to -> Help with ordering

Privacy and Cookies

Data Security

Website Terms and Conditions

Software Licensing Terms


Privacy and Cookies

We may change this privacy notice from time to time by updating this page.

What information do we collect?

When you use this website, we may collect the following information:

  • the areas of the website that you visit
  • information about your computer, such as which browser you are using, your network location, the type of connection you are using (e.g. broadband, ADSL etc) and your IP address

We do this by using cookies, which are small files that help us track how our visitors use the website and enable us to understand where we can improve your experience. If you would like to find out which cookies we use and the information they track see our Cookies Policy.

Once you submit or register information through our website we will know who you are and your activities on this website and information about you and/or your company may be recorded on our systems. For example, we may ask for personal information when you download our software including:

  • your name
  • company name
  • email address
  • postal address
  • telephone number
  • country where you are based
  • Social media ID
  • your comments/questions
  • services/markets you are interested in

We may also collect personal information from telephone calls and/or other correspondence with you.

What do we do with the information we collect?

The information we capture is used for various purposes. The main purpose is to provide you with our services (whether available via the website or offline). We also use the information for:

  • website development
  • understanding how our visitors interact on the website
  • understanding what our clients are interested in
  • understanding what potential clients are interested in
  • dealing with enquiries/concerns
  • marketing our services and people to you
  • market research
  • service development
  • internal record keeping

Marketing

We would like to provide you with information about our services and other information which we think you may find interesting. We may send you such information by post, email and/or telephone, unless you have asked us not to do so.

We will not provide your personal information to other organisations for marketing purposes without your explicit consent.

If at any time you do not want your information used for direct marketing purposes, please contact us or follow the unsubscribe link in our marketing email messages.

Who do we share this information with?

We may share your personal information with companies acting on our behalf who will only use the information to provide that service. However, we will retain control of your data and any third party service provider that we use must act in accordance with our instructions. We may also share your personal information with a purchaser or potential purchaser of our business.

In some circumstances, we may have to disclose your personal information by law, because a court or the police or other law enforcement agency has asked us for it.

How to get copies of or amend the information we have collected

You may request details of the personal information that we hold about you under data protection laws. If you would like a copy of the information held about you please write to us at oasys@arup.com or at: Data Protection Officer, 13 Fitzroy Street, London, UK, W1T 4BQ. Please note that we may charge a small £10 administration fee for information requests.

If you think any information we have about you is incorrect or incomplete, please email us as soon as possible. We will correct or update any information as soon as we can.

top ]


Data Security

We are committed to ensuring that your information is secure. In order to prevent unauthorised access or disclosure we have put in place suitable physical, electronic and managerial procedures to safeguard and secure the information we collect, including locked cabinets, electronic password protection and pass card access to buildings.

If at any point you suspect or receive a suspicious communication from someone suggesting they work for Oasys or a website claiming to be affiliated with Oasys, please forward the communication to us or report the incident by email to oasys@arup.com or in writing to Oasys, 13 Fitzroy Street, London, UK, W1T 4BQ as soon as possible.

top ]


Website Terms and Conditions

The contents of this web site are protected by copyright and other intellectual property rights under international conventions. No copying of any words, images, graphic representations or other information contained in this web site is permitted without the prior written permission of the webmaster for this site.

Oasys accepts no responsibility for the content of any external site that links to or from this site.

top ]


Software Licensing Terms

Terms and Conditions of Purchase

The full conditions of purchase and maintenance for all Oasys software are set out in the Oasys Software Licence and Support Agreement. All prices are subject to TAX at the current rate.

Prices and specifications are subject to change without notice – please ask for a written quotation.

Although every care has been taken to ensure the accuracy of all information contained herein, the contents do not form or constitute a representation, warranty, or part of any contract.

Superseded Versions of Terms and Conditions

Oasys keeps copies of all superseded versions of its terms and conditions.

Maintenance & Support Services

Twelve months support and maintenance is included with most products. Thereafter maintenance is typically 20% of the current sales price.

An annual maintenance service is available for most programs after the first year.

This service includes:

  • telephone/fax/email/web based support
  • free software updates available via internet download
  • personalised output header for many products

Pdisp Change Log

All notable changes to Pdisp will be documented within the change log

New Features

  • Consolidation – 1D Time dependent consolidation for linear problems using the finite difference approach.
  • COM – Programming interface is provided by COM automation.

Minor Enhancements

  • ME PDISP-186 3D Graphics Automation of display of timestep results added to 3D Graphics. Build 9
  • ME PDISP-185 Contouring, 3D Graphics Contours for Consolidation results. Build 9
  • ME PDISP-183 Tabular Output Option to view All Input Data or All Results or both in a single Text Output view. Build 9
  • ME PDISP-172 Gateway, Default width of gateway to be increased. Build 6
  • ME PDISP-166 Graphs, Consolidation, Graph for degree of consolidation. Build 6
  • ME PDISP-154 Table Views, Ctrl + Z and Ctrl + Y accelerators from Table Views for undo/redo. Build 5
  • ME PDISP-153 Miscellaneous, New Titles Dialog. Build 5
  • ME PDISP-152 Tabular Output, Right-click/context menu in Text Output (fully populate fields, export, stripey output and grid view). Build 5
  • ME PDISP-151 3D Graphics, Additional buttons/drop lists to 3D Graphical Output toolbar to allow rapid access to most common settings e.g. displacement grids, lines, points, filled and line contours, lighting, transparency. Build 5
  • ME PDISP-150 Graphs, Selection of different views from within chart via multi drop list. Build 5
  • ME PDISP-149 Graphs, Improved chart access directly from Output Explorer. Build 5
  • ME PDISP-148 Input, Table Views Load Data (rectangular, circular, polygonal) separated to Rectangular,Circular and Polygonal. Build 5
  • ME PDISP-147 Input, Table Views Displacement Data (points, lines, polylines, grids) separated to Displacement Points, Displacement Lines, Displacement Polylines and Displacement Grids. Build 5
  • ME PDISP-146 UI Separation of Gateway to Input and Output Explorers. Build 5
  • ME PDISP-139 UI, Graphs Line graphs of stresses/strains if Boussinesq method is chosen. Build 5
  • ME PDISP-137 Tabular Output Tabular Output modifications. Build 5
  • ME PDISP-131 Soil Profiles “Name” field added to layers of Soil Profile table. Build 5

Fixes

  • NCR PDISP-184 2D Plan, Contouring Plan view contours may be wrong on some occasions when the soil zones are active at the same time. Build 9
  • NCR PDISP-182 Circular Loads PDisp crashes when analysing a model with circular loads. Build 9
  • NCR PDISP-181 Export, CSV Deflected check box on the graphics settings wizard not active even when results are present. Build 9
  • NCR PDISP-180 Export, CSV PDisp crashes when trying to export csv via File->Export. Build 9
  • NCR PDISP-179 Miscellaneous Installing PDisp may corrupt Frew file associations. Build 9
  • NCR PDISP-178 Installer PDisp not installing on certain machines. Build 9
  • NCR PDISP-177 Table Views Weird behaviour of Table Views when cancelling deleting the results warning while deleting any record. Build 9
  • NCR PDISP-102 Non-linear Curves Non-linear curves for factors on Young’s Modulus need not be entered starting with a value for zero strain. This may lead to confusion and indeterminate results… Build 9
  • NCR PDISP-176 Output, UI, Results should be deleted and the user should be warned accordingly when deleting displacement entities. Build 6
  • NCR PDISP-175 UI, Displacement Data, Displacement Entities’ (Points, Lines and Grids) input nodes are missing in the output explorer. Build 6
  • NCR PDISP-174 3D Graphics, UI, “Apply” button may disappear from the 3D Graphics Settings Build 6
  • NCR PDISP-173 Graphics, UI, Plan, Graphical Input, Graphics sub-menu wrong for Plan, Graphical Input and Cross-Section views. Build 6
  • NCR PDISP-171 3D Graphics, Clicking the “General” tab in 3D Graphics Settings crashes the program when there are no displacement grids. Build 6
  • NCR PDISP-170 Imported Displacements, UI, Imported displacements won’t open. Build 6
  • NCR PDISP-169 Analysis, Validation, Analysis should throw up an error message if the user enters 0 for mv or Cv. Build 6
  • NCR PDISP-168 Reading, Error while reading files that are saved in 19.4 Build 5. Build 6
  • NCR PDISP-167 Validation, Consolidation, Consolidation checks are carried out even when the consolidation option is not checked in the analysis options. Build 6
  • NCR PDISP-165 Analysis, Consolidation, Pore pressures are wrong at permeable boundaries. Build 6
  • NCR PDISP-164 Analysis, Consolidation, k/Cv calculations could be wrong at interface nodes. Build 6
  • NCR PDISP-163 Tabular Output, Consolidation, Degree of Consolidation (U) should not be reported for points that lie in layers of no consolidation. Build 6
  • NCR PDISP-162 Input, Consolidation, Unable to set water level and unit weight. It always takes default values. Build 6
  • NCR PDISP-161 Cross-Section view, Cross-Section view is not accessible from the Output Explorer. Build 6
  • NCR PDISP-160 Cross-Section view, Opening the Cross-section view crashes the program. Build 6
  • NCR PDISP-159 Plan, Plan View not present in the output explorer. Build 6
  • NCR PDISP-158 Tabular Output, Consolidation and Water items are not needed in the Output Explorer as they are already printed in the Analysis Options. Build 6
  • NCR PDISP-157 Soil column Displacements Soil column displacements’ view crashes when dealing with files having non-linear curves. Build 5
  • NCR PDISP-156 Analysis The vertical stress at any point that is at the load level and in the loaded area should be equal to the pressure specified at that load. Build 5
  • NCR PDISP-145 Miscellaneous It would be useful if PDisp remembered the location of the last opened file, and presented it when next performing File->Open. Build 5
  • NCR PDISP-144 Miscellaneous PDisp would better save backup files to the user’s AppData\Local\Temp folder, rather than the Program Files\Samples folder since users may not always have write permissions to the latter. They should also be deleted on closing the data file. Build 5
  • NCR PDISP-142 UI, Analysis Pdisp is crashing when a file with wrong input in Analysis options dialog is analysed. Build 5
  • NCR PDISP-141 UI, Analysis Pdisp crashes when analysing a model that has 0 number of rectangles specified for a circular load. Build 5
  • NCR PDISP-140 UI, Analysis Pdisp may crash if an analysis is attempted with no displacement points, lines or grids. Build 5
  • NCR PDISP-138 UI If non units of length are not metres, and loads are rotated, then their rotations (and so results) may not be as expected. Build 5
  • NCR PDISP-119 Input Pdisp misbehaves if Youngs Modulus of zero is set for either or both top and bottom of strata. Build 5
  • NCR PDISP-104 Input, Soil Profiles Double-clicking the “Colour” field in a soil profile’s table opens the colour dialog but without the correct colour shown. So it is intedeterminable by the user. Build 5
  • NCR PDISP-102 Non-linear Curves Non-linear curves for factors on Young’s Modulus need not be entered starting with a value for zero strain. This may lead to confusion and indeterminate results… Build 5
  • NCR PDISP-101 UI, Graphs The title bar of line graphs shows only the file extension “.pdd” and not the full file name. Build 5

New Features

Pdisp 19.3 : New Features

  • New 64-bit version.
  • Multi-core processing of analysis calculations.
  • Multi-threading to allow data to be inspected, or another file opened, while an analysis is proceeding.
  • Polygonal loads.
  • Import to DXF background information.
  • Undo/redo in table views.
  • Improved 3D graphics settings for display of displacement data and results.
  • Grid View of Tabular output for straightforward copying into a spreadsheet.

Pdisp 19.3: Minor Enhancements

  • User-defined tolerance for omission of duplicate locations on import and export of CSV results.
    [ME PDISP-31] (Added 26 November 2015) (Released in Build 5)
  • Revision to digital signature of installer.
    [ME PDISP-67](Fixed 17 May 2016; released in Pdisp 19.3 Build 6)
  • Inclined displacement lines are not shown in the Plan View, so their line graphs of results cannot be selected and shown.
    [ME PDISP-41] (Implemented 12 November 2016; released in Build 8)
  • Import Xdisp data file (but displacement data only to Xdisp version 19.3).
    [ME PDISP-44] (Implemented 2 February 2016; released in Build 8)
  • The Analysis Options FormView may open with some content/buttons accessible only by scrolling.
    [ME PDISP-51] (Implemented 4 March 2016; released in Build 8)
  • The 3D Graphics View does not preserve results’ selections (where might be appropriate) if data is amended, results deleted, and an analysis re-run.
    [ME PDISP-52] (Implemented 17 February 2016; released in Build 8)
  • The title of the Tabular Output wizard (“Page Setup”) is misleading. Change to e.g. “Tabular Output Selection”.
    [ME PDISP-53] (Implemented 17 February 2016; released in Build 8)
  • 3D Graphics: Removal of titles and warning re comparison of Mindlin v Boussinesq (moved to Analysis Dialog and Tabular Output).
    [ME PDISP-54] (Implemented 19 February 2016; released in Build 8)
  • Do not present page set up dialog after analysing (and set all check boxes to true by default when it is opened).
    [ME PDISP-55] (Implemented 19 February 2016; released in Build 8)
  • Move Wizard column to start of polygon loads columns.
    [ME PDISP-56] (Implemented 22 February 2016; released in Build 8)
  • “Application Look”, on the program’s View menu, does not work well for all styles. Unnecessary option added for Pdisp 19.3. Remove.
    [ME PDISP-59] (Implemented 7 March 2016; released in Build 8)
  • The 3D Graphics Settings Wizard (Displacements’ page) is unusable when large numbers of imported displacements are available.
    [ME PDISP-61] (Implemented 8 April 2016; released in Build 8)
  • Writing 19.2 files (for GSA use) from 19.3.
    [ME PDISP-62] (Implemented 19 July 2016; released in Build 8)
  • Import of Xdisp files (insofar as is possible i.e. displacement data, background data, restuls and imported results).
    [ME PDISP-69] (Implemented 13 June 2016; released in Build 8)
  • The 3D Graphics Settings should more helpfully default to a wire frame view since load and displacement data is then visible.
    [ME PDISP-72] (Implemented 5 July 2016; released in Build 8)
  • Improved (less obtrusive) data validation in table views. Some validation delayed to pre-analysis check.
    [ME PDISP-75] (Implemented 29 July 2016; released in Build 8)
  • Move Soil Boundary Layer to top of/higher in Analysis Options dialog.
    [ME PDISP-80] (Implemented 2 September 2016; released in Build 8)
  • Move non-linear curves branch of Gateway below Soil Profiles (and introduce GSA Piled Raft Data as super-title to its data).
    [ME PDISP-81] (Implemented 2 September 2016; released in Build 8)
  • Some toolbar icons differ from Xdisp, whose icons have been updated in a recent revision. It would be more helpful to users of both programs to present consistent icons.
    [ME PDISP-82] (Implemented 15 September 2016; released in Build 8)
  • Inform user that Tabular Output “is being prepared. Please wait.” in case the lack of information causes them to feel the program has crashed.
    [ME PDISP-84] (Implemented 30 September 2016; released in Build 8)
  • Condensed font droplist, with improved flexibility re scaling, to Pdisp toolbar for use by Plan View, Graphical Input View and Tabular Output in place of previous 2-size condensed font options.
    [ME PDISP-85] (Implemented 31 October 2016; released in Build 8)
  • Table View headers tidied up (consistency of units row to all tables with units, removal of unnecessary blank lines in headers) (inc blank line in header of soil zones’ table).
    [ME PDISP-86] (Implemented 4 November 2016; released in Build 8)
  • Error message re rigid boundary level would better point the user at the Analysis Options dialog for resolution.
    [ME PDISP-87] (Implemented 7 November 2016; released in Build 8)
  • Filled contours can only be activated in the Plan View when line contours are already selected. This is an unnecessary restriction.
    [ME PDISP-88] (Implemented 7 November 2016; released in Build 8)
  • The Analysis Options dialog warns repeatedly (and unnecessarily) if the global poisson’s ratio is less than poisson’s ratios in soil profiles. Only one warning is necessary. (Item includes improvement to text of warning message.)
    [ME PDISP-90] (Implemented 8 November 2016; released in Build 8)
  • Removal of warning in Displacement Data table re >99 intervals to prevent possible repetitive warning. Moved to pre-analysis checks.
    [ME PDISP-92] (Implemented 8 November 2016; released in Build 8)
  • Additions/amendments to feature logging e.g. for possible future UX improvements (e.g. graphics labelling subsets, delete results button, Tabular Output Wizard “All” and “None” buttons, graphics filled polygons, use of circular loads, rotated rectangular loads, printing of graphics or tabular output), use of calculation sheet.
    [ME PDISP-94] (Implemented 12 November 2016; released in Build 8)
  • Warning added to Tabular Output if horizontal displacements are requested and the “stiffness at displacement point” option is selected. (Same warning as has previously appeared only on exiting the Analysis Options dialog.)
    [ME PDISP-112] (Implemented 13 January 2017; released in Build 11)
  • The alignment of warnings in the Tabular Output is poor. It would also benefit from numbering there and in the Analysis Dialog.
    [ME PDISP-118] (Implemented 3 February 2017; released in Build 13)
  • Update to licensing.
    [ME PDISP-130] (Released in Build 16)

Fixes

  • Pdisp’s Analysis Parameters checkbox “GSA raft analysis data” might better be named “GSA piled raft data”.
    [NCR 8708] (Fixed 01 September 2014) (Released in Build 1)
  • Unnecessary warning message while data input in Soil Profiles table.
    [NCR 9359] (Fixed 11 November 2014) (Released in Build 1)
  • Pdisp fails to update the user on progress of calculations, giving the impression, during large calculations, that the program has hung.
    [NCR 3828] (Fixed 12 November 2014) (Released in Build 1)
  • Tooltips for the toolbar items of plan are not working.
    [NCR 9455] (Fixed 11 December 2014) (Released in Build 1)
  • Vertical loading plane is shown horizontal in the graphical input.
    [NCR 9451] (Fixed 12 November 2014) (Released in Build 1)
  • A 3D Graphics View of an undeflected displacement grid is filled whether the “Filled Polygon” check box is checked or not. If not, then it would be expected to show an empty “net” of grid lines with no fill. The fill hides other items in the display.
    [NCR 8342] (Fixed 02 September 2014) (Released in Build 1)
  • There are no options in the preferences dialog to enable/disable undo-redo feature and set the number of undo-redo steps.
    [PDISP 1] (Fixed 20 January 2015) (Released in Build 3)
  • Pdisp crashes when the results are viewed by opening a file that already has results and has Boussinesq as analysis method.
    [PDISP 2] (Fixed 16 February 2015) (Released in Build 3)
  • A copy of warnings list is added to the analysis progress dialog whenever the file is re-analysed.
    [PDISP 3] (Fixed 12 February 2015) (Released in Build 3)
  • Pdisp saves the default colour always for a soil profile instead of the user selected colour.
    [PDISP 4] (Fixed 12 February 2015) (Released in Build 3)
  • Background data is not shown in the 3DGraphics view.
    [PDISP 5] (Fixed 16 February 2015) (Released in Build 3)
  • Pdisp does not delete the results of a file when its soil profile data is edited.
    [PDISP 6] (Fixed 20 February 2015) (Released in Build 3)
  • Results view incorrectly shows that results include imported displacements even when they do not.
    [PDISP 7] (Fixed 23 February 2015) (Released in Build 3)
  • Rogue loads are added to the loads table when the full results are viewed by opening a file that already has results and atleast one polygonal load.
    [PDISP 8] (Fixed 25 February 2015) (Released in Build 3)
  • Message mentioning the maximum displacement difference between Boussinesq and Mindlin methods should be output in the 3D-Graphics view also.
    [PDISP 9] (Fixed 25 February 2015) (Released in Build 3)
  • Imported displacements are not added to the results from Pdisp analysis when the user reopens a file, which already has results.
    [PDISP 10] (Fixed 25 February 2015) (Released in Build 3)
  • Undo/Redo is accessible even while the analysis is in progress.
    [PDISP 11] (Fixed 26 February 2015) (Released in Build 3)
  • Pdisp allows input even while the analysis is in progress.
    [PDISP 12] (Fixed 26 February 2015) (Released in Build 3)
  • Pdisp crashes when a file with multiple non-linear curves is analysed.
    [PDISP 13] (Fixed 27 February 2015) (Released in Build 3)
  • Undo/Redo doesn’t update the table view that is not active, hence giving an impression to the user that the undo/redo hasn’t been performed on the data.
    [PDISP 14] (Fixed 02 March 2015) (Released in Build 3)
  • Soil column displacements view if already opened is still active even when the input data is modified.
    [PDISP 15] (Fixed 02 March 2015) (Released in Build 3)
  • Line displacements graph is not closed when the results are deleted.
    [PDISP 16] (Fixed 27 February 2015) (Released in Build 3)
  • Plan view is not updated immediately after the displacement data is modified.
    [PDISP 17] (Fixed 03 March 2015) (Released in Build 3)
  • Pdisp crashes when a non-linear curve’s record is deleted.
    [PDISP 18] (Fixed 03 March 2015) (Released in Build 3)
  • Loads’ Tableview : Undo/Redo doesn’t work properly in the case where records are inserted in between the existing records.
    [PDISP 21] (Fixed 24 April 2015) (Released in Build 4)
  • A file with polygonal loads doesn’t give correct results always.
    [PDISP 22] (Fixed 24 April 2015) (Released in Build 4)
  • Some diisplacement related errors are always reported in SI units, but the titles are in user-selected units.
    [NCR PDISP-25] (Fixed 21 July 2015) (Released in Build 5)
  • Pdisp incorrectly warns of locations in displacement grids that lie outside all soil zones.
    [NCR PDISP-27] (Fixed 29 October 2015) (Released in Build 5)
  • Pdisp fails to display soil column displacements correctly if polygonal loads are used.
    [NCR PDISP-28] (Fixed 20 November 2015) (Released in Build 5)
  • The Pdisp help manual incorrectly states that the Plan View’s contour interval is set via the View menu rather than Graphics -> Grid results -> Set contour interval.
    [NCR PDISP-29] (Fixed 20 November 2015) (Released in Build 5)
  • If European regional settings are used, then Pdisp may reset loads’ data to zero on closing and reopening the Loads’ Table.
    [NCR PDISP-30] (Fixed 14 December 2015) (Released in Build 5)
  • Delay in presentation of data in the Tabular Output.
    [NCR PDISP-32] (Fixed 30 November 2015) (Released in Build 5)
  • More information/references regarding derivation of pile-soil interaction coefficients in the help manual.
    [NCR PDISP-33] (Fixed 4 December 2015) (Released in Build 5)
  • Pdisp will underestimate displacements if a circular load is modelled by choosing to represent it by only one rectangle (specified in the loads’ table).
    [NCR PDISP-65] (Fixed 12 May 2016) (Released in Build 6)
  • On installing to a computer which has not had a previous version of Pdisp, the program may first open in a small window in the top left of the screen, or not visible at all.
    [NCR PDISP-66] (Fixed 13 May 2016) (Released in Build 6)
  • Pdisp crashing when full results of a file (having errors) is viewed.
    [NCR PDISP-23] (Fixed 29 March 2016; released in Build 8)
  • Pdisp displays National Grid type coordinates poorly in the Tabular Output, the Graphical Input plan, and 3D Graphics.
    [NCR PDISP-35] (Fixed 24 December 2015; released in Build 8)
  • Entering non-numeric text (e.g. “123456789-a”) into the Young’s Modulus – Bottom cell of the Soil Profiles’ table gives a blank error message.
    [NCR PDISP-37] (Fixed 27 July 2016; released in Build 8)
  • “Help -> Oasys UserVoice” and “Help->Keyboard Map” are permanently greyed out.
    [NCR PDISP-38] (Fixed 12 November 2016; released in Build 8)
  • Pdisp may give zero displacements if the Mindlin method (non-legacy) is selected, and the displacement point is precisely at the level of the junction of two soil layers.
    [NCR PDISP-40] (Fixed 25 January 2016; released in Build 8)
  • Pdisp’s 3D Graphics may display a reflected image of the model in the plan view, if some or all coordinates are negative.
    [NCR PDISP-42] (Fixed 27 January 2016; released in Build 8)
  • Pdisp fails to prompt the user to save a file when closing a file that has had DXF data imported.
    [NCR PDISP-43] (Fixed 29 January 2016; released in Build 8)
  • The Gateway refers to Analysis Options whereas the dialog its selection presents is titled Analysis Parameters.
    [NCR PDISP-45] (Fixed 2 February 2016; released in Build 8)
  • The Gateway opens at a fixed, narrrow width, irrespective of the width when the program was last closed.
    [NCR PDISP-47] (Fixed 5 February 2016; released in Build 8)
  • Help Menu: remove “Keyboard Map” which is currenty permanently disabled; reinstate “Tutorials”.
    [NCR PDISP-48] (Fixed 9 February 2016; released in Build 8)
  • Help File: incomplete description of “Number of Rectangles” in the Load Data page.
    [NCR PDISP-49] (Fixed 9 February 2016; released in Build 8)
  • The menu command “Window” -> “Position” arranges views with margins outside the viewable area.
    [NCR PDISP-50] (Fixed 10 February 2016; released in Build 8)
  • Neither the Loads Table View nor the Tabular Output View shows the units for tolerance for fitting rectangles to polygons if polygonal loads are specified.
    [NCR PDISP-57] (Fixed 22 February 2016; released in Build 8)
  • Tabular Output: if Boussinesq results then “Displacement” missing from header which shows “Z” only.
    [NCR PDISP-58] (Fixed 23 February 2016; released in Build 8)
  • A failure in calculation, which produces #1.INF results, will prevent contour plots from being drawn. (The program may appear to hang.)
    [NCR PDISP-64] (Fixed 16 November 2016; released in Build 8)
  • Pdisp fails to calculate horizontal displacements if soil zones are not specified to cover the whole model (i.e. the extent of all displacement data and loads). This situation should be prevented with an error before analysis.
    [NCR PDISP-70] (Fixed 7 November 2016; released in Build 8)
  • Test files that contain polygonal loads should be those not already expanded to multiple rectangles.
    [NCR PDISP-71] (Fixed 1 July 2016; released in Build 8)
  • Pdisp may crash during analysis if the data contains an unreferenced soil profile which has more strata than do the soil profiles that are referenced.
    [NCR PDISP-73] (Fixed 13 July 2016; released in Build 8)
  • Pdisp fails to check correctly that soil strata are ordered by decreasing elevation.
    [NCR PDISP-74] (Fixed 29 July 2016; released in Build 8)
  • The 3D Graphics fails to display anything if there are no soil zones in the model (though soil profiles). It could usefully assume the first profile to the extent of all other data.
    [NCR PDISP-76] (Fixed 2 August 2016; released in Build 8)
  • The settlement of points above the level of load may be calculated incorrectly at points in plan when the settlement at level of load is very close to settlement at rigid boundary level.
    [NCR PDISP-78] (Fixed 4 August 2016; released in Build 8)
  • Analysis may fail to run with the error message that displacement locations are above soil profiles, though they are equal in level. Despite this fix, when legacy “problem” files are opened in Pdisp 19.3 Build 8 or later, their displacement location, load and soil profile levels may have to be retyped in order to overcome legacy precision issues.
    [NCR PDISP-79] (Fixed 13 September 2016; released in Build 8)
  • Pdisp may crash when opening an existing file from the File menu, when run in a virtual desktop.
    [NCR PDISP-83] (Fixed 22 September 2016; released in Build 8)
  • The Plan View is not updated, e.g. to remove contour results, when results are deleted.
    [NCR PDISP-89] (Fixed 7 November 2016; released in Build 8)
  • “Soil column displacements” appears on both the “Edit” and the “View” menus when the Tabular Output is active. It should be on the “View” menu only.
    [NCR PDISP-91] (Fixed 8 November 2016; released in Build 8)
  • Help file “Label objects” suggests this option is on the “View” menu. It is on the “Graphics” menu.
    [NCR PDISP-93] (Fixed 10 November 2016; released in Build 8)
  • The file name is missing from the title bar of the Soil Column Displacements View.
    [NCR PDISP-95] (Fixed 12 November 2016; released in Build 8)
  • The Line Graph button on the Plan Toolbar cannot be unset when there are results. The user should be able to select or deselect it.
    [NCR PDISP-97] (Fixed 12 November 2016 released in Build 8)
  • Use of non-linear curves with zero factors should be prohibited, since this will result in soil with no strength, and so infinite displacements.
    [NCR PDISP-98] (Fixed 16 November 2016; released in Build 8)
  • Print and Print Preview buttons are incorrectly disabled when the Tabular Output is displayed in the Grid View.
    [NCR PDISP-99] (Fixed 16 November 2016; released in Build 8)
  • [NCR PDISP-108] (Fixed 10 January 2017; released in Build 11)
  • Pdisp crashes when the coordinates wizard for a polygonal load is closed if that wizard was opened from an incomplete row in the loads table.
    [NCR PDISP-109] (Fixed 6 January 2017; released in Build 11)
  • If non-SI units are used for length (i.e. not metres), then Pdisp fails to display, in the polygonal load’s wizard, the rectangles by which a polygonal load will be approximated.
    [NCR PDISP-110] (Fixed 6 January 2017; released in Build 11)
  • If horizontal displacements/loads are specified, and the model contains overlapping soil zones or gaps in soil zones, then Pdisp may calculate incorrect results.
    [NCR PDISP-111] (Fixed 10 January 2017; released in Build 11)
  • Analysis options are not all reported in the Tabular Output.
    [NCR PDISP-113] (Fixed 13 January 2017; released in Build 11)
  • Checks for warnings are not completed before analysis if the Mindlin method is chosen without the legacy option e.g. displacement and load location checks are skipped (among others).
    [NCR PDISP-114] (Fixed 13 January 2017; released in Build 11)
  • Switching from “Condensed” to “Full” in the Tabular Output has no effect.
    [NCR PDISP-115] (Fixed 18 January 2017; released in Build 11)
  • Licensing fix (commercial builds only).
    [NCR PDISP-120] (Fixed 31 January 2017; released in Build 12)
  • Results pertaining to the 0th index of a level array are being printed twice in the “full” version of the Tabular Output.
    [NCR PDISP-121] (Fixed 6 February 2017; released in Build 13)
  • The Tabular Output is not updated after making changes in its wizard.
    [NCR PDISP-122] (Fixed 14 February 2017; released in Build 13)
  • Performing an “update” when batch testing a file which contains a polygonal load results in the polygonal load being saved as its set of rectangular loads that are used for analysis. The polygonal loads are lost.
    [NCR PDISP-123] (Fixed 8 February 2017; released in Build 13)
  • Pdisp crashes if an analysis is attempted with a polygonal load which has no polygon coordinates.
    [NCR PDISP-126] (Fixed 11 February 2017; released in Build 13)
  • Pdisp may fail to preserve polygonal load coordinates when the loads table is closed and/or the file saved.
    [NCR PDISP-127] (Fixed 14 February 2017; released in Build 13)
  • Pdisp may skip reading some modules (e.g. soil zones) if a file which has imported displacements is opened.
    [NCR PDISP-128] (Fixed 28 February 2017; released in Build 14)
  • If the “Name” field of displacement data is edited, the change may not be preserved upon saving and reopening the data file.
    [NCR PDISP-129] (Fixed 14 March 2017; released in Build 15)

New Features

Pdisp 19.2 : New Features

  • Import of displacement results from CSV file.
  • Export of displacement results and contours to CSV file.
  • Improved granularity of entity labelling in 3D Graphics View.
  • Striped output to Tabular Output.

Pdisp 19.2: Minor Enhancements

  • Loads and soil zones may be named.
    [ME 2382]

Fixes

  • Deleting the sole remaining non-linear curve leaves a rogue curve with no data.
    [NCR 5313]
  • Double-clicking a soil profile in the gateway opens the soil profiles table but with the first soil profile’s tab active, not the soil profile that was selected.
    [NCR 5314]
  • The “Show Detailed Results” toggle in the Displacements Table View is only effective for Displacement Grids.
    [NCR 5579]
  • Data is not preserved correctly in the non-linear curves table. Entering data and then clicking “Add Curve”, or closing the view, causes the data to be lost.
    [NCR 6186]
  • Pdisp fails to display contour plots for displacement grids in the 2D Plan View correctly.
    [NCR 6216] (Fixed 21 July 2011) (Released in Build 1)
  • Pdisp gives a default value of 5kN/m2 for load in the tangential y direction. A default of 0kN/m2 would be more sensible.
    [NCR 6244] (Fixed 1 August 2011) (Released in Build 2)
  • Pdisp reads soil zones incorrectly, removing characters from the start of the name field each time the data file is opened (after saving), until there are no characters and the program warns that soil zones cannot be read.
    [NCR 6245] (Fixed 1 August 2011) (Released in Build 2)
  • Pdisp may fail to display line graphs of displacements for displacement lines correctly.
    [NCR 6277] (Fixed 23 August 2011) (Released in Build 3)
  • The bitmap chosen in the background of the plan view is not persistant on closing and re-opening the view, or closing and re-opening the data file.
    [NCR 6320] (Fixed 7 September 2011) (Released in Build 4)
  • After selecting a bitmap as the background for the plan view, the error message “bitmap not created” may, at some point, be output, and the bitmap no longer shown.
    [NCR 6321] (Fixed 7 September 2011) (Released in Build 4)
  • Pdisp’s 2D Plan View does not allow toggling on and off of displacement points, lines and grids.
    [NCR 6323] (Fixed 8 September 2011) (Released in Build 4)
  • Displacement points cannot be “turned off” in the 3D Graphics View, even though the Settings Wizard is set not to display them.
    [NCR 6329] (Fixed 13 September 2011) (Released in Build 4)
  • If results are available, and displacement points are selected to be shown and labelled in both deflected and undeflected positions, the 3D Graphics View labels both positions as “…(Deflected)”.
    [NCR 6331] (Fixed 13 September 2011) (Released in Build 4)
  • The cross section plot fails to show the strata with filled colours.
    [NCR 6334] (Fixed 13 September 2011) (Released in Build 4)
  • The Graphical Input Plan View shows all components in black. They should be coloured for easy distinction.
    [NCR 6363] (Fixed 21 September 2011) (Released in Build 4)
  • The Plan View does not allow components to be labelled, although labels for grids, lines, points and loads are offered in the program’s menu.
    [NCR 6365] (Fixed 16 September 2011) (Released in Build 4)
  • Soil zones can be toggled, but not labelled in the 2D Plan View.
    [NCR 6366] (Fixed 21 September 2011) (Released in Build 4)
  • The program menu’s “Graphics” menu allows graphical input of displacements and loads, but not soil zones.
    [NCR 6371] (Fixed 23 September 2011) (Released in Build 4)
  • Display of deflected displacement points and lines cannot be turned off in the 3D Graphics View.
    [NCR 6408] (Fixed 7 October 2011) (Released in Build 4)
  • Pdisp’s Tabular Output should indicate the units of vertical strain: absolute or %.
    [NCR 6235] (Fixed 4 November 2011) (Released in Build 5)
  • Pdisp may fail to plot line contours on the 2D Plan View for a displacement grid whose second point’s x value is less than the first point’s x value, or whose first point’s y value is less than the second point’s y value.
    [NCR 6702] (Fixed 26 January 2012) (Released in Build 6)
  • Pdisp’s indexing of displacement grids, lines and points differs (by 1) depending on whether viewing data in the input Table View or the Tabular Output.
    [NCR 6827] (Fixed 26 March 2012) (Released in Build 7)
  • Pdisp may fail to plot displacement contours correctly in the 3D Graphics View.
    [NCR 6914] (Fixed 23 March 2012) (Released in Build 7)
  • When opening the PSIC table from the gateway by double-clicking the last PSIC entry in that branch, the program crashes.
    [NCR 6917] (Fixed 14 March 2012) (Released in Build 7)
  • Pdisp’s PSIC input view displays only one set of curve data as the tabs are clicked to change the curve being displayed.
    [NCR 6918] (Fixed 14 March 2012) (Released in Build 7)
  • Displacements may be reported as “-1.#IND0”.
    [NCR 6956] (Fixed 22 March 2012) (Released in Build 7)
  • The 3D Graphics View may fail to open, leaving the program hanging.
    [NCR 6975] (Fixed 29 March 2012) (Released in Build 7)
  • Copying displacement data from Xdisp’s to Pdisp’s displacement data tables causes loss of resolution so intended identical points no longer match in the two programs.
    [NCR 7017] (Fixed 4 April 2012) (Released in Build 7)
  • Tabular Output fails to show displacement data to sufficient detail for them to be distinguishable.
    [NCR 7037] (Fixed 13 April 2012) (Released in Build 7)
  • Tabular Output is not updated automatically when the number format in the Preferences Dialog is updated.
    [NCR 7038] (Fixed 13 April 2012) (Released in Build 7)
  • Exporting displacement results from Pdisp into Xdisp may fail to generate matches, though identical displacement coordinates are intended, due to inaccurate precision of coordinates.
    [NCR 7063] (Fixed 4 April 2012) (Released in Build 7)
  • Imported displacements are not shown in the Tabular Output with sufficient resolution.
    [NCR 7097] (Fixed 2 May 2012) (Released in Build 7)
  • When importing displacements from Pdisp into Xdisp the imported displacements may have rounded, or otherwise very slightly different coordinates sufficient to prohibit a match when combining results.
    [NCR 7098] (Fixed 2 May 2012) (Released in Build 7)
  • Pdisp crashes when entering displacement grids, lines or points in the 2D graphical input view, if no displacement grids, lines or points have previously been entered.
    [NCR 7184] (Fixed 12 June 2012) (Released in Build 8)
  • Displacement lines’ displacements’ graphs are stepped as though they only plot distances to the nearest integer distance e.g. the nearest 1m.
    [NCR 7263] (Fixed 14 August 2012) (Released in Build 9)
  • Line contours in the plan view may be stepped along grid lines, rather than continuous.
    [NCR 7327] (Fixed 15 August 2012) (Released in Build 9)
  • The error message “Encountered an improper argument” appears, and a blank window opens, if the Soil Column Displacements graph is opened for a model whose soil zones do not cover the coordinate x = 0m, y = 0m.
    [NCR 7337] (Fixed 20 August 2012) (Released in Build 10)
  • The 2D Plan View may fail to colour the lowest contour when filled contours are chosen.
    [NCR 7343] (Fixed 20 August 2012) (Released in Build 10)
  • Pdisp may give the warning “Enter a number” when visiting or leaving the “Displacements” page of the 3D Graphics Wizard.
    [NCR 7393] (Fixed 6 September 2012) (Released in Build 11)
  • Line contours in the 2D Plan View may be incorrectly labelled with the label of the neighbouring contour.
    [NCR 7610] (Fixed 15 November 2012) (Released in Build 12)
  • If a “.pdt” or “.vdt” file, containing a list of other pdisp files for testing, is selected for batch testing, then the files listed must be in the folder from which the program is running, rather than wherever the “.pdt” or “.vdt” file is.
    [NCR 7850] (Fixed 12 February 2013) (Released in Build 13)
  • Pdisp may fail to combine imported displacement results in some instances when it should do for coincident points – though it correctly indicates in the Tabular Output those which have and have not been combined.
    [NCR 7904] (Fixed 12 March 2013) (Released in Build 13)
  • Soil Column Displacements graphs may be prevented for valid coordinates – the program incorrectly stating the coordinates have no soil profile.
    [NCR 7855] (Fixed 12 March 2013) (Released in Build 14)
  • Pdisp calculates displacements for points lying outside soil zones, without warning the user and clarifying which soil profiles are assumed.
    [NCR 7940] (Fixed 12 March 2013) (Released in Build 14)
  • Pdisp incorrectly allows calculations of displacements for locations (displacement data or load centres) which are above the top levels of their corresponding soil profiles.
    [NCR 7974] (Fixed 10 April 2013) (Released in Build 14)
  • Pdisp fails to include imported displacements in the Soil Column Displacements graph.
    [NCR 7975] (Fixed 11 April 2013) (Released in Build 14)
  • If a displacment line with coincident start and end coordinates is analysed, then Pdisp gives an “Out of Memory” warning, and Youngs Modulus units are subsequently corrupted e.g. by a conversion factor such as 1000.
    [NCR 7979] (Fixed 10 April 2013) (Released in Build 14)
  • The Soil Column Displacements menu option is missing from the program menu when the Tabular Output is active.
    [NCR 7981] (Fixed 10 April 2013) (Released in Build 14)
  • Pdisp needlessly informs the user that there are no data check warnings before performing an analysis. It should simply continue with the analysis.
    [NCR 7985] (Fixed 12 April 2013) (Released in Build 14)
  • Pdisp allows calculation of displacements for points outside soil zones (see NCR 7974) on “analysis” but does not allow it in soil column displacements.
    [NCR 7995] (Fixed 19 April 2013) (Released in Build 14)
  • Soil column displacement graphs are prevented for displacement points that clearly lie in soil zones and so should be allowed. The check on a point’s location may incorrectly report that the point lies outside all soil zones.
    [NCR 7996] (Fixed 16 April 2013) (Released in Build 14)
  • File->Export->CSV Results offers a check box to “Skip duplicate locations” if they occur. It appears not to work. Duplicate locations (e.g. if start of one line is coincident with the end of a previous line) are output anyway.
    [NCR 8004] (Fixed 17 April 2013) (Released in Build 14)
  • Pdisp may draw a displacement line in the plan view with its intermediate points’ crosses in the wrong places, offset from the line.
    [NCR 8008] (Fixed 18 April 2013) (Released in Build 14)
  • Repeatedly double-clicking the “Displacement Data” branch on the Gateway opens new table views of displacement data, rather than bringing the view that is already open to the foreground.
    [NCR 8321] (Fixed 23 August 2013) (Released in Build 17)
  • Pdisp may hang or crash if a displacement grid is specified with zero width.
    [NCR 8041] (Fixed 3 December 2013) (Released in Build 17)
  • Displacement data (or load data or soil profiles’) levels that are at or below the level of the horizontal rigid boundary level may cause the program to crash upon analysis.
    [NCR 8543] (Fixed 1 November 2013) (Released in Build 17)
  • Pdisp may calculate zero displacement if displacement points lie precisely at stratum interface levels.
    [NCR 8630] (Fixed 2 December 2013) (Released in Build 17)
  • Error and warning messages regarding the relationship in space between displacement locations, loads, and soil zones/profiles should be improved.
    [NCR 9048] (Fixed 5 June 2014) (Released in Build 18)
  • Checking for errors and warnings on analysis takes longer than necessary.
    [NCR 9071] (Fixed 5 June 2014) (Released in Build 18)
  • Strata should be entered into the soil profiles’ table in order of descending level. If they are not then Pdisp should prevent analysis, and warn the user to correct the data.
    [NCR 9137] (Fixed 26 June 2014} Released in Build 19)

New Features

  • Heave correction factor – A new Heave correction factor has been added to Mindlin method to prevent excessive displacements in cases where softer soil layers overlay stiffer soil layers.
  • Effect of Soil above load – When calculating the displacements below the load acting on horizontal plane, the user has the option to ignore the effect of soil above the load in calculations – both for normal and tangential loads.

Fixes

  • Displacement results are zero at some displacement points.
    [NCR 3308]
  • The maximum displacement difference between Boussinesq and Mindlin methods is not constant.
    [NCR 3309]
  • Pdisp may fail to display displacement grids that are extruded in the Global X direction.
    [NCR 3962]
  • XP look and feel missing in Pdisp 19.0.
    [NCR 4103]
  • Pdisp gives an out of memory exception if there is no soil zone.
    [NCR 4106]
  • The colour column in the Soil Profiles table displays RGB codes in grey colour in each of the cells.
    [NCR 4124]
  • Pdisp may give incorrect results if a low numbered record describes a load with a lower level than a higher numbered record in the load table.
    [NCR 4126]
  • Pdisp crashes if the displacement grid ends at the rigid boundary level.
    [NCR 4231]
  • Soil column displacement graph not closed when results deleted.
    [NCR 4236]
  • The 3D Graphics View may fail to display an image of the model, or display it offset beyond the limits of the window.
    [NCR4239]
  • Pdisp may fail to display the contour plot correctly in the Plan View.
    [NCR 4293]
  • The Plan View only shows grid results for grids extruded in the glolbal Y direction.
    [NCR 4378]
  • Analysis failed due to memory being run out.
    [NCR 4384]
  • Video link in the tutorials page does not function.
    [NCR 4432]
  • Possible error in condensed output view.
    [NCR 4487]
  • Printing out 3D Graphics view on to calculation-headed paper.
    [NCR 4515]
  • When soft soil overlies stiffer soil, Pdisp may overestimate the displacements in the soft soil if the load is in the stiff soil layer.
    [NCR 4576]
  • Pdisp fails to run and displays the warning “installation out of sync”.
    [NCR 4594]
  • Pdisp does not show horizontal loads, rotated at an angle, in the plan view.
    [NCR4631] (Fixed 18 October 2010) (Released in Build 3)
  • The 2D Plan View may compress the displayed model in the x or y directions to an inappopriately narrow width.
    [NCR 4925]
  • The program may fail to run.
    [NCR 4954]
  • Pdisp crashes when Legacy Mindlin option is selected.
    [NCR 5199] (Fixed 18 October 2010) (Released in Build 3)

New Features

  • Percentage unit (%) is missing from strain output table.
    [NCR 2377]
  • Deleting soil profiles does not update the drop list in the Soil Zones table.
    [NCR 2378]
  • Numerical format for display of input data in TableView is different from OutputView and can lead to misleading analyses.
    [NCR 2379]
  • Allows the user to enter a Youngs Modulus that varies through the thickness of the soil for a Mindlin analysis, though Mindlin analysis does not consider non-linear soil properties.
    [NCR 2380]
  • Soil layer with 0 kN/m2 Young’s Modulus is permitted but give erroneous results that fail to plot a plan of the settlements.
    [NCR 2381]
  • Recalculating the results whenever opening the tabular view of results .
    [NCR 2167]
  • Graphical input error while entering data.
    [NCR 2289]
  • Problem with deleting non-linear curves.
    [NCR 2384]
  • Inclined displacement lines(bottom-right to top-left ) drawn in graphical input seems not working properly .
    [NCR 2398]
  • 3D view is not ploting the data correctly if there are no soil zones.
    [NCR 2736]
  • Vdisp crashes if results are deleted with the Output View open.
    [NCR 3298]
  • Vdisp help file doesn�t describe the procedure to see line graph properly.
    [NCR 3531]
  • Line graph icon is disabled when there are no grid results.
    [NCR 2384]
  • The footer of the Output View shows a lone ‘\’ until the data file has been saved.
    [NCR 3607]
  • Unit of sum of principal stresses is incorrect.
    [NCR 3611]
  • Tabular output window and 3D graphics view not comming to front.
    [NCR 3612]
  • Line graph is having incorrect signage on the Y-axis.
    [NCR 3727]
  • Results are deleted if the colour of any soil layer is changed.
    [NCR 3780]
  • Help file isn’t mapped if “F1” key is clicked anywhere in the “Line Graph” view.
    [NCR 3811]
  • The 2D Plan View may compress the displayed model in the x or y directions to an inappopriately narrow width.
    [NCR 4925](Fixed 2 July 2010)(Released in Release 6)
  • The program may fail to run with the warning “The application has failed to start because its side-by-side configuration is incorrect…” or “This application has failed to start because the application configuration is incorrect…”.
    [NCR 4954](Fixed 9 July 2010)(Released in Release 7)

Fixes

  • An updated version of Mindlin’s method of analysis, which calculates horizontal displacements in addition to vertical displacements, has been added.
  • The user can now specify tangential and normal loads on horizontal and vertical planes./li>
  • A new soil column displacement graph has been added to view the displacement profile along a vertical line beneath a user defined point.

Require more information?

  • This field is for validation purposes and should be left unchanged.

Newsletter Sign up

Please fill out your details below to receive the latest oasys news.
  • This field is for validation purposes and should be left unchanged.