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1 1. Introduction 

 

1. Introduction 

 

Pdisp (Pressure Induced Displacement Analysis) calculates the displacements (and stresses if 

required) within a linear elastic or non-linear soil mass, arising from uniform normal or tangential 

pressure, applied to rectangular and circular loaded planes. The program is ideal for predicting the 

displacements that may arise due to the action of several loads in a soil mass. 

The outputs enable the user to study the settlements and stresses within the soils. The calculation 

itself is based on verified and robust numerical methods and the simplicity of design enables new 

users to set up and run an analysis easily 

The tutorial examples deal with practical loading applications but this Tutorial Manual is intended to 

familiarise the user with Pdisp. The examples should therefore not be used as a basis for practical 

projects. 

Users are expected to have a basic understanding of soil mechanics and geotechnical theory, and 

should be able to work in a Windows environment. The tutorial lessons are also available in the 

examples folder and can be used to check your results. 

It is important to realise that Pdisp is an advanced program analysing a complex problem and the 

user must be fully aware of the various methods of analysis, requirements and limitations discussed 

in the User Manual before use. The Tutorial Manual will not provide theoretical background 

information on the methods, nor does it explain the details of various methods of analysis available 

in the program. These details can be found in the User Manual for Pdisp. This also contains detailed 

information on the available program features.  

Short courses are also regularly organised and should you be interested in more hands-on 

experience you can contact oasys@arup.com for dates and program content. 
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2. Pdisp Analysis Methodology 
 

Two methods of analysis are available in Pdisp: 

• Boussinesq 

• Mindlin 

It is important that the user is familiar with both methods and their suitability to different types of 

analysis. The selection of analysis method also influences inputs such as the number of displacement 

points and the final outputs the user obtains from their analysis. 

Consequently, before using the program, read Sections 2.1 to 2.3 of the user manual to enable to 

you answer the questions below. 

Space has been left for you to write your answers for future reference. 

2.1 Boussinesq Analysis 

 

1. Stresses and strains are calculated in Pdisp using Boussinesq equations. How are 

displacements derived from these values? 
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2. What impact does decreasing the displacement intervals in a soil-strata have on the 

accuracy of the analysis? Why are displacement intervals important for the Boussinesq 

method? 

 

 

 

 

 

 

 

 

3. To calculate settlements and stresses below a small loaded area carrying a significant load 

accurately, what is the best vertical spacing of displacement levels close the load? 

 

 

 

4. If you apply a larger maximum allowable ratio between values of E at adjacent displacement 

levels, how does this affect the accuracy of the Boussinesq analysis? 

 

 

 

5. For loads below the ground level in which there is a sudden change in stress, how would you 

improve the accuracy of the Boussinesq solution? 

 

 

 

 

6. When selecting Global Poisson’s ratio for materials with very different elasticity, should you 

choose the higher or lower Poisson’s ratio and why? 
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2.2 Mindlin Analysis 

1. When starting a new analysis, would you use the Legacy Mindlin Method? Why? 

 

 

 

 

 

2. a. How would you model displacements above a load where there is a significant difference 

in stiffness between the soils below and above the load?  

 

 

 

 

 

 

 

 

 

 

b. Which heave correction factor should be used for a new analysis? 
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2.3 General 

1. Which analysis should be used if you are interested in horizontal displacements and 

why? 

 

 

 

2. Which analysis should be used if you need to calculate stresses and displacements in the 

soil? 

 

 

 

3. Which analysis is best if you are interested in accurately representing settlements above 

a load? 
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3. Pdisp Program Features 
 

The main features of Pdisp are summarised below. 

• Displacements are calculated using a profile of Young's modulus with depth. The modulus 

can be constant or vary linearly with depth for each soil layer. Non-linear stress/strain curves 

may also be specified. 

• Displacements and stresses can be calculated at several levels and at any location in plan. 

The location of the displacement/stress points is defined by means of two-dimensional 

orthogonal grids, by lines or by points. The results from the grids can be displayed 

graphically as contours. 

• Loaded areas can be defined as rectangles or circles. Pressures are applied as vertical and/ 

or horizontal uniformly distributed loads to rectangular and/or circular loaded areas. Areas 

can be superimposed and placed at any level. All loads are completely flexible i.e. no 

allowance is made for stiffness of the structures. 

• The base of the model is defined by the specification of an equivalent rigid boundary. 

• The ground is modelled using a series of vertical soil profiles each consisting of a number of 

horizontal soil layers. The plan distribution of the soil profiles is specified in rectangular 

areas known as soil zones. These can be superimposed allowing the development of 

complicated ground models. 
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4. Components of the Pdisp Interface 
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5. Loaded Soil Tutorial 
 

By the end of the session the user should be able to: 

• Navigate the Pdisp Interface 

• Input load data 

• Input displacement data 

• Input soil data, including non-linear curves 

• Run an analysis 

• Navigate the Graphical Output 

• Create simple graphs 

• Export tabular outputs for further analysis 

• Export contours for dxf drawings 
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5.1 Creating the Input 

 

 Once opened, create a new file by clicking the ‘New File’ icon on the top left of the program 

 or clicking Ctrl + N 

1. Double click on Titles in the Gateway and fill in the dialog box: 

 

(Hint: Should the user need to change the Units, they should do so at this point by double 

clicking on Units in the Gateway) 

 

  



10 5. Loaded Soil Tutorial 

 

10 | 

 

2. Double click on Analysis Options in the Gateway.  

 

Select the following: 

 

 

(Note: The horizontal rigid boundary level sets the base of the analysis as where there is no 

settlement. This is often specified as the level of bedrock) 
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3. Double click on Soil Profiles in the Gateway 

 

Enter the data shown in the diagram on the following page for Soil Profiles 1 and 2. 

New soil profiles can be entered using the Add Soil Profile tab at the bottom of the table. 

 

Poisson’s ratio is 0.25 for all the soil strata. 

 

For each soil strata, specify displacement calculation points at every 0.5m using appropriate 

values for the Number of intermediate displacement levels. 

 

(Hint: Use section 3.2.3 of the User Manual to help you understand the required inputs) 
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 An example for Soil Profile 1 is shown below: 
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4. Double click on Soil Zones in the Gateway 

 

Enter data for the soil zones shown in the diagram below for Soil Zones 1 and 2. 
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5. Double click on Load Data on the Gateway. 

 

Enter the loads shown in the diagram below. 

 

 

The loads are: 

• Load 1 = 60 kN/m2 

• Load 2 = 70 kN/m2 

• Load 3 = 50 kN/m2 

 

Circle radius = 45m 

Represent the circular load with 7 rectangles. 

An odd number of rectangles is always specified due to the geometry of representing a circle 

using rectangles.  

 

(Hint: Check the input is correct using the Graphical Input window, accessible through the 

Gateway) 
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6. Double click on Displacement Data in the Gateway. 

 

Enter the displacement lines and grid shown in the diagram below. 

 

The grids have 10 extrusion intervals and the lines have 7 extrusion intervals. 

 

Try inputting the Grids in the Global X and Global Y direction to better understand the 

process. 

 

(Hint: Use Section 3.2.6 of the User Manual to assist you with the inputs) 
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7. Double click on Graphical Input in the Gateway to check the load, displacement grid and 

displacement line geometry. 
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5.1.1 Non-linear curves 

 

1. Using the following description, derive the non-linear curve from the data below. 

 

Strain 

(%) 

Non Linear Stress (kPa) Equivalent Non Linear Stress (kPa) 

0.0247 0 0 

0.0798 0.000822126 0.003546703 

0.8348 0.723993197 3.735775008 

22.88 72.89719626 421.3710767 

94.16 300 1734.104046 

 

 

 

 

 

2. Double click on Non-Linear Curves in the Gateway 

 

Click on the tab titled Add Curve on the top right of the table. 

 

Choose the linear option at the base of the curve. 

 

Create the curve from the values derived at Stage 1. The expected curve and values are 

shown on the following page. 
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(Note: The user can also approximate the curve by clicking points on the graph using their 

mouse) 

 

3. Double click on Soil Profiles in the Gateway. 

 

Assign the non-linear curve to Soil Stratum 2 in Soil Profile 2. 
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5.2 Analysis and Output 

1. Prior to analysis, check all inputs and save the file. 

 Click on the analyse button to carry out the analysis 

2. The data check window will automatically appear. Select Proceed. 

 

 

 

3. The following window will appear showing the difference between the Mindlin and 

Boussinesq results. 

 

 

 

Note: 

There is a significant difference between the Mindlin and Boussinesq methods because: 

a) This analysis involves non-linear soils, which are not considered in a Mindlin 

analysis. 

b) This analysis involves loads below the surface, which is not represented as 

accurately using the Boussinesq method 

The point at which the greatest difference occurs is where the loads below the surface 

intersect. This is as expected due to the differences in the methods for loads acting below 

the surface. 
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4. The Page Setup window will appear. Select all the options to view the results and inputs in 

the Tabular Output. 

 

 

 

5.2.1 Tabular Output 

 

1. View the Tabular Output. 

What is the vertical stress and displacement at: 

a. The centre of each load 

b. -64, 39, 0 

c. -64, 30, 3 

d. -70, -80, 0 

Hint: 

Section 4.2 of the User Manual outlines where displacements and stresses are shown in the 

Tabular Output. 

The points listed are shown on the displacement grids. A quicker way to find these 

displacements would be to enter displacement points in the Displacement Data input table. 

 

2. Choose File > Export > Tabular Output 

 

3. Save the file with a .csv extension and open the Excel file. 
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5.2.2 Plan View 

 

Double click on Plan in the Output section of the Gateway 

 

Line Graph 

 Click on the Line Graph icon. 

 

1. Hover the mouse over Line 1 and left click to plot the displacements over the line. 

 

 Note: 

 To plot more points in the graph, amend the Displacement Data input table by adding more 

intervals to the displacement line. 

 

It is advised that the distance between points on the line should be less than the width of 

the loads to depict settlements accurately. 
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2. Right click on the graph. 

The following options will appear: 

 

 

3. Explore the different options to amend the graph view, appearance and to save the graph. 

Use Chart Style to label axes. 
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Contours 

 Select the Contours icon. View the line contours for Grid 1. 

1. Choose Graphics > Grid Results > Set Contour Interval and set the contour interval to 

10mm. 

 

 

The following view will show. 

 

 

2. Toggle between grid results by using the Grid Up and Grid Down icons ( ) 

 Show settlement at specific points using the Annotate icon. 
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 Select the Fill Contour icon to view the filled contours: 

 

 

Note: 

Assess the impact of changing the number of intervals in the Grids on the contour output: 

a) Use File > Save As to save a test file 

b) Change the grid intervals in the x and y direction to 3 to assess the impact of 

decreasing the grid intervals on the output file. 

c) Change the grid intervals in the x and y direction to 30 to assess the impact of 

increasing the grid intervals on the output file. 

Having looked at the file, it is evident that the file with fewer intervals does not show 

maximum values for settlement.  

 

If the grid interval produces distances between grid points which are larger than the width of 

the load, the grid points may not pick up the point of largest settlement. 
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Exporting Contours 

1. Go to File > Export > CSV Results File 

2. Choose the following option to output the contours and select OK: 

 

 

(Note: X and Y settlements are not shown as these are not calculated for the Boussinesq 

method) 

 

3. Save the csv file and review the outputs.  

 

(Note: Section 4.4 of the User Manual will explain how the csv results file could be 

interpreted for a CAD drawing.) 
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5.2.3 Cross Section 

 

1. Double click on Cross Section in the Output section of the Gateway 

2. Use the toolbar to view the loads in relation to the soil stratigraphy. 

 

Toolbar: 

 

 

View: 
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5.2.4 Graphical Output 

 

1. Double click on 3D Graphics View in the Output section of the Gateway 

 Select the Wizard icon or right click on the view and select Settings Wizard 

2. Choose the appropriate options to get the following graphical view: 

 

 

Hint:  

Selecting the Wire Frame grid on the Soil property page allows the user to view loads and 

contours. 

The outputs include the deflected displacement line and line contours of settlements 
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5.2.5 Soil Column Displacement 

 

1. Double click on Soil Column Displacement in the Output section of the Gateway 

2. Choose to view the displacement at point (20, 0) in plan. 
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5.2.6 Printing Outputs 

 

1. Select Tools > Preferences 

2. Apply your company details 

 

 

3. View your output using Print Preview 
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6. Graphical Input Tutorial 

 

By the end of the session the user should be able to: 

• Input background bitmaps to inputs  

• Graphically input loads, soil zones and displacement points 

• Run a Mindlin analysis 
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3.1  Analysis Description 

 

The following is a scaled drawing of a building with column loadings at surface level (10mOD) and 

the path of an underground train tunnel below the building (crest at z=5mOD).  

 

The building is due to be demolished and the Asset Owners require prediction of the actual and 

differential settlements that will occur at the crest of the tunnel. 

 

 

 

 

  

Soil Zone 1 – Soil Profile 1 Soil Zone 2 – Soil Profile 2 
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3.2 Graphical Input 

1. Start a new Pdisp file 

 

2. Fill the Titles and Units section 

 

3. Complete the Analysis Parameters section as follows: 

 

 

(Note: The legacy correction factor has not been chosen as the program defaults to the new 

correction factor, which is outlined in Section 2.3.2 of the User Manual) 
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4. Enter Soil Profiles as shown below: 

Soil Profile 1 

 

 

Soil Profile 2 
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5. Double click on Graphical Input in the Gateway 

 Click on the bitmap icon and insert Graphical Input.bmp to the scale shown in Section 3.1. 

 

  

6. Zoom into the area around the image by left clicking and pulling a window around it. 

 Click on the Soil Zones icon to plot Soil Zone 1 and Soil Zone 2. 

 Check the Soil Zones table to adjust the co-ordinates if necessary 

 Use the Displacement Line icon to draw the line along the path of the tunnel. Specify the 

level in accordance with Section 3.1. 

Select the best interval for the displacement line, remembering that the load width is 2m. 
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 Use the Load icon to input the loads as shown in the diagram. Specify the level in accordance 

with Section 3.1.  

 (Hint: Consider modelling demolition loads, which act in the negative direction.) 
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 Use the Grid icon to create a surface grid around the building with suitable intervals. 
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3.3 Analysis and Outputs 

 

1. Check all the inputs and save 

 

2. Run the analysis 

 

3. Determine the following from your analysis: 

a. Maximum settlement and point of maximum settlement along the crest of the 

underground line 

 

b. Maximum gradient of settlement along the underground line 

 

c. Maximum settlement occurring at the surface of the demolition 

 

d. Maximum settlement at a point occurring 5m from the boundary of the building 

 

e. Maximum x and y displacements occurring at the surface of the demolition 

 

 

 

4. Produce the following line graph from your analysis: 
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5. Produce the following Graphical Output for your analysis: 

  

 (Hint: The Output shows the deflected displacement grid and displacement line) 


