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Improved Window Positioning
Window “Common Border” Dragging



Window “Common Border” dragging: introduction

When there are multiple windows on a page, it is now possible to change their position and size 
in a coordinated way. Windows that share a common border now “know about” their neighbours 
and it is possible to resize all windows sharing that border.

For example:



Window “Common Border” dragging: two windows case

To give flexibility about what is dragged, different regions of borders perform different functions 
and are colour-coded to distinguish them.

To drag just the single border between two windows, use the central pink zone:



Window “Common Border” dragging: single axis case

To drag the entire single border axis in a given direction between all windows which share that 
border, use the blue zone (intermediate between centre and corners): 



Window “Common Border” dragging: both axes case

To drag both horizontal and vertical borders between all windows which share those borders, use 
the green zone (at the corners):



Window “Snap to grid”

Repositioning a window by dragging it used to move just 
that window and left it “floating” in its new position. When 
there are multiple windows on a page, these now occupy a 
grid of locations and it is possible to move a window from 
one cell to another, shifting the existing windows up and 
down as required.

1. In the top image W4 in the bottom right corner being 
dragged up and to the left.

2. When the cursor enters W1 its borders light up in blue 
to show it is the destination window.

3. On mouse release W4 “snaps” to W1’s position and 
windows W1 to W3 shuffle down to make space.



Improved Window Positioning
Changes to Window Layout



Changes to Window Layout Menu – Basic Mode

In D3PLOT and T/HIS 19.0, the Window Layout menu has changed 
and has been split into separate Basic and Advanced modes.  

In Basic mode, the menu can be used to select a page layout that is 
automatically applied to all of the pages.  

Automatic Page Layout

If the layout is set to “Tile Wide” or “Tile Tall” then all windows are 
automatically added to page 1.

In all other layouts Windows are automatically added to pages and 
as many pages as needed are created to hold all the windows.



Changes to Window Layout Menu – Basic Mode

Window Order (drag to reorder)

By default, Windows are added to pages in the order they are 
created.

The order of Windows can 
be changed by clicking on a 
row and dragging it up or 
down the list to a new 
position.



Right-clicking on an << Add item >> row will display a popup menu 
that can be used to select any Windows currently on the desktop.

In a Linked D3PLOT → T/HIS session, this menu will also display any 
T/HIS graphs that are currently docked inside D3PLOT windows so 
that they can be added back onto a page.

Changes to Window Layout Menu – Basic Mode

Any Windows that have been dragged out onto the desktop are 
removed from the list (Windows 3 and 4 in this example).

If Windows are on the desktop, the menu will display additional rows 
that can be used to add the windows back into the list so that they 
are displayed on a page again.



Changes to Window Layout Menu – Advanced Mode

Advanced mode works in a similar way to Basic mode except that it 
controls the settings for the current page only.

In Advanced mode, the layout and content of each page can be set 
for that page and the order of the items displayed on each page 
can also be controlled by clicking on an item and dragging it up or 
down to a new position.



Changes to Window Layout Menu – Advanced Mode

If a page has room for additional Windows to be added to it then 
the menu will display additional rows with the first empty row 
showing << Add item >>.

Right-clicking on << Add item >> 
will display a popup menu that 
can be used to select any Window 
that is not currently on the page.



Changes to Window Layout Menu – Advanced Mode

Right-clicking on a row containing a Window will display a popup 
menu that can be used to remove the Window from the current 
page.

Alternatively, the same popup can also be used to change an item 
to a different D3PLOT Window or T/HIS graph that is not already on 
the current page.



Changes to Window Layout Menu – Advanced Mode

In Advanced mode, the All Pages… button can be used to display a 
separate menu that shows the layout and contents of all pages:



Changes to Window Layout Menu – Advanced Mode

This menu allows the layout 
and contents of each page 
to be individually changed.

The options to reorder or 
change the contents of each 
page are similar to those in 
the Window Order section 
of the Layout menu:
• Drag the buttons in each 

column up and down to 
reorder windows and 
graphs on a page

• Use the popup menus to 
edit page contents



New Data Components



Yield Utilisation Factor and Yield Utilisation Percentage 

• New components Yield Utilisation Factor and 

Yield Utilisation Percentage have been added.

• Available for elements which output a stress 

tensor:

• Solid / Shell / Thick Shell / SPH / DES

• Yield Utilisation Factor:

• Von Mises Stress / Yield Stress

• Yield Utilisation Percentage:

• Von Mises Stress / Yield Stress * 100



Extra history variables for *MAT_280 (*MAT_GLASS)

• Support has been added for new extra history variables for *MAT_280 (*MAT_GLASS).

• If your results directory contains a valid ZTF file written from PRIMER, the new variables can be 

accessed from the Material Properties category in the Data Component menu:

Material number/name Data slot Variable name Description Element type

MAT_280 *MAT_GLASS 1 CRACK_FLAG Crack flag Shell

MAT_280 *MAT_GLASS 2 PRINCIPAL_STRESS_1_DIRECTION Direction of first principal stress Shell

MAT_280 *MAT_GLASS 3 CRACK_DIRECTION_2 Second crack direction Shell

MAT_280 *MAT_GLASS 4 FAILURE_CRITERION_VALUE Failure criterion value Shell

MAT_280 *MAT_GLASS 7 CURRENT_TENSILE_STRENGTH Current tensile strength Shell

MAT_280 *MAT_GLASS 8 CURRENT_STRAIN_RATE Current strain rate Shell

MAT_280 *MAT_GLASS 9 CRACK_OPENING_DISPLACEMENT Crack opening displacement Shell



Cut Sections



Multiple cut plane directions

• Cut planes can 

now be defined in 

up to 3 non-

parallel directions.

• The example on 

the right shows 

two orthogonal 

planes intersecting 

a vehicle model.



Parallel cuts with multiple directions

• Multiple directions 

can be combined 

with multiple 

parallel planes in 

one or more 

directions.



Thick cut in first direction

• Thick cuts can be 

turned on for the 

first plane 

direction to draw 

the union of that 

thick cut with a 

thin cut.



Multiple parallel thick cuts in first direction

• Thick cuts can still 

be turned into 

multiple parallel 

thick cuts when 

more than one 

plane direction is 

active.



Combination of thick cuts and multiple parallel cuts

• This example 

shows thick cuts in 

the first plane 

directions and 

multiple parallel 

cuts in both 

directions.



D3PLOT Viewer Export



True Beam Section Export

• Beams have been able to be drawn with 

true sections in D3PLOT for some time

• In D3PLOT 18, beams were exported to 

D3PLOT Viewer as lines only

• Now, if beam true sections are switched 

on in D3PLOT, the true sections will be 

exported to D3PLOT Viewer



True Beam Section Export

• Beam elements exported with true 

sections are displayed in D3PLOT Viewer 

with true sections

• True beam sections cannot be switched 

off in D3PLOT Viewer

• Exporting true beam sections will result 

in larger files than exporting beams as 

lines



Colour



User colour updates

All entities can now be assigned colours By Include 

and By Model.

Setting part and element colour By Material, By 

Section and By Assembly is now available on the 

following menus:

• Properties panel

• Quick Pick

• Part Tree



Target marker colours

• Colours for target markers can now be selected from the colour palette:



Changes To Screen Selection



Changes To Screen Selection

The interactive screen selection of Entities has been updated to improve its performance 

and to add new features.

In Quick Pick, the selection mode can now 

be switched between 3 different options 

using the         button.

Drag out a rectangular area  (Default)

Drag out a circular area 

Select items within a polygon C : Close the Polygon

R : Reject Last Point

X : Abort Polygon and Restart



Changes To Screen Selection

In previous versions of D3PLOT, predictive picking only 

worked for Quick Pick, Blanking, Write and XY-Data. Now, 

predictive picking has been enabled for all menus.   



Changes To Screen Selection

It is now also easier to select items such as X-Sections when 

the centroid of the cross section is hidden inside a structure 

or within a block of solids:



Propagating Blanking



Propagating Blanking from Propagate Properties Popup

• In previous versions of D3PLOT, when blanking was 

propagated using the Properties Panel, entities 

blanked in any window would be blanked in all 

windows.

• Now, the Propagate Properties popup allows you to 

specify both the model and the window to propagate 

blanking from.



Propagating Blanking from Window Popup

• The popup menu accessible from the 

windows option button now contains 

options for:

• Blanking ==> Mn to propagate the 

blanking of the selected model in this 

window to the same model(s) in all active 

windows

• Blanking ==> All Models to propagate 

the blanking of the selected model to all 

models in all active windows



Propagating Blanking from Quick-Pick Popup and Export Menu

• The same blanking propagation options 

that are available in the windows option 

popup menu are also available in the 

following menus:

• Quick-pick popup menu accessible from 

right-clicking on a model (but not in the 

drop-down above the graphics area)

• Export menu accessible from shortcut key 

“E” or by right-clicking in a blank part of a 

window

B

B

Right-click away from 
model to launch 

Export Menu

Right-click on model 
to launch Quick-Pick 

popup



REPORTER Integration



Automatic update of DEFAULT_DIR and DEFAULT_JOB

If you open REPORTER from D3PLOT or 

T/HIS and capture an item, the values 

of DEFAULT_DIR and DEFAULT_JOB are 

now automatically updated to match 

the current model in D3PLOT or T/HIS 

(previously you would have had to edit 

the hardwired filenames manually). 

This makes it easier to set up your 

template to run for different models.In REPORTER, job uses variables automatically

Model file path and filename from D3PLOT automatically

Capture item from D3PLOT



User-Defined Data



User-Defined Binary (Ubin) Data

• Ubin data is stored in the same directory as the D3PLOT input files by default, but can 

also be stored in a location specified by the d3plot*ubd_file_location preference

• If Ubin data is identified in both locations, D3PLOT will now read files from both 

locations and create all the required user-defined data components

• In the case where a component of the same name exists in a file in both locations, the 

component found in the model directory will be ignored in favour of the one in the 

preference location

• A warning is printed to the dialogue window when this happens so that it is clear 

which data will be plotted

• You can learn more about User-Defined Data in this webinar

https://www.oasys-software.com/dyna/training/webinars/oasys-post-user-defined-components/


JavaScript



Memory use in JaDe

• The JavaScript debugger now shows 
how much garbage collection 
memory is being used by a script.



console API

• The JavaScript engine now implements the console API (as specified in 
https://console.spec.whatwg.org) so functions such as console.log(), console.warn() 
etc are now usable.

• Output is sent to the console window on Windows and the terminal window on 
Linux.

https://console.spec.whatwg.org/


Other JS API changes

• The special encoding comment at the beginning of a script now supports Shift-JIS as 
an encoding.

• ECMAScript 6 Modules are now supported in D3PLOT. Both static and dynamic 
imports are supported.

• A new function Colour.GetFromName has been added to return a colour value 
(integer) for a core colour or user colour from its name.



Menus



Data component popups

There is a new preference d3plot*show_all_components. 

When this is set to TRUE, the data component popup appears in 

the same way as the Data menu in Write and XY Data. 

Unavailable components will be greyed out rather than omitted. 

This is useful for automatic processes relying on the position of 

buttons on the popup – for example, in the playback of 

command files.



File skip for loading results files

• The default file skip value was changed from 5 to 50 

to read, by default, analyses with more intermediate 

result files removed, e.g., when a subset of results 

has been transferred to a local drive

• This value determines the maximum permitted gap 

in a file family (e.g., <name>.ptf, <name>.ptf01, 

<name>.ptf02 for the Arup naming convention; the 

extension would be .d3plot for the standard LS-

DYNA naming convention) that D3PLOT will check 

before it decides it has reached the end

• A new preference d3plot*file_skip which allows 

users to change this default value was also added



Attached – Recursive option

If set, the Recursive option in Tools → Attached will now be switched off automatically 

at the completion of an Attached operation. This behaviour is consistent with the 

Attached tool in PRIMER.

1

2

3



Search Box

• Search options can be controlled from Utilities → Search Opts

v18 v19

• Previous versions of D3PLOT included a Quick Find button which has now been made 
more prominent in the form of a search box located on the top bar. 

• The existing keyboard shortcut (#) can still be used too.



Contact Information

UK

T: +44 121 213 3399

dyna.support@arup.com

For more information please contact us:

www.arup.com/dyna

China

T: +86 21 3118 8875

china.support@arup.com

India

T: +91 40 69019797 / 98 

india.support@arup.com

USA West

T: +1 415 940 0959

us.support@arup.com

or your local Oasys distributor 

mailto:dyna.support@arup.com
mailto:china.support@arup.com
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