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• Data is read from LS-DYNA output files and is stored in T/HIS as 
curves. Each curve is a series of XY points, usually data-vs-time. 

• Curves may also be read from other sources: csv file, T/HIS curve 
file (*.cur), *DEFINE_CURVEs from a keyword input file, or by typing 
in at the Keyboard. 

• Curves may then be operated on, e.g 
– Filtering (Automotive menu) 
– Adding, multiplying, etc by constants 
– Adding, multiplying, etc curves to each other 
– Combining X-vs-time with Y-vs-time to obtain X-vs-Y 
– Many others: see Operate, Maths, Automotive menus 

• Many options for changing the appearance of graphs (available by 
right-clicking the curve itself, or the axis; also from menus) 

• Curves may be written to T/HIS .cur file or csv file 
• T/HIS may be run stand-alone or within D3PLOT to synchronise with 

animations. 

Principles of T/HIS 
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Top menus 

User Interface 
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Tools menu 

User Interface 
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Active function 
window 

User Interface 



LS-DYNA ENVIRONMENT 

[back to contents] 

User Interface 

Dynamic viewing is available, as in D3PLOT 
and PRIMER.  

SHIFT+Middle Mouse button = Pan 

SHIFT+Right mouse button = Zoom 
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• To read LS-Dyna output, browse for the 
results files and select any one file from 
the required model (e.g. if using LSTC 
filenames, d3thdt, glstat, etc) 

• All time history results files for that 
model will be loaded automatically when 
you press ‘Apply’, unless you first un-
check the box for any particular results 
file. 

• Don’t forget to press “Apply”! 

Can de-select any 
particular output file 

Reading LS-DYNA results 
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The entity types for which 
time-history data is 

available are shown by the 
green buttons.  

Press one of these to 
make the data component 
menu and entity selection 

menu appear. 

Reading LS-DYNA results 
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Click the data component. 
To select more than one 

component, SHIFT-click or 
CTRL-click 

Click the entities. 
To select more 

than one, click on 
several, or SHIFT-

click 

After selecting 
data components 
and entities, press 
Apply to read the 

data into T/HIS 
and make the 
graph appear. 

Reading LS-DYNA results 
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• Many types of time-history data are 
available from more than one output file.  

• The Settings menu defines which file to 
read first for each data type. 

• The XTF file is not available for MPP 
LS-DYNA. It is recommended to use the 
LSDA (Binout) file instead. 

• This menu affects the current session of 
T/HIS. Alternatively, these may be set in 
the Preferences (under Data Sources) 
for future use. 

• Other settings (e.g. automatic 
regularisation before filtering) are 
accessible through ‘Other’ 
 

Right click to select 
file type  

• Note: THF = job.thf or d3thdt 

Reading LS-DYNA results 
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• T/HIS can keep several models open, and 
read data from them in one operation  

• “Select Models” controls which models are 
available for reading data and identifies each 
model by title or by directory 
 
 

Hover over text to see 
full directory / title  

Change listing to 
‘Model Titles’ or 

‘Directories’  

Object list includes 
model ID  

Fainter colour: not 
all models have 

this data  

Working with multiple models 
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• To open multiple models, EITHER use the 
“New Model” button to open models one at a 
time… 
 
 

Browse for 
model 

Working with multiple models 
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• …Or load all models contained in a 
directory and any subdirectories in 
a single operation 

Option to deselect 
models – default is 
to read all models 

found below the root 
directory 

Select root directory 

Option to deselect 
result file types 

Find models from directory 
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• Filter entities by model through ‘Model Manager’ 
when reading data from LS-DYNA results files 
 

Select active models 
to filter listings 

Selecting data from multiple models 
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Common IDs – show 
entities that are 

present in all 
models; select 

entities from the list 
to read data from all 

models Can sort by 
ID then by 

model 

• Different listing options are available for object list: 

Default: 
entities are 

ordered first 
by model, 
then by ID 

Selecting data from multiple models 
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• CSV (Excel-compatible) files may take 
one of the following formats: 
– X,Y,Y,Y: the x-axis values are in the first 

column 
– X,Y,X,Y,X,Y: the x-axis values are given 

separately for each curve, with the 
columns in X,Y pairs 

– X-axis values may be absent, in which 
case T/HIS can generate them at a 
constant user-specified interval 

• Press READ to read in the file 

Reading data from other sources 
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Control of curve 
blanking from 
drop-down 
menu 

Or click on 
individual 
red/green 
buttons 
(red=blanked). 
To blank a 
range of 
curves, click 
the first, shift-
click the last 

Curve Manager 
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Use drop-down 
menu to delete 
selected curves. 
Condense then 
removes gaps left 
by the deleted 
curves. 

Curve manager can 
also be used to 
change curve “line 
labels” 

Curve Manager 
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• Options are available for sorting the curves in the 
curve menu – this can help with blanking etc. 

• The sorting options selected here also apply to 
curve lists, e.g. in the Operate menu. 

• E.g. sort by Entity ID then by Component then by 
Model 

Curve Manager - Sorting curves 
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The 
highlighted 
curves will 
be changed  

After 
selecting 
colour/style 
etc, press 
Apply.   

Curve Manager – Curve styles 

• The appearance of curves can be changed using the curve style menu. 
This menu can be activated by either clinking on the Style button in the 
curve manager or from the top menu. 
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• T/HIS has 30 pre-defined colours. 
• 6 user defined colours can be created 

via the oa_pref preference file. 
 

Curve style 

• Different symbols can be 
used to mark points: 

• Different line widths: 

• Different line styles: 
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Curve Manager – Curve styles 

• Curve styles can be applied to groups of curves.  

Create the group.   

Choose the curves to add 
to the group. 

Show the groups and 
apply the style. 

• Styles can also be applied by model. 
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• By default, T/HIS identifies the model 
from which each curve originates 
using M1, M2, M3… 

• The identity of M1, M2, M3 etc can be 
found from the Models menu… 

Curve Manager - Model prefix 
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• The prefix can be changed to show 
the subdirectory containing each 
model,  

• Another alternative is to use the root 
name of the THF file, e.g. base.thf 

Curve Manager - Model Prefix 
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• To type in model prefixes for 
the User Defined option, use 
the Model menu, click on the 
model, type in the prefix.  

Curve Manager - Model Prefix 
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• Model prefixes can be turned 
off here. 

• “Automatic” means show 
model prefixes only when 
multiple models are present. 

• The prefix format may be set 
by a preference 
(prefix_format)  

Curve Manager - Model Prefix 
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Graph Properties 

• The appearance of each graph can be 
modified using the Display menu and the 
Title/Axes menu. 
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Automatic 

Scientific 

General 

Axis values can be displayed using 3 
different  formats, Automatic Scientific 
and General. 

In Automatic mode T/HIS only uses E3, 
E6, E9 etc. 

Graph Properties – Axis and Legend 
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The number of decimal places displayed 
can be set between 0 and 9. 

Graph Properties – Axis and Legend 
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Graph Properties – Axis and Legend 

Graph Legend can now be 
positioned anywhere using 

the “Floating” option 

Can also access this menu 
by right-click on legend 

Legend can be dragged to 
position or resize 

Default 

Floating 
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Click on legend 
border and drag to 

resize 

Click inside legend and 
drag to reposition 

Graph Properties - Floating legend Graph Properties – Axis and Legend 

r 

• The size and position of a “floating” legend can be modified interactively 
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Graph Properties – Axis and Legend 

• Other legend types: 

Full 

Auto 
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Click on graph border 
and drag to resize 

Graph Properties – Axis and Legend 

• The position of a each axis can also be modified interactively 
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• The axis and 
legend menus 
can also be 
accessed by 
clicking on either 
an axis or within 
the legend area. 

Graph Properties – Axis and Legend 
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Multiple graphs 

• T/HIS can contain up to 32 separate graphs. 
• These graphs can be arranged in any combination on up 

to 32 pages. 
• The contents and display of each graph can be controlled 

either individually or changes can be applied to multiple 
graphs.  
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Multiple graphs 

 

To create a new graph, 
shortcut G 

Make each graph 
active/inactive (e.g. when 
reading new data) using the 
blue buttons G1, G2, etc  

Curve=>Table to control which 
curves appear in which graph 

Graph=>Layout to select 1 
graph per page, 2x2, etc 

Use Page Number controls or 
Page up, Page down buttons  
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The initial display 
and axis settings for 
new graphs can be 

copied from 3 
possible sources. 

Multiple graphs 
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Make each graph active 
or inactive: only the 

active graphs respond 
to menu commands 

e.g. reverse 
background/foreground 

Multiple graphs 
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To control which 
curves appear in 

which graphs, use 
the Table menu from 
the Curves menu… 

Multiple graphs 
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… or make the required 
graph(s) active when 

reading the data. 

Multiple graphs 
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Use Graphs=>Options 
to change the layout of 

the graphs.  

Multiple graphs 
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Multiple graphs 
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Multiple graphs 



LS-DYNA ENVIRONMENT 

[back to contents] 

If you have more graphs 
than will fit in the requested 

layout, T/HIS can arrange  
the graphs on multiple 

“pages”.  

Multiple graphs 
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Multiple graphs 
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Different “pages” can 
easily be selected using 

either the Global 
Commands Menu or Page 

Up, Page Down, Home 
and End shortcut keys  

Multiple graphs 



LS-DYNA ENVIRONMENT 

[back to contents] 

The Quick-Pick menu can 
be used to apply 

functions, edit curves or  
change the appearance of 

curves. 

Quick-pick 
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Right-Click on a curve to  
display basic curve 

information or to apply a 
different option. 

Left-Click on curve to 
apply current option 

Quick-pick 
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Left-Click and drag to 
apply the current 

operation to multiple 
curves 

Right-Click and drag to 
apply a different option to 

multiple curves. 

Quick-pick - Multiple Curves 
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All of the functions 
available from the Quick-

Pick menu generate a 
single output curve. 

The output can be set to 
either generate a new 

curve or to overwrite the 
input curve  

Quick-pick - Functions 
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Curve Operations 

• T/HIS contains over 80 functions for 
manipulating curve data.  

• Functions are divided into 4 main 
categories: Operate, Maths, 
Automotive and Seismic. 

When a category has been 
selected you can hover over a 

button for a longer 
description 
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Curve Operations – Operate 

• The Operate menu contains a 
number of general functions. 

• Basic functions include adding, 
subtracting, multiplying and dividing 
curves by either constants or other 
curves.  Other options include 
integration, differentiation and 
normalisation. 

• More advanced functions include the 
vector magnitude of 2 or 3 
components, summation of multiple 
curves and the minimum/maximum 
of multiple curves. 



LS-DYNA ENVIRONMENT 

[back to contents] 

Curve Operations – Automotive 

• The Automotive menu contains a 
number of filtering options and injury 
criteria . 
– SAE C60, C180, C600, C1000 filters 
– Butterworth and FIR filters 
– Head Injury Criteria (HIC) 
– 3ms Clip 
– Viscous Criteria 
– Theoretical Head Impact Velocity 
– Neck Injury Criteria 
– Thoracic Trauma Index 
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Curve Operations – Maths / Seismic 

• The Maths menu contains a number 
of standard mathematical functions . 
– Square Root, Ln, Exponential, Log 
– SIN, COS, TAN, ASIN, ACOS, ATAN 
 

• The Seismic menu can used to 
handle response spectra information. 
In particular, displacement, velocity 
or acceleration spectra can be read 
and converted to another format. 



LS-DYNA ENVIRONMENT 

[back to contents] 

• Operations requiring one curve input,  
• e.g. clip(A) => B. 
• A (“Group 1”) can be one or many curves. 

Click on the curves in the list, or use Pick 
Visible then Done to terminate picking.  

• If the operation requires constants, these are 
typed in the text boxes. 

• One output curve is produced from each input 
curve.  

Curve Operations 
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• Operations requiring two inputs,  
• e.g. Multiply A x B = C 
• A (“Group 1”) can be one or many curves. 

Click on the curves in the list or use Pick 
Visible (and press Done to terminate picking). 
Say Group 1 contains N curves. 

• B (“Group 2”) can be  
– Constant: key in the value. Each curve in Group 

1 will be multiplied by the constant, producing N 
output curves. 

– One curve. Each curve in Group 1 will be 
multiplied by this curve (the y-values at each x-
point are multiplied together), producing N 
output curves.  

– N curves. The first curve in A is multiplied by the 
first curve in B, the second by the second, etc, 
resulting in N output curves. 

Curve Operations 
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This behaviour 
can be 

changed, as 
shown 

Curve Operations 

• By default, both input and output curves are 
kept; the output curve has the same colour and 
style as the input curve. Example shown here 
after C180 filter. 
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Curve Picking is automatically 
activated to select input curves 

for functions 

Curve Operations – Selecting Curves 
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Curves are highlighted as they 
are picked 

Curve Operations – Selecting Curves 
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Shortcut key “V” toggles between 
curve picking groups.  

“Q” swaps back to “Quick-pick” 

Curve Operations – Selecting Curves 
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Curve Operations – Curve Groups 

• Groups of curves used to apply the 
same style, operations or blanking 
to multiple curves. 

• Use Tools=>Groups=>Create to 
create groups. 

• From Curves menu, right-click on 
Blank to Blank (or Unblank) by 
groups. 
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Curve Operations – Curve Groups 

• In menus in which 
curves are selected 
(Operate, Style, Write, 
etc), toggle between 
selection by curves or 
by groups. 

• Clicking on a group 
selects all the curves 
in that group. 

• Groups are saved in 
FAST-TCF scripts.  
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Operations 
that require 

only one input 
and no 

constants may 
be performed 

by right-
clicking the 

curve. 

Curve Operations – Using Quick-Pick 
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The “overwrite 
input” setting is 

also available 
from here, so the 
original curve will 

automatically 
disappear. 

Curve Operations – Using Quick-Pick 
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Curve editing 

• In addition to the standard edit menu 
curves can be edited interactively. 
 

• When a curve is being 
edited the Quick-Pick 
menu changes to a special 
‘EDIT’ mode. 
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In curve being edited is 
highlighted and drawn in the 

normal graph window. 

Curve editing 
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Existing points can be selected 
and dragged in X, Y or both.  

Both the original and the 
modified curves are drawn. 

 

As a point is dragged it’s 
coordinates are updated 

automatically. 

Curve editing – Modify Point 
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Between – Picked screen 
location is projected onto 

nearest segment 

At Cursor – New Point 
created at screen location  

Split Segment – Nearest 
segment is split in “n” parts 

Curve editing – Insert Point 
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• In the Write menu, 
select type of file 
e.g. CSV. 

• Give the filename. 
• Select Curves to 

be written. 
• Press Apply. 

Output Options - Curves 
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Images can be 
generated using 
either the screen 
resolution or at 2, 
4 times the screen 

resolution for 
printed output. 

Image  output 
formats include PNG 

and GIF. 

Images can 
contain multiple 

graphs. 

Output Options - Images 
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PDF and Postscript 
files are generated 

using raster images to 
reproduce the screen 

contents exactly. 

T/HIS can write both 
Postscript and PDF 

files. 

Images can 
contain multiple 

graphs. 

Output Options - Postscript / PDF 
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Images can be used for 
the graph backgrounds. 

Images – Background 
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1) Read in a background 
image. 

Digitising – using a background image 
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2) Set Axis limits and drag 
graph borders to match 

background image. 

3) Create a new curve 

Digitising – using a background image 
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4) From the EDIT menu, 
select Modify->Drag XY and 
drag the second piont onto 

the curve. 

5) Select Insert->At End and 
click to create more points 

Digitising – using a background image 
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4) From the EDIT menu, 
select Insert->Split Segment 
and split the curve into 20 

segments. 

5) Select Modify->Drag Y 
and drag points to match 

curve 

An alternative method for creating a curve 
with evenly spaced points along the x-axis 

is to replace steps (4) and (5) with  

Digitising – using a background image 
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FAST-TCF 

• FAST-TCF is a scripting language for T/HIS, for use with automatic 
post-processing. 

• Scripts are easy to write and edit by hand, and can also be recorded 
by T/HIS. 

• A FAST-TCF script can contain all of the commands to setup and 
position multiple graphs, read in data, perform curve operations and 
generate output. 
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• Automatic generation of FAST-TCF scripts 
– Records operations that created the 

currently  visible curves 
– More robust than command files, not 

dependent on history 
– Easily editable 

Select file type to 
be generated by 
FAST-TCF script 

FAST-TCF - Recording scripts 
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Can be played or 
stepped through 

line by line \ 

FAST-TCF Script 

Feedback in 
interpreter 

window     

• Model Mapping – used 
with multiple models to 
define which model in 
T/HIS corresponds to 
which model in the script. 
 

FAST-TCF - Play-back of scripts 
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• FAST-TCF supports almost 100% of T/HIS commands. 
• Multiple data selection by range including tags ‘first’, ‘last’ and ‘all’ 

– Vastly improved speed up through reading all data in single file pass 
 
 

• Read data from multiple models 
 
 

• Improved functionality requires some changes to existing scripts. 
– Changed syntax for using variables in filenames 

 
 

– FAST-TCF defaults for plot setups are now standard T/HIS ones 
– Must specify data component for rigidwall and strain data 

eg.   sect   100:last   force   z_dir 

$filename.cur    replaces    $filename  .cur 

eg.   Model 1 or Model all 

FAST-TCF scripts 
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• Multiple read/operation syntax examples: 
– Multiple operations using many curves with the same tag: 

 
 
 
 

– Alternative version having the same effect – wild-card (*) used to 
generate and identify tags:  

Sect   100:last   force   z_dir    tag sec_fz 

 

Oper   mul  sec_fz  0.001   tag sec_fzkN 

Sect   100:last   force   z_dir    tag sec_fz* 

 

Oper   mul  sec_fz*  0.001   tag sec_fzkN* 

The z-force on cross sections 100 to (last) will be 
extracted. Curves will be given tags “sec_fz1”, 
“sec_fz2”, etc. 

All curves with the tag “sec_fz*” (where * can be 
any alphanumeric characters) will be multiplied by 
0.001; the resulting curves will be given tags 
“sec_fzkN1”, “sec_fzkN2”, etc.  

The z-force on cross sections 100 to (last) will be 
extracted. All curves will be given the same tag, 
“sec_fz”. 

All curves with the tag “sec_fz” will be multiplied by 
0.001; the resulting curves will all be given the 
same tag, “sec_fzkN”.  

FAST-TCF Scripts 
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• Multiple read/operation syntax examples: 
– Using the entity ID in automatically-generated tags (## command): 

 
 
 
 
 

– Other examples of reading multiple entities:  

Sect   100:last   force   z_dir    tag sec_fz## 

 

Oper   mul  sec_fz*  0.001   tag sec_fzkN## 

Node  all  accel z  tag acc_z 

 

Node 89,90,100000  accel z  tag acc z 

 

Curves will be given tags “sec_fz100”, 
“sec_fz101”, etc, according to the ID of the 
entity whose data is shown in the curve. 

During the operation, the entity ID from the 
original curve (e.g. sec_fz100) will be used to 
form the tag of the output curve (e.g. 
sec_fzkN100)  

All nodes 

 

Nodes 89, 90 and 100000 

FAST-TCF Scripts 
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• Macros may be defined by the user 
for quick access to common 
sequences of operations. 

• Each macro is a FAST-TCF script 
with some additional lines specific to 
macros, and extension .thm. 

• Macros may be kept in a subdirectory 
macros from the directory containing 
the T/HIS executable, or else in a 
subdirectory macros from the user’s 
home directory. 

• T/HIS creates a button for each 
macro. 

Macros 
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• Example 1 – macro with one curve as input 

# 
# Apply C180 filter, then mm/s^2 to g 
# 
macro acr gc180 
macro title convert to g, C180 
macro curve input_curve input curve file                   
# 
operation c180 $input_curve tag curve_2 
operation div curve_2 9810 tag curve_3  

• Inputs to the macro can be curves or 
constants. 

• Input names are variables, so use $ when 
referring within main part of script, e.g. 
$input_curve 

Acronym to appear on 
the button 

description 

Input description 

Macros 
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• Example 2 – macro with one curve and 
one constant as input 

Pick curves for 
the macro to 
operate on  

# 
# Converts velocity into accel, with 
# user-defined g-value 
# 
macro acr acc_ve 
macro title accel from vel       
macro curve input_curve input curve file                   
macro constant gvalue accel due to gravity 
# 
operation dif  $input_curve tag curve_2 
operation div curve_2 $gvalue tag curve_3 # 
 

Macros 
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Command-line Options 

filename 
 

LS-DYNA output file (d3thdt, .thf etc) that T/HIS opens 
and reads when it starts 

-model_list=filename filename is a file containing a list of LS-DYNA results 
files for T/HIS to open. 

-curve_list=filename filename contains a list of T/HIS curve files, one per line, 
which are opened and read when T/HIS starts. 

-curve=filename 
-cur=filename 

filename is a T/HIS curve file which is opened and read 
when T/HIS starts 

-bdf=filename filename is a T/HIS Bulk Data File which is opened and 
read when T/HIS starts. 

-startin=directory  
 

Specifiy a directory for T/HIS to start in.  

-tcf=filename 
 

filename is a T/HIS FAST-TCF script 

-cf=filename 
 

filename is a T/HIS command file 
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Contact Information 

UK: 
Arup 
The Arup Campus 

Blythe Valley Park 

Solihull, West Midlands 

B90 8AE 

UK 

T +44 (0)121 213 3399 

F +44 (0)121 213 3302 

dyna.support@arup.com 

For more information please contact the following: 

www.arup.com/dyna 

China: 
Arup 
39/F-41/F Huai Hai Plaza 

Huai Hai Road (M) 

Shanghai 

China 200031 

 

T +86 21 6126 2875 

F +86 21 6126 2882 

china.support@arup.com 

India: 
nHance Engineering Solutions Pvt. Ltd (Arup) 
Plot No. 39, Ananth Info Park 

Opposite Oracle Campus 

HiTec City-Phase II 

Madhapur 

Hyderabad - 500081 

India  

T +91 (0) 40 44369797 / 8  

india.support@arup.com 

or contact your local Oasys distributor 
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