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REPORTER 10.1 – Getting 

started 
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REPORTER 10.0 - Contents 

• Running REPORTER. 

• A 1 minute introduction to REPORTER. 

• Basic menu layout. 

• Opening and closing templates and reports. 

• Inserting and editing pages. 

• Simple example: 

• Adding a D3PLOT image. 

• Adding a T/HIS image. 

• Variables. 

• Inserting text. 

• Page master. 

• Output files. 

• This presentation is released together with example files, BLOCK_1 to BLOCK_4 

and a REPORTER template, ‘Reporter_example_March2012.ort‟. 

• Note: Requires access to valid license of Oasys D3PLOT, T/HIS and 

REPORTER. 
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A 1 minute introduction to REPORTER 

• REPORTER is designed to help you post-process analyses 

automatically. The idea is that you create a template which contains 

the instructions, or 'recipe„, for how to post-process an analysis. When 

you run REPORTER on an analysis, it takes this template, applies it to 

the analysis and creates a report, which you can save in various 

formats (for example, HTML, PDF, PowerPoint).. 

 

• For example you may want to run a set of standard checks on a series 

of analyses after they have completed, to check that the analyses 

terminated normally, there was not too much added mass, the energy 

balance is OK, etc. You would create a checking template in 

REPORTER and then this would be applied to each analysis you want 

to check. 
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A 1 minute introduction to REPORTER 

• A summary of the steps required to make a template is: 

 

1. Start REPORTER.  

2. Create a new empty template. 

3. Create pages (and/or a master page if required).  

4. Add objects on to pages. These can be simple things such as 

lines, text etc or advanced things like D3PLOT or T/HIS objects.  

5. Use variables to make the template generic.  

6. Save the template.  
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A 1 minute introduction to REPORTER 

• Once you have created a template you can apply it to analyses as 

many times as you want: 

 

1. Start REPORTER .  

2. Open the template.  

3. Set the current analysis variable(s).  

4. Generate the report.  

5. Create output such as HTML, pdf, PowerPoint etc.  
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Running REPORTER 

• REPORTER is run by selecting the REPORTER button menu on the 

Oasys Ltd shell. 

• Alternatively, you can right click on the button to give starting options 

for REPORTER. 
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Basic menu layout 

•  REPORTER runs within a single window. A typical REPORTER session will look like this: 

 
Within this main window there are a 

number of sections: 

• Menu Bar - Access to the main pull 

down menus.  

 

• Toolbars – explained on the next 

slide. 

Main Working area 
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Basic menu layout 

File toolbar 

The file toolbar allows you to create a new template, open a template or save a template. 

View toolbar 

The view toolbar allows zooming in and out. This is the same as using the Zoom submenu from 

the View menu. You can also control the grid and snap tools. 

Design toolbar 

The design toolbar buttons allow you to swap between the "design" view and the "presentation" 

view.  This is explained later. 

 

Style toolbar 

The style toolbar allows you to change the line width, line style, line colour, fill colour and text 

colour for REPORTER objects. 

 

 

Tools toolbar 

The tools toolbar contains the various REPORTER objects which you can place on the page. 

These may be simple objects such as lines, rectangles, text etc. or more advanced objects such 

as a D3PLOT or T/HIS object or a library program object. If you hover the mouse over the buttons, 

a brief text description will temporarily be shown over the button and a longer text description will 

be shown in the status bar. 
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Creating, opening and closing templates and reports 

• Templates can be created, opened, or saved by either using the File menu or the 

File Buttons: 

• Creating a new template: A new template can be created from either the 

New file option in the File menu or by using the New file button. 

• Reading an existing template or report: An existing report template can 

be opened from either the Open file option in the File menu or by using the 

open file button. 

• Saving a template (.ort): A template can be saved by choosing the Save 

as option in the File menu and then changing the file type to template. 

• Saving a report (.orr): A report can be saved by using the Write report  

option in the File menu. The difference between a report (.orr) and a 

template (.ort) is that a template just contains the instructions or recipe of 

how to construct the report, a report contains the generated objects as 

well.  

• Generating a Report: To actually create the report you have to generate 

it. This could mean running D3PLOT objects, programs, FAST-TCF scripts 

etc. By saving the report (.orr) this also saves the output of programs, 

command files etc. with the template, so when you next read the file, the 

results are already available (the report does not need to be regenerated). 

•  Saving a html, ppt or pdf version of the report: File -> Write html or 

Write ppt or Write pdf. 
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Inserting and editing pages 

•  A report is generally made up of a number of different pages. Only one page is 

shown on the screen at any one time. Moving through the pages of the report, 

adding, deleting, and reordering pages are all controlled form the Page menu. 

 

 
•  Adding a new page: A new page can be added by using the New 

page option in the Page menu. This will bring up a Page layout 

window from which you can give the new page a title and set the 

background colour. 

•  Deleting pages: You can delete the present page you are working 

on by using the Delete page option in the Page menu. 

•  Duplicating pages: You can copy the current page by using the 

Duplicate page option in the Page menu. 

•  Reordering pages: You can change the order of the pages in the 

report by using the Reorder pages option in the Page menu. 

•  Page Setup: To set up the page settings choose the Page setup 

option from the File menu: 

•  Generating a single page: Instead of generating the entire report 

you can generate a single page by using the Generate page option 

in the Page menu. However, note that if some of the objects on the 

page require data that would be generated on previous pages and 

those pages have not yet been generated, the page generation will 

not work. 
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Simple example 

• The following slides will show how to build a REPORTER template and 

generate a final pdf report containing analysis results. 

•  The example will compare two runs: answer_block1 and block2.  

•  The final report will contain two pages: 

• The first page will show stress results using D3PLOT (below left).  

• The second report page will show a comparison of the internal energy and the 

hourglass energy for the two analyses using T/HIS (below right).  
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Simple example – D3PLOT image 

• First open a REPORTER session from the Oasys shell. 

• Create a new template:        By default the pages are set up as portrait. To 

change to landscape, go to File-> Page Setup -> Landscape-> OK. 

• To add a picture showing model stresses click on the D3PLOT object button       , 

click and drag on the report page to create a box that will contain the image. In 

the window that appears, click „Capture‟ and this will open a session of D3PLOT. 

 
 

 

 

Click 

Drag 
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•  Choose the view, plot state and type of results to show, for example: 

 

•  Choose an ISO view +ISO:  

 

•  Go to last plot state: 

 

 

 

Simple example – D3PLOT image 

• Inside the D3PLOT session, open the example model /Example_block/BLOCK_1 

/answer_block1.ptf.  
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Simple example – D3PLOT image 

 

• Plot von Mises 

stress: Stress-> 
VON_MISES_STRESS  

 

 

 

 

• Plot stresses by 

clicking on SI:  
 

 

 

 

•  Return to 

REPORTER by 

clicking on File-

>Reporter – this will 

close the D3PLOT 

session and take you 

back to REPORTER: 

 
 

 

 

 

•  Still inside the D3PLOT session: 
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Simple example – D3PLOT image 

• Once back into REPORTER, the Bitmap file and the Job file entries 

have been filled in, since D3PLOT has automatically created a 

settings file, a properties file and a command file and returned them to 

REPORTER. If you want to change the image, you can press Update 

capture again at any time. For now, accept the object by clicking OK. 

 

• You can now look at the results, as they will appear in the final report,  

by generating the page: at the top menu -> click Page and choose 

Generate page, or you can generate the whole report by clicking on 

File-> Generate: 
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Simple example – D3PLOT image 

• Note that when the report was generated, the view was automatically switched from 

the Design view to Presentation view. To continue working on the template, click on 

the Design view button: 

• We now want to add a second picture on the same page, showing the same type of 

results/view for the second model. This can be done by repeating the steps above. 

Alternatively, we can just Copy and Paste the existing D3Plot object. Then right click 

on the new object and choose Edit. Now, simply pick the second model Block2  in the 

“Job file” input line: 

 

 

 

 

Paste & 

Edit 
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Simple example – D3PLOT image 

• The page can now be generated again, to view the final report (Page-> Generate page): 
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• To add a picture of energy curves from T/HIS, click on the 

T/HIS tool button        , then click and drag on the report 

page to create a box that will contain the image. In the 

window that appears, click „Capture‟ and this will open a 

session of T/HIS and generate a FAST-TCF script 

automatically.  

• Inside the T/HIS session -> 

Open the example model  

/Example_block/BLOCK_1/  

answer_block1.thf.  

 

 

Simple example – T/HIS image 

• We now want to create a second page for the time-history results.  

Using T/HIS: Select Page-> New page…-> OK. The new page will become the current page. 

 

 

Press Apply 

• In the T/HIS session, now open 

the second model as well, in 

order to read the relevant result 

from both runs in the same 

graph. Read model block2.thf by 

clicking on New Model: 
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Simple example – T/HIS image 

• To plot the Internal 

Energy for both 

models answer_block1 

and block2, click on 

Global:  

 

• From the list of 

energies, choose 

Internal energy, click on 

both models M1 and M2 

and click Apply: 

 

• This shows now the two 

IE curves. To return to 

REPORTER go to File-> 

Return to Reporter. 

 

• Still inside the T/HIS session, with both analyses results open:  
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Simple example – T/HIS image 

• Once back into REPORTER, 

the Bitmap file and the Job file 

entries have been filled in, 

while the FAST-TCF script has 

been embedded in the 

template. If you want to 

change the image you can 

press Update capture again at 

any time. For now, accept the 

object by clicking OK. 

 

 

 

 

 

• You can now look at the 

results by generating the 

page: at the top menu click 

Page and choose Generate 

page, or you can generate 

the whole report by clicking 

on File-> Generate: 
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Simple example – T/HIS image 

• Please note that when the report page was generated, the view was 

automatically switched from the Design view to Presentation view. To continue 

working on the report, click on the Design view button: 

• We now want to add a second picture on the same page, this time showing the 

Hourglass energy for both models. We can do this by repeating the steps above. 

Alternatively, we can just Copy and Paste the existing T/HIS object. Then right 

click on the new object and choose Edit.  

• To change the output from IE to HE, first select Update capture, which will open 

T/HIS and execute the original FAST-TCF script: 

 

 

 

 

Paste & Edit 
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Simple example – T/HIS image 

• To return to REPORTER go to 

File-> Return to Reporter. You 

may get a question about 

replacing text with variables – 

click Yes and OK. Click OK for 

the „Edit T/HIS object info‟. 

 

• In the T/HIS 

session, right click 

on the M1 curve 

and select History 

in the drop-down 

menu. 

 

• In the window that pops up, right 

click on Read, hover over I.E. 

and choose HG.E. Click Update 

curve (note that the HG.E. for 

the first model is 0). Close the 

Curve History panel. Repeat this 

process for the second curve. 
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Simple example – T/HIS image 

 

• Review the results by generating the report: File-> Generate: 
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Simple example – Variables 

 

• A main feature of REPORTER is that it allows you to create a standard template for one 

specific model, or a set of models, and then use that template to automatically create a 

report for a different set of models. This is mainly achieved through the use of variables. 

• Each of the objects that we have created (i.e. the D3PLOT and T/HIS images) refer to 

some particular models, using their actual name and path. If we want to use this template 

to post-process a different set of runs, we would have to change the names and the 

paths on each of the objects D3PLOT and T/HIS objects.  

• Instead, we can define variables for each analysis and name them, for example:  

• MODEL_DIR1 - the directory path of analysis 1. 

• JOB_NAME_1 - the job name of analysis 1. 

• MODEL_DIR2 - the directory path of analysis 2. 

• JOB_NAME_2 - the job name of analysis 2. 

• In each of the D3PLOT and T/HIS objects, replace the actual model names with the 

variables. Then, when you want to use the template on different model, only the variables 

need to be updated, as shown in the next slides. 

• Note that when referred to, the variables need to be enclosed by % signs to distinguish 

them from the rest of the text string. 
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Simple example – Variables 

• For the next few slides, in your REPORTER template make sure you have the first page active, 

with the two D3PLOT objects. 

• When we created the D3PLOT objects, the Job file was filled in automatically with the absolute 

path of the job and the actual name of the job. We want to replace these absolute values with 

variables. We need to create 4 new variables, 2 for each job: one to store the Job directory and 

the second to store the Job name.  

 

 

 

 

• Click on Variables at the 

top menu-> Edit. This will 

open the window shown 

below, which contains all 

the pre-defined variables.  

 

 

 

• To create new variables, click New (the 

window shown here in the centre will 

open); for Variable name type in 

MODEL_DIR1, for Variable description 

„Model 1 directory‟, for Variable value 

type in the whole path to the job, for 

example: 

C:…\Example_block\BLOCK_1 and OK.  

 

 

 

• The new variable MODEL_DIR1 

should now be visible, as shown 

in the left window below.  

• We will now repeat the process, 

to create a variable for the job 

name, see next slide. 
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Simple example – Variables 

 

• Creating the second variable for the Job nameJOB_NAME_1, and then the remainder two 

variables for the second D3PLOT object, MODEL_DIR2 and JOB_NAME_2: 

 

 

 

 

• Click on Variables at the 

top menu-> Edit. This will 

open the window shown 

below, which contains all 

the pre-defined variables.  

 

 

 

• To create a new variable, click New 

(the window shown here in the centre 

will open); for Variable name type in 

JOB_NAME_1, for Variable 

description „First analysis‟, for 

Variable value type in the job name 

answer_block1 and OK.  

 

 

 

• The variable JOB_NAME_1 

should now be visible, as shown 

in the window below.  

• Repeat the process and define 

variables MODEL_DIR2 and 

JOB_NAME_2” for model block2. 

The list of variables should look 

similar to below: 
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Simple example – Variables 

 

•  The D3PLOT objects now need to be edited and the absolute values replaced with the variables 

defined above. So, for the first object you would have:  %MODEL_DIR1%/%JOB_NAME_1%.ptf. 

To do this, right click on the D3PLOT objects -> Edit -> modify the „Job file‟: 

 

 

 

 

 

• Note: the variables can also be accessed by right clicking while in the Job file field, select „Insert 

variable‟ and chose the variable form the list.  

• The variables should now appear on the D3PLOT objects, as shown above. 

• Generate the page and check it works ok. 
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Simple example – Variables 
 

• The second page, containing the T/HIS energy curves, will also have to be updated to use the variables 

created previously, rather than the absolute path and job name. 

• Right click on the first T/HIS object and select Edit. Extend the window that opens so that all of the „Job 

file‟ text is visible. The two jobs are listed here, so this needs to be replaced with the variables, as 

shown below. Both T/HIS objects will use this string, as they both read the same two jobs. 

 

 

 

 

 

• Should be: "%MODEL_DIR1%/%JOB_NAME_1%.thf" "%MODEL_DIR2%/%JOB_NAME_2%.thf“ 

(including the quotation marks and the space ) 
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Simple example – Variables 
 

• Generate the whole report now: File->Generate. You can save the template: File-> 

Save as-> Template.ort. 

• The report can also saved as a pdf, for example. 

• This REPORTER template can now be used to post-process different runs, as 

explained on the next two slides. 
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Simple example – Variables 

• Using the existing template to post-process new runs: 

        1. Top menu, Variables-> Edit-> select JOB_NAME_2-> Edit-> change Variable value to  block3-> OK 
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Simple example – Variables 

• Generate the report: File->Generate. This will now compare answer_block1 and block3. 

 

 

 

• Using the existing template to post-process new runs: 

        2. Top menu, Variables-> Edit-> select MODEL_DIR2-> Edit-> change Variable value to point to the 

directory BLOCK_3 -> OK 
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Simple example – Insert text 

• Each page also needs a description. This tutorial contains a short overview. For more advanced 

features, such as tables, changing fonts and colours, drawing simple shapes etc, see the 

REPORTER manual, section 5. „Inserting and editing simple objects‟. 

 

 

 

• Generate the page and you should see 

something similar to below: 

 

 

 

• Click on Insert at the top menu-> Textbox..., 

click on the screen where you want the text; 

this will open the Enter text window, where 

you can enter, for example „Von Mises stress 

– time 0.03s‟; click-> OK. To modify the text, 

double click on the text and the Enter text 

window will open again. 
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Simple example – Insert text 

• It would also be useful to have a title at top of each picture, to state which model it is showing. 

The text will update according to the current variable value. 

 

 

 

• Switch back to Design view; click on Insert at the top menu-> 

Textbox..., click on the screen above the first D3PLOT object 

and drag to create a box; in the Enter text window type 

„Model 1 – „ and right click, select „Insert variable‟ and chose 

JOB_NAME_1, as shown below-> do OK.  

 

 

 

• Repeat the process for the second object 

(can right click on the Model 1 box, copy 

and paste and edit). Generate the page 

and you should see something similar to 

below: 
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Simple example – Insert text 

• In a similar way, text can be added to the second page: 
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Simple example – Page master 

• A master page can be added. To create a new master page use -> Page ... -> Page master. 

• Anything added to the page master will appear on all pages in the report . A normal blank page is 

created on which you can place objects as required. An extra toolbar called Master appears. To close 

the master page and return to a normal page select Close master. The result can be seen in the 

Presentation view: 
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Simple example – Library programs 

• REPORTER can extract some other useful information about the runs, for example from the .otf file (or 

d3hsp) we can get the version of LS-DYNA used, analysis date, precision, termination status, etc.   

• This can be done using the Library Program tools, as explained below. 

 

 

Left mouse double click, then enter the 

variable name for model 1 / job1.  
Tip: instead of typing this in, right click and 

select the variable from the list. 

1 

3 

4 

5 

6 

Click 

Drag 

Generate 

Page 

2 
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Simple example – Library programs 

•  After generating the page, the information is now shown in the box below the first model. Repeat the 

process and create a box under the second model:   
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Simple example – Library programs 

•  Other information can be extracted from the .otf file, such as termination status:   
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Simple example – Output 

• Once we are happy with the template/report, we can save the template (.ort) and the report (.orr) 

as explained on slide 9.   

• To save a ppt or a pdf copy of the report ->File -> Write pdf or Write ppt. 
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Contact Information 

UK: 

Arup 

The Arup Campus 

Blythe Valley Park 

Solihull, West Midlands 

B90 8AE 

UK 

T +44 (0)121 213 3399 

F +44 (0)121 213 3302 

dyna.support@arup.com 

For more information please contact the following: 

www.arup.com/dyna 

China: 

Arup 

39/F-41/F Huai Hai Plaza 

Huai Hai Road (M) 

Shanghai 

China 200031 

 

T +86 21 6126 2875 

F +86 21 6126 2882 

china.support@arup.com 

India: 

nHance Engineering Solutions Pvt. Ltd (Arup) 

Plot No. 39, Ananth Info Park 

Opposite Oracle Campus 

HiTec City-Phase II 

Madhapur 

Hyderabad - 500081 

India  

T +91 (0) 40 44369797 / 8  

india.support@arup.com 

or contact your local Oasys distributor 


