
Oasys PRIMER
A training course for new users



Course Content

• Introductions

• Purpose of Oasys PRIMER 

• User Interface and controlling the display

• Some basic functions – editing, deleting, etc

• Model Checking

• Other methods of checking a model – contouring etc

• Working with multiple models, model merge

• Replace Part

• Working with Include files

• Contact penetration checking and fixing

• Spotwelding/connections

• Functions not covered in this course - demo 

• Q&A / Discussion



Before starting this course 

• This training course assumes that certain Preferences have been set for PRIMER. To do this either:

• (a) Put the file named oa_pref that is provided with this course in your log-in directory

• Or (b) use the Preferences editor within PRIMER, checking and changing the primer preferences shown in

the oa_pref file provided (the preferences can also be edited from within PRIMER).

• Or (c) hand-edit your existing oa_pref file, pasting in the *primer lines from the file provided

• If this course is being taught to others, ensure the “students” have the same oa_pref settings as the “teacher”



PRIMER: assemble, 

edit and check models
D3PLOT: display 

and animate results

REPORTER: automatic 

post-processing
T/HIS: time-history 

plotting and processing

Oasys software 

for LS-DYNA



Purpose of Oasys PRIMER 

Typical 

Pre-processor

Hand editing

~90% 

data

LS-DYNA Model

~10% 

data 

loss

Typical pre-processor for 

mesh generation only

Oasys PRIMER

LS-DYNA Model

No data 

loss

100% 

data

• Oasys PRIMER is a specialized pre-processor used only for LS-DYNA
models.

• PRIMER’s modeling tools and comprehensive error checking can
reduce preparation and debugging time.

• PRIMER is fully compatible with the latest version of LS-DYNA, so no
information is lost when reading, or writing out model data.

• PRIMER’s model management tools allow the CAE team to work in
parallel on different components of the same model.

• Because of PRIMER’s robustness and depth of understanding of the
LS-DYNA data, users trust PRIMER to work on their complex models
without corrupting or losing any data.



User Interface before…



User Interface after…



…and now



User Interface and Controlling The 
Display



Exercise: Read an LS-DYNA Model

1

4

2

Reading in a Model:

1. Start PRIMER. If the menu in the bottom right

corner is not already shown as here, click Model

and Read.

2. Leave the file type set to LS-DYNA.

3. Using the file browser, select the file

demo_car4.key.

4. Click Apply.

5. Watch the messages in the dialog box at bottom-

left of the screen.



General Layout

Top menus

Allows access to basic options, keywords 

and tools, in a drop-down menu format.

Quick-Pick Control

Controls the mouse action when 

applied within the graphics area.

Graphics Area

Area within which graphics

are drawn.

Dialogue & List area

Area for command-line

input and output, also acts

a listing area for messages.
Provides all aspects of view

control: direction, perspective,

scale, etc. Contains the

drawing commands and their

settings.

Viewing & Drawing 

Commands

Tools

Provides access to PRIMER specific

functions.

Keywords

This provides access to the

Keywords that are supported

and can be edited by PRIMER.

Menu tabs

These control which option is

displayed in the current menu

panel. Model and Part Tree

will always be available in

addition to selected options.



Setting Menu and Text Size

Display Factor = 1.4Display Factor = 0.9

• Note: if Display Factor is made too large, there 

will not be room for text – you will see blank 

buttons.

Controlling image/menu/text size:

Depending on your screen size and eyesight,

you may prefer the menus to be larger, or to

take up less room.

Use Options=>Menu attributes to set the

Display Factor.



Display Tools

33
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1. Try the different plotting modes: Line, Hidden

or Shaded.

2. Try Zoom then drag across an area. Auto

scale (AC) the view.

3. Try the standard view buttons.

4. Try the Arrow buttons make small changes to

the model orientation.

5. Try Back and Forward, to change to previous

views.

6. Views allow views to be stored/retrieved

Changing the Display

5

6
1

2

3 3
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Dynamic Viewing

1. Hold down the left SHIFT key

2. Position the cursor near the centre of the graphics window, then drag the model using the left button (rotate about screen

X/Y). Observe the cursor symbol and the way the model moves.

3. Now position the cursor near the edge of the graphics window, drag with left mouse button (while holding down left-

SHIFT) – rotate about screen Z. Observe the cursor symbol and the way the model moves.

4. Try left-SHIFT + drag with middle mouse button (translate)

5. Try left-SHIFT + drag with right button (zoom)

Dynamic Viewing



Shortcut Keys

1. Try the shortcut keys:            

L H S 1 2 3 4 5 6 7 8 + - Z 

after Z, click 2 points across 

a rectangle to zoom in

2. Now press A to reset 

Shortcut Keys

? = list of available shortcut keys (also Options=>Shortcuts)

ESC = dismiss the menu that the mouse is over .

RETURN (or middle mouse button) = APPLY.

1,2,3,4,5,6,7,8 = XY, XZ, etc standard views.

A = Autoscale.

B = blanking menu; R = reverse all blanking; U = unblank all.

E = entity visibility menu.

H, L and S = perform Hidden line, Line and Shaded plots.

M = measure node-to-node.

Q = return to Quick-pick.

Z = Zoom (drag across rectangular area).

+ and – = zoom in and out.

T = tidy all floating menus; C = close all floating menus.

I = iconise all floating menus.

List of Shortcut Keys



Quick-Pick

Quick-Pick

Quick-Pick is a powerful time saving tool giving access to

commonly used functions.

1. This menu decides what action will happen when you

click on an entity. Leave this set to Blank.

2. This menu decides what type of entity you will select –

leave it set to Part

3. Click on any part – it disappears (is blanked).

4. Drag across an area – all the parts in that area are

blanked.

5. Middle-click to undo previous quick-pick actions.

21
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Quick-Pick

1

2

43

Quick-Pick

1. Right-click to activate menu.

2. Select the display Only function.

3. Click the part to be displayed.

4. All other parts are blanked.

5. Try shortcut R to reverse the blanking

6. Press U to unblank all parts again

Other functions include blanking, item information, 

editing, colouring, transparency, plotting mode, locate in 

part tree, and create part table. View animation for 

further examples.



Quick-Pick

More Quick-Pick

Try other quick-pick combinations:

1. Change the action (left box) to Transparency 

70%

2. Pick the roof to make it transparent

3. Middle-click to reset

4. Change the action to colour – red and entity 

(right box) to Element – Shell

5. Drag across an area to turn the shells red

6. Change the entity back to Part

7. Change action to Information, click on some 

parts

8. Change the quickpick control back to Blank 

Parts

5

2

1



Control of Visibility of Entities

For an entity to be visible the following must all be true.

1. The relevant model must be active (green) in the model List.

2. The entity type must be turned on in Entities panel (to invoke this panel use shortcut E).

3. It must not be blanked.

Control of Visibility of Entities

1 3

2



Entities Displayed

3

The entities panel controls which entities are currently available to be displayed in the graphics 

window.

1. Use shortcut E to bring up this menu.

2. Change the entities displayed by checking and un-checking the appropriate boxes –

e.g. only beams 

3. Click Update or press S to display new view.

Entities can also be labelled and labelling options can be chosen. 

Entities Displayed

2

3



Entities Displayed

Turn on only solid elements – blank the engine

1. Select CONSTRAINED from the left menu list – the list on the right changes to show all 

CONSTRAINED types, if not, click on ‘CONSTRAINED’ for the list to appear.

2. Display each type one-by-one, update the plot using Update, S or L

3. Notice the user’s errors in this model:

• RIGID_BODIES joining the left and right front wheels

• Nodal Rigid Bodies across the front doors

This is a method of checking the model.  Note: this model contains CONSTRAINED_SPOTWELD –

we do not recommend this method of joining panels. Please ignore those spotwelds.

Entities Displayed Contd.

2

1

Error: RIGID BODIES

joining the left and right 

front wheels

Error: NODAL RIGID BODY

across the front doors



Part Tree
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Before proceeding, go back to the Entity panel, turn off Constrained, turn on 

(Elements) Shells and Solids.

1. Click the Part Tree tab to bring up the Part Tree. 

2. Click ONLY. 

3. Click some INCLUDE files. 

4. Expand an INCLUDE file (using the +). 

5. Try click and shift-click to select multiple parts. 

6. Right-click, change the colour. 

7. Press FIND. Type in 194.

8. Click on the part highlighted. 

9. Type in Roof. 

10. Click on the part highlighted

11. Before proceeding, unblank all parts (shortcut U)

Part Tree



Part Tree

“Contents” mode allows you to view all

entity types in the part tree, not just

parts.

1. Click the Part Tree tab to bring up the

Part Tree.

2. Click CONTENTS.

3. Expand an INCLUDE file (using the +).

4. Right-click, change the colour.

5. Press INCLUDE to turn off the display

of include files.

6. Click LIST then select some entities

Part Tree

1



Cut Section

3
1. Shortcut X to bring up the cut-section menu.

2. Shortcut N to activate node-picking, then click near the center of the roof. 

Display changes to a cut-section at constant X through the picked node.

3. In the menu, change Negative Action to Normal (i.e elements behind the 

plane are drawn normally.

Cut Section

2



Cut Section

1. Zoom in on the cantrail. The cut edges of shells are drawn with their 

actual thickness – useful for seeing whether there are gaps (as in this 

model) or interferences.

2. Shortcut D, drag the section through the model.

3. Try switching the section to Constant Y.

Cut Section

3



Cut Section

1. Switch back to constant x.

2. ONLY display one of the a-pillars.

3. Click on PROPERTIES.

4. Turn off the cut section and dismiss the menu.

Cut Section

3



Exercise: Write Out an LS-DYNA Model

1. Start PRIMER. If the menu in the bottom right 

corner is not already shown as here, click Model

and Write

2. Leave the file type set to LS-DYNA.

3. Using the file browser, type in the name of the 

master file that you want to write 

demo_car4_modified.key.

4. Click Next.

Writing out a Model:

1

3

2

4



Exercise: Write Out an LS-DYNA Model

5. You will enter the “Pre-output check” menu. This has 4 tabs. Click 

on the General tab. 

6. Select Version. This is the version of LS-DYNA you are running. 

Some versions of LS-DYNA will have different formatting for 

some keywords, hence it is important to choose the version that 

matches your project. 

7. Select the keyword format (e.g. Small format) 

8. If you model has include files, decide how you want to save the 

include files. To preserve the existing include file structure, 

choose Select files. 

9. Choose how the include path is written out in the keyword file 

(Absolute or Relative). 

10. Choose the keyword file format (Native, Unix or Windows). 

Writing out a Model:

5

8

6

9

10
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Exercise: Write Out an LS-DYNA Model

11. Next, click on the Options tab. 

12. Select output of keywords in either 

alphabetical order or classic order 

(where the control and database cards 

are at the top of the keyword file, 

traditionally called the top deck) 

13. Select output naming for materials 

(typically Full material name is 

chosen). 

14. Select check boxes for things written 

to keyword file as comment. Important 

to check ZTF output, to enable 

advanced functionality in Oasys POST. 

15. Next, click on the Options2 tab

16. Select whether check file is written to 

the keyword

17. Select whether additional data is 

written to the keyword

Writing out a Model:

17

11

13

14

12

15
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Exercise: Write Out an LS-DYNA Model

18. Next, click on the Compress tab. 

19. Select options for whether file is compressed or 

not.

20. Click on Apply.

Writing out a Model:
20

19

18



Exercise: Write Out an LS-DYNA Model

25

24

22

23

21

23 21. The “select include files to write” menu opens up. Clicking the View 

thumbnails toggles include thumbnails on or off. 

22. Select the folder and path for the master keyword file (note: you 

already defined the filename in step 3). 

23. Click on Find modified. Any differences between the modified file and 

the original file are shown in the pop-up window. The include files 

that have changed are ticked. 

24. Alternatively, the include files you want to write out can be manually 

ticked. Choose whether to write them out in a sub-directory or to 

Rename them and write them as a new filename. 

25. Click on Apply.

Writing out a Model:



Some basic functions – using Editing panels, Part 
Table, Remove, Orient



Using the Editing Panels

1

1

2

3

Parts and all their referenced attributes can easily be edited using PRIMER.

1. Go to Keywords – Part – Modify, and select part 163 from the list.

2. Change the material ID by erasing “12” and typing “1”. Now try a different method - right click for

further options: this right-mouse menu is available wherever the small arrow appears in a text box.

Try pick (from screen), select (from list). Also try edit; change the Youngs Modulus to 10000. After

making changes, click Update to make the changes permanent. Otherwise, if you press Abort,

changes are not saved.

Example – editing a Part and its Material

1



Using the Editing Panels

1. Return to Quick-pick (shortcut Q). Right-click on the roof, Edit. Right-click on the Material ID,  Edit. 

This material references a stress-strain curve, LCSS.

2. Right-click on the curve ID under LCSS, Edit. The editing menu for this loadcurve appears.

3. Change some data values and press PLOT.

Part and Material Editing – example 2
2

1

3

3



Floating Menus

Many menus “float” over the graphics – they can be controlled in several ways:

1. Press i to iconise all floating menus – they will shrink to their top bar

2. Press t to tidy all icons – they will be aligned in the top left graphics corner

3. Press i again to open up the menus

4. Use ESC key to dismiss all the floating menus without saving any changes (= Cancel)

5. Enter key will dismiss a menu and save any changes (= UPDATE)

Note the cursor must be over the menu for ESC & Enter to function

Floating Menus

Press i to iconise Press t to tidy

= ESC

= Enter

1 2

5

4



Floating Menus

You can select where you want

floating panels to appear:

1. Click OPTIONS->PANEL

BEHAVIOR.

2. “Panel placement” setting can be

changed here (default FREE).

Floating Menus

1

2



Creating Data Using Edit Menus

We will create a new part for shells, 1mm thick, with 

elasto-plastic material. 

1. Keyword=>Part=>Create: the Part editing menu 

appears. Text boxes coloured red must be filled in 

before the data can be valid.

2. To choose the Label (ID) for the new part, you can 

type in 1, or use the drop-down menu (right-click), 

choose First Free.

Creating data



Creating Data Using Edit Menus

We will create a new part for shells, 1mm thick, with elasto-plastic material. 

1. From Section ID, drop-down to Create. 

2. Create a new section with ID 3001, element type Shell, thickness 1.0, and 

leave all other entries as the default. Press CREATE_SECTION.

Creating data



Creating Data Using Edit Menus

Either browse for the 

material type, or enter 

the type number (in 

this case, 3)

We will create a new part for shells, 1mm thick, with elasto-

plastic material. 

1. From Material ID, drop-down to Create. Create a 

material with ID 3001, material type 3,  RO=7.8e-9, 

E=200e3, PR=0.3, SIGY=300, ETAN=1000. 

2. Press CREATE_MATERIAL.

Creating data



Creating Data Using Edit Menus

We will create a new part for shells, 1mm thick, with 

elasto-plastic material. 

1. Give the part a title e.g. “My new Part”

2. In the Part menu, all the data input is now 

complete – press Create. 

Creating data



Keyword Editor – Editing Existing Data 

Many KEYWORDs can be edited using a generic 

menu format called the Keyword Editor – the same 

field of many keywords can be updated in one action

1. For example open the Keyword editor for 

*ELEMENT_SEATBELT_ACCELEROMETER

2. Select some accelerometers from the list

3. Enter 5e-2 in to one of the selected rows. The value 

will be automatically entered into all the selected 

rows

4. Press UPDATE

Keyword Editor

1

3

2
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Keyword Editor – Creating New Data 

Some entity types have both Keyword editor and single-entity editor (Modify menu). 

Others have only a Modify menu, while others again have only a Keyword editor. 

1. Go to Keyword=>INITIAL_VELOCITY.

2. The Create and Modify buttons are greyed out – only a Keyword editor is available. 

Start the keyword editor. There are no Initial Velocity definitions currently in the 

model.

3. Enter the data shown: VX=13500.

4. Press CREATE – the data appears in Green.

5. The data is still only temporary – to save it in the model, press UPDATE. 

6. When you redraw the model, PRIMER will also draw the newly-created initial 

velocity data. To avoid this, visit the Entity panel and turn off INITIAL. Entity visibility 

is switched on whenever new data is created. 

Keyword Editor



Keyword Editor – Displaying Data

The keyword editor displays all the _OPTIONs for this keyword together.

Go to BOUND keyword then PRESCRIBED_MOTION.

The _OPTIONs are shown in a column “Suffices”.

Keyword Editor

*BOUNDARY_PRESCRIBED_MOTION_RIGID

*BOUNDARY_PRESCRIBED_MOTION_NODE

*BOUNDARY_PRESCRIBED_MOTION_NODE_SET



Each line of data may be blanked. In this example (*ELEMENT_BEAM) , the second lines have

been blanked.

Keyword Editor

Keyword Editor – Displaying Data

Line 1

Line 2



Keyword Editor – Displaying Data

Where the LS-DYNA data has multiple lines, “Single-row layout” displays the data on a single line.

Keyword Editor



Keyword Editor – Displaying Data

“A” means automatically filter 

to include all _OPTIONs 

present in the model

Hide/show entities with these 

OPTIONs

It is possible to display only those entities having 

certain _OPTIONs, using the “Filter by” buttons:

Keyword Editor



Keyword Editor – Displaying Data

The data may be sorted by clicking on the header of any column.

Keyword Editor



The “Options” button allows you to select entities in the keyword editor, and then carry out various 

operations on those selected.

Keyword Editor

Keyword Editor – Displaying Data



Further options are available from right-click on entity (in left column) – Sketch, Blank, Delete, etc

Keyword Editor

Keyword Editor – Displaying Data



Using Option Selection Menu

Objects can be selected in several ways in 

PRIMER. E.g. from PART > 

MODIFY…

1. Parts can be picked straight away 

from the graphics window – click 

on a part, or drag across an area.

(The quick-pick selection box 

turns blue to tell you the cursor 

function is controlled by a menu)

2. The VIS option gives further 

options for selecting visible 

entities: “ALL” or by screen 

polygon. 

3. Alternatively, click on items in the 

list. Use shift or control to select 

multiple items. 

4. To refine the listing, click Filter.

For example, to show only parts 

that are used for solid elements, 

select element type then shell.

5. A further alternative is to choose

KEY_IN & type in the entity ID.

Using Object Selection Menu

4

1
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Using Option Selection Menu

Clicking on the dark grey bar toggles between original order => A-Z => Z-A => 1-9 => 9-1 => original 

order

Object menu order



Using Option Selection Menu

“KEY_IN” can be used to type in selections. Ranges and wildcards can be used

Keyword Editor – KEY_IN

Select all parts

with ID’s between

150 and 159

inclusive

Select all parts

with ID’s 3

digits long that

begin with “15”



Using Option Selection Menu

Useful for selecting shells from a seed shell up to a break angle – e.g. all shells on a flange

Keyword Editor – VIS – FEATURE LINE



Cursor Action Control

• Return to Quickpick mode using shortcut Q, or 

dismiss the menu that is currently controlling 

cursor action

Cursor action = Quick-pick

• E.g. PRIMER is expecting you to pick a Part for 

the Modify menu

• To return to picking a part for the Modify menu 

(e.g. after temporarily using Quick-pick), click on 

the cross at top-left of the menu

Cursor action = menu pick



Part Table

1. In the Part Tree, right-click the include file body_with_welds4.key

2. Choose “Part Table” option

3. In the View menu, turn on Mass (Dyna Part), Mass (Dyna Added), Sect

NIP and Sect Elform. 

4. Turn off Part Type and Section ID.

Part Table

1

2

3



Part Table

The table now shows the requested data.

1. Click on the column heading “Part Mass”. 

The parts are now in order of mass, 

lightest at the top. 

2. Click again. Now the heaviest parts are 

at the top.

3. The total mass is shown on the column 

heading.

Part Table



Part Table

1. Next, click twice on the column heading “Sect

Gauge”, to bring the thickest parts to the top. 

2. Click the top part, shift-click down to Part 316 – to 

select the 6 thickest parts. 

3. Right-click on the column “Sect NIP” (number of 

integration points). 

4. Type 5 in the text box.  Now the number of 

integration points is set to 5 for the selected parts. 

5. To change the data in the model, press Apply.

6. Dismiss the table, unblank all parts.

Part Table

1
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Remove

The remove function can be used to delete entities 

whilst maintaining the integrity of the model. First, 

unblank the whole model (U).

1. Go to Tools – Remove, to display the 

remove menu.

2. The Delete sub-menu is shown by 

default.  Select Part 156 & Apply.

3. The next menu shows what entities 

PRIMER decides should be deleted

together with Part 156.  In this this 

example some Constrained entities are 

also highlighted – if left in the model 

these would cause an error. 

4. The user can Sketch each entry on the 

list and choose which types to leave

undeleted. In this case delete all using

DELETE_SEL.

Remove
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Remove

The cleanup function identifies data that is no longer 

needed in the model.

1. Select Cleanup sub-menu to remove 

entities that are no longer used.

2. Click Apply.

3. In the next menu we see what PRIMER 

recommends to be deleted – Sketch the 

joints to see their location.  If these joints 

are left in the model LS-Dyna will 

terminate with an error.

4. Delete all using DELETE_SEL.

Remove (cont)

1
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Orient

Using the TOOLS – ORIENT menu we can move 

any entity in the model to a different position and 

(optionally) make copies of the entity during the 

process

1. Delete one wheel & tyre using the 

REMOVE function (previous slide)

2. Open the ORIENT menu and choose 

Reflect

3. Pick a node on the centre-line of the 

vehicle as a mirror point in the Y-Axis

4. From the list on the right choose Part,  drag 

an area over parts to copy

5. Select the Copy on feature, 1 copy

6. Press Apply – PRIMER will create a new 

wheel with new part IDs, elem IDs etc.

Numbering of the new entities can be 

specified here, or renumbered later using 

MODEL – RENUMBER CONTENTS -

SELECTION

Orient
6 ways to Orient are available

e.g. Trans-rot maps 

one node triad onto 

another

52
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Orient - Dragging

Orientation can also be done by dragging.

1. Switch the Orient method to Translate.

2. Switch off Copy

3. The previously selected parts are still selected in the Object menu. Deselect these 

using the NONE button, then pick the newly-reflected parts. Dismiss the screen-

pick menu which is covering some of the Orient menu buttons.

4. Press Drag, select option Y

5. Drag the wheel into a new position. 

6. Press Apply – PRIMER will leave the parts in their new position.

Numbering of the new entities can be specified here, or renumbered later using 

MODEL – RENUMBER CONTENTS - SELECTION

Orient

1
2
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Tabs

1. Many of PRIMER’s menus appear in the bottom-right corner –

these are called “Docked” menus. As each docked menu is 

called up, a Tab appears.

2. Clicking on a Tab brings that menu to the front.

3. The Model and Part Tree Tabs are always present. Other 

docked menus can be dismissed by pressing ESC when the 

mouse is in the menu.

Tabs



X-Refs

Linkage (cross references) between entities may be viewed using Xrefs.

1. From parts menu, Edit part 156 or 157 (one of these may have 

been deleted!).

2. VIEW_XREFS will open the Cross reference viewer

3. The left menu contains entities that refer to this part – look at the 

CONSTRAINED entities that refer to this part

4. The right menu contains entities that this part refers to – right click 

& open – we can see that only 1 parts references this material

X-Refs (Cross reference)



Model Checking



Checking Models 

Checking a Model:

Delete the model and re-read

demo_car4.key.

1. Click Tools – Check to display

checking options.

2. Select the model to check, click

Apply.

3. The checking summary,

showing the number of errors

and warnings, is displayed. The

distinction between “error” and

“warning” is somewhat arbitrary

– not all of the “errors” would

cause LS-DYNA to terminate.

4. The Error Tree viewer is also

displayed. Each category may

be expanded or contracted by

clicking on [+] or [-]

4

3
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Checking Model

User-defined check to catch possible modelling error

User-defined check to catch possible modelling error

“multiple constraint” error 

Faults with material data that (in our experience) can 

cause trouble in LS-DYNA

Missing data – will stop LS-DYNA 

Faults with connections can be fixed using Connections Table

Read the descriptions of the different 

errors…

Contact quality checks



Checking Models

Recommended parameter is not the default

(Spotweld beam) element quality checks

Material type 24 - warnings

Discontinuous rigid body – could be a mistake?

Model badly organised



Checking Models

2. Right-click on the top error heading (RIGID BODIES).  The pop-up menu give options that apply to 

all the entities listed under that heading.

3. Click on Sketch. You should see several rigid bodies that are subject to a 

*CONSTRAINED_RIGID_BODIES that fails the user-defined check.

Some of these may not be errors – it depends on user defined values – you need to consider each 

one separately.

Error Tree Viewer contd:

1. Expand the first error category in the tree:

[+] CONSTRAINED then [+] RIGID BODIES

This is a user-defined check for the distance between merged rigid bodies – it 

could show up a modelling error that the wrong rigid bodies were merged. 

Later we will learn how to set preferences for user-defined error checks.

Checking with the Error Tree Viewer:

2

1

3



Checking Models

1. Right-click on the last of the individual entities affected

(RBOD34). Click on Sketch.

2. Rotate the model to see the small rigid bodies that have

been merged accidentally – this is clearly an error.

3. Delete the constraint by clicking on Delete, then

DELETE_SEL and CONTINUE.

Error Tree Viewer contd:

1

3



Checking Models

1. Right-click on the last MAT_24 error.  Click on Edit  This will open the MODIFY MATERIAL 

menu for MAT 226

2. Right-click on the stress-strain curve table LCSS, Edit.  

At large plastic strain, the stress-strain curves for different strain rates will cross. This can cause 

instability.

More Checking & Fixing:



Checking Models

3. This can be fixed by making the material fail before the curves cross 

– set FAIL=1.0 (100% plastic strain)

4. Check again using Check button

5. Erase the SIGY=400 – this is ignored by Dyna when the stress-

strain curves start at a different value.  Check again – should be no 

errors for MAT 226

More Checking & Fixing contd:



Checking Models

1. Expand the WARNING section and look at the first PART warning

2. Many parts are listed under this warning – use the right-click ONLY

option to show only part 433.  This is a quick way to see where the 

parts are in the model.

More Checking:

1

2



Writing an Error Summary File 

1. Write an error summary file using List.

2. View it using a text editor.  This file can also 

(optionally) be created during model write-out.

Saving the Errors:

1

2

1



User-defined Checking Options 

1. To set user-defined values for some of the 

Error & Warning checks, click Options from the 

main check menu

2. Tick the boxes and set the desired limits – this 

will apply to the current PRIMER session only

User Defined Options:

Use drop-down 

to change 

category



User-defined Checking Options

1. For a permanent setting, use 

Options, Edit prefs from the top 

tool bar.   Note – this does not 

affect the current PRIMER session 

unless you then “Refresh 

preferences”

2. Expand [+] PRIMER → [+] 

checking → [+] model 

quality checks → [+] rigid →

[+] Rigid body merge check →

rigid body merge max separation

3. Change the value to 250

4. Save settings & exit from the top 

File option.  The value of 250 will 

now be used in future sessions of 

PRIMER.

User Defined Options:

1

4

2



User-defined Checking Options

• PRIMER has a further capability for customising error checking.

• A user-written file can change the status of selected errors, and add extra messages which will appear in the 

error log file. The user’s scripts can then scan the error file for these messages and take action accordingly.

Example file:

PART_122,    ERROR,    Fatal - do not run this model

M_ST_24_07,  WARNING,  Demoted to warning

M_ST_24_10,  IGNORE, 

Error tags – identifying the 

selected error. The tags can be 

made visible in the error tree.



Writing Out the Corrected Model

1. To write out the model, use Write

from the main model menu.

2. Give a file name.  As the model has 

INCLUDE files, this will be the master 

keyword file.

3. Press Next >>> to move to the next 

menu

4. Set the desired Version of LS-Dyna.  

Input data not valid for this version 

(e.g. new KEYWORDs) will be 

omitted and a warning message 

printed.

5. Pick the Select Files option – to 

choose which INCLUDE files are 

written in the next step

6. After selecting all the required options, 

press Apply

Model Write:

1

2

3

5

6

4



Writing Out the Corrected Model

1. Either click the boxes to tell PRIMER which 

INCLUDE files to write… 

2. … or ask PRIMER to Find modified INCLUDE files. 

This process will take one or two minutes as 

PRIMER compares with the files previously read off 

disk. 

3. PRIMER will show a list of all the changes you’ve 

made in this session. Skip to the end of the listing 

then Continue to the next menu

Model Write contd.:

This list may be slightly different – depending 

on what modifications you’ve made 

2

1



1. The modified INCLUDE files are shown in red & 

automatically selected .

2. To write the new files in the same directory as the 

originals, use RENAME and give a new file name. 

Model Write contd.:

Writing Out the Corrected Model

2



Other Methods of Checking a Model 



Visual Checking - Contouring

Ensure that only the body structure is visible. 

Select component Matl Props, Yield Stress. 

Click SI to perform a Shaded Image plot. The parts are now 

coloured according to yield stress.

Can you see the error? The part highlighted should be high-

strength steel – green, like the part on the other side.



Visual Checking - Contouring

• To fix the error, we need to edit the Part data, and reference the correct material.

• Change the quick-pick settings to Edit Part. Click the offending Part to bring up the Part 

editing panel. 

• Right-click on the Material ID, click PICK. 

• Now click on the symmetrically-opposite part. The material ID should change to 234.

• Press UPDATE. 

• Press SI. The plot should now show the correct symmetrical pattern of high-yield 

material.



Visual Checking - Contouring

1. Ensure that only the body structure is visible.

2. Select component Shell Thk, do an SI plot

3. Note the contour levels – somewhere there is a panel with a thickness of only 0.083mm – this is probably an error. 

4. To find it, set the contour levels: press Settings…, enter a contour maximum value 0.5. Press SI.

5. The part containing the error is now obvious – right-click on the part, edit, edit the Section: change the thickness to 0.83.

6. Experiment with plotting some other data components.

Thickness contouring:



Visual Checking – Find Attached

To check that all parts are connected, we

use the ATTACHED function. First,

display only one part (e.g. the roof). To do

this, right-click on the roof, click Only.

Under Tools, press ATTACHED. In the

attached menu, press APPLY. PRIMER

finds and displays any entities joined to

the entities already displayed – in this

case, mesh-independent spotwelds that

are joined by a tied contact. PRIMER

uses the same thickness tolerances etc

as LS-DYNA to decide which nodes are

tied by a tied contact.



Visual Checking – Find Attached

Press APPLY a few more times. Elements

of the panels attached to the spotwelds

appear.

Now click Attached Part, and press 

APPLY. The whole of each attached part 

appears.



To find every connected entity (without 

pressing APPLY many times), click 

Recursive. Press APPLY. PRIMER 

automatically continues to find attached 

entities until no more are found. 

Finally, press R to reverse the blanking. 

Any loose part will now be displayed. 

These need to be fixed to the car.

Visual Checking – Find Attached



Working with Multiple Models and Merging Models



Working with Multiple Models

Read in odb_rigid_2.key and rigid_wall_conds_ffb.key. These now exist

in PRIMER in addition to the first model that was read in; the three

models are completely independent of each other, there can be no

connection or inter-relation between them.

Use Model List to make each model visible (green) or invisible (red).

Try using the up/down arrow keys to make one model visible at a time.

Leave only M3 visible.



Working with Multiple Models

Go to Keyword=>Part=>Modify. 

The object menu has tabs for each model. By default only the 

parts in active models are offered.

Try clicking the tabs, see the effect on the list of parts offered.



Merging Models

Multiple models can be read into PRIMER 

and kept separate unless the user merges 

them.

1. In the Model menu, click Merge

to create a new model by 

merging existing models.

2. Select models 1 and 2 (the 

vehicle and ODB), click Apply.

3. Usually there will be clashing 

labels in the two models that 

need to be resolved – click 

“Increment slave model always”, 

then Apply Merge. A new model 

M4 will be created.

4. Check the contents of M4 using 

Model List to make it visible, and 

look for its parts in the Part Tree.

5. Delete models 2, 3 and 4 ready 

for the next workshop example.

Merging Models

3

2

2

1



Exercise: Diff Function (Find Modified Keywords)

1. The What’s modified tree viewer pops up.

2. Expand the menus by clicking on the white boxes. 

3. Right click on the difference found and click on Edit

4. This pops up the material where the difference was found. You can then 

interrogate what the difference is

Modified?

1

2

3



Replace Part 



Replace Part 

REPLACE PART is used to introduce a remeshed part into an LS-

DYNA model.

In this example, the design of the roof has been changed. It is an

extreme example, so that the change will be clearly visible in the

pictures.

Read the model roof_modified.key. There are now 2 models in

PRIMER. Use the red/green buttons in the Model List menu to

make only Model 1 visible.

+ =



Replace Part 

From the Keyword menu click Part, then Replace.

Leave the menu in “replace single part” mode.

Under “re-attach options” make sure “remake connections” is on, to

ensure that mesh-independent spotwelds will re-connect to the new roof

panel.

Click on the roof panel of Model 1, to select which part should be

replaced. Click NEXT.



Replace Part

PRIMER now offers the parts in Model 2. Select P416 (the new roof).

Press Next.

The new roof is now included in the car model.

PRIMER automatically fixes numbering clashes (e.g. same node ID in

new mesh and in another panel).

Delete Model 2 (the separate roof panel) from PRIMER.

Part Replace will also re-attach any items connected to the old mesh

(in this case, there aren’t any such items).

Multiple parts may be replaced in one operation, provided that the Part

IDs match.



Replace Assembly

Old model with spotwelds

+ =

Spotwelds “around the 

edges” of  the assembly are 

taken from the old model, 

and re-connected.

Spotwelds “inside” the 

assembly are taken from 

the new mesh

New mesh of assembly, 

spotwelded, may have 

different number of parts

Old model with spotwelds



Checkpoint files, command files, macros and oa_pref files



Checkpoint Files

• A checkpoint file is automatically written by PRIMER during each session.

• Example filename:  cp_PRIMER_rc1_(build604)_2314

• This is a record of what buttons you pressed, and where on the screen you clicked. 

• A checkpoint file can be replayed, to recreate the exact same actions using the same model. 

• Useful in the rare event of PRIMER crashing, or being terminated abnormally by the computer system – can recover any unsaved work.

• Also useful if your last action was a mistake – you can choose how many of the stored commands should be replayed. 

• Checkpoint files are not editable and cannot be modified in any way.



Command Files

• A limited range of PRIMER functions are available in command files.

• PRIMER may be run in batch mode with a command file.

• For example, your LS-DYNA submission script could include a command to read the model into PRIMER, run the error checker, write an error report. 

The submission script could then read the error report and decide whether to submit the job.

• The PRIMER manual (Appendix XII) lists the available commands

• New commands may be available in addition to those in the manual – try typing H in the dialog box to see the available options

Command to run PRIMER in batch mode with a command file (see Manual Section 1.4 and 1.5):

$<pathname>/primer91.exe -d=batch -cf=my_command_file -exit 

Example command file:

/READ DK (path)/model_name.key 1

/CHECK checkfile filename.dat

MODEL 1 APPLY

/EXIT



Preferences - (oa_pref files)

• oa_pref files are text files saved on your system that contain preferences used by Oasys software.

• These are useful so you don’t have to change settings every time you open PRIMER/D3PLOT etc.

• The file will contain lines that look like this:

primer*display_factor:            1.40

primer*display_brightness:        1.00

primer*display_saturation:        1.00

primer*button_gradation:          0.00

primer*font_size:                 default

primer*font_type:                 helvetica

primer*background_colour:         WHITE



Preferences - (oa_pref files)

• Preferences can be set in PRIMER through the “Options” menu:



Preferences - (oa_pref files)

• When opening the preference panel, you may get a message about modifying the install preferences – this is because preferences can be saved in a

number of places:



Preferences - (oa_pref files)

Common area 
oa_pref

User home area 
oa_pref

User home area 
oa_pref

User home area 
oa_pref

PRIMER user 1 PRIMER user 2 PRIMER user 3

• When opening the preference panel, you may get a message about modifying the install preferences – this is because preferences can be saved in a

number of places:



Preferences - (oa_pref files)

• oa_ref files can be stored in 4 locations:

• OA_ADMIN – top level configuration – often the same as OA_INSTALL

• OA_INSTALL – Installation level (location of executables)

• HOME – users personal home area

• Current working directory (rarely used)



Preferences - (oa_pref files)

• Preferences can be changed in the preference panel which opens. The example below shows how to change the background colour of the graphics

window. Once you have made changes, click File > Save



Macros

• Macros are readable, editable, recordable command files. They record which buttons were pressed in which menus.

• Macros offer the most flexible method of capturing a process, then applying the process to a different model.

• The “Pause” command (added by hand-editing the macro file) allows instructions to be passed to the end-user, who may then take control to carry 

out some actions interactively.

Window("Contact").Button("Create")

Window("CREATE CONTACT in model 1").Popup("Label:")

PopupWindow1().Button("Highest+1 Layer")

Window("CREATE CONTACT in model 1").Button("Contact Type")

Window("CREATE CONTACT in model 1").Menu("CONTACT 
TYPE").Select1("AUTOMATIC_SURFACE_TO_SURFACE")

In Window("CREATE CONTACT in model 1")

.Textbox("Static friction (fs)") = "       0.2"

.Textbox("Dynamic friction (fd)") = "       0.2"

.Button("Optional data..")

.Textbox("Soft constraint opt (soft)") = "      1"

.Button("==> Main Panel")

.Popup("Set type (sstyp)")

End In



When You Need Help

• Help text is available from most menus

• The on-line manual can be accessed from within PRIMER, provided that it has 

been installed with the software

• Support line – call us (or your distributor).



ztf File

• Certain information (e.g. beam sections) is not contained in the d3plot/ptf file. 

• The ztf file is a file that passes such information to D3Plot. 

• Several features in D3Plot benefit from the ztf file. 

• It can be automatically generated when you open D3Plot (see “Opening Models”) or can be written using PRIMER. 

• The ztf file must have the same filename as the ptf being opened. 



Data Read into D3PLOT

• The ZTF file created by PRIMER  includes data for SPC’s, spotwelds, 

*DATABASE_CROSS_SECTIONS.

• Results for spotwelds, SPC’s, springs and 1D seatbelt elements can be read 

from the LSDA (binout) file and displayed.

PTF (d3plot) File
Nodes

Solids

Beams

Shells

Thick Shells

SPH

Airbag Particles

ZTF File 
Springs

Seat belts

Joints

Lumped Masses

Rigidwalls

Spotwelds

SPC’s

Geometry Only

Geometry + 

Results

LSDA File
Spotwelds

SPC’s

Springs

Seatbelts

Results

XTF File 
(older versions, 
SMP only)
Springs
Seat belts
Joints
Lumped Masses
Rigidwalls

Results



Working with INCLUDE files



Good Modelling –Practice 1

Self-contained INCLUDE files:

• When an INCLUDE file contains *PART, all the elements and nodes contained in that part should be in the same INCLUDE file.

• LS-DYNA data referencing entities in another INCLUDE file should be minimised (“connections”)

• To check, read each INCLUDE file as a separate model.

• This type of image is seen when elements are in one INCLUDE file (that has been read into PRIMER) reference nodes in another file that has not been 

read in. “Latent” nodes are drawn at (0,0,0). 



Good Modelling –Practice 2

Define a numbering scheme for each INCLUDE file. This will minimise the chance of clashes when building models, and allow large teams to work in

parallel on the different INCLUDE files.

This is a very simplified example!

Component Node, element, NRB, node set All other data e.g. Parts

Barriers 1 to 499,999 1 to 4,999

Dummies (driver side) 500,000 to 999,999 5,000 to 9,999

Dummies (passenger side) 1,000,000 to 1,499,999 10,000 to 14,999

Airbags 1,500,000 to 1,599,999 15,000 to 15,999

Seats 4,500,000 to 4,999,999 45,000 to 49,999

Powertrain 5,000,000 to 5,999,999 50,000 to 59,999

Suspension 6,000,000 to 6,999,999 60,000 to 69,999

Closures 8,000,000 to 8,999,999 80,000 to 89,999

Body structure 10,000,000 to 19,000,000 100,000 to 189,999

Body structure spotwelds 19,000,000 to 19,999,999 190,000 to 199,999



Reading Selected INCLUDE Files

Include files may be selected on reading a model. 

1. In the Model menu, click Read. Browse for demo_car4.key. Press Quick scan.

2. Click on the body and suspension INCLUDE files. Press Apply.

3. PRIMER reads in only the selected INCLUDE files – this will be Model 2. 

Scan and Quick-scan



Some data referenced in the INCLUDE files that we have read in, was defined in other INCLUDE files that we have not read in. The model is incomplete. 

Go to Keyword=>DEFINE_CURVE=>Modify. Note the curves listed in pale blue type – these are called “latent”, i.e referenced but not defined. These 

would also show up as errors during a Model Check.

It is not good practice to create INCLUDE files like this – they should be as self-contained as possible, except for connections that join across INCLUDE 

files.

Now delete all models in PRIMER except Model M1.

Reading Selected INCLUDE Files



Methods to Find Which INCLUDE File an Item is in 

• If you can see the item on the screen,

• Use Quick-pick “Information”, click on the

item

• Alternatively, if the item is a part, use

Quick-pick “Locate in Tree” to see it in the

Part Tree under its Include file

• If you know the name or ID of a part

• Part Tree “Find”

• If the entity type has a Modify menu, use it to edit

the entity – the menu tells you which INCLUDE

file it is in

• Or,

• Put the item on the clipboard, right-click and

LOCATE



INCL File Location

The EDIT menus offer viewing and modification of the INCLUDE file

location of each entity.

Try editing Part 2101, change the INCL location to body_with_welds.

Check the “find referenced items” button to ensure that nodes and

elements are also moved across.



Moving Entities to a Different INCLUDE File

The clipboard can be used to store a selection 

of entities. Its contents can be accessed when 

selecting from other menus. There are also 

certain model management functions available 

within the clipboard menu.

1. Go to Tools – Clipboard, to display 

the clipboard.

2. Click +(ADD), and select object 

type PARTS. Select some parts.

3. Click Move to INCLUDE file.  

4. Browse for the INCLUDE file. 

Activate the Find referenced items

button, and click Apply.

5. The user can select which entity 

types will be moved.

Clipboard

2

2

3

4

5



INCLUDE File for Newly Created Entities

• If the user copies or modifies data, the modified or new data is put into the same INCLUDE file as the 

original data.

• When the user creates new data, how does PRIMER decide into which INCLUDE file it should be put?

• Answer: the “Current Layer” means the INCLUDE file for newly created data.

• To set the current layer, right-click on Include file in Part Tree, Make Current Layer.

Current layer is 

displayed in green



The INCLUDE Menu

Go to Tools=>INCLUDE. The model’s INCLUDE file structure 

appears. This menu is similar to the Part Tree but with greater 

functionality.

The pictures are called Thumbnails. The blank images are for 

INCLUDE files that have no drawable data – e.g. the first 

INCLUDE contains only control cards. Try pressing Hide 

Thumbnails, then View Thumbnails.

The thumbnails are stored in the keyword files. Right-click on 

Refresh Thumbnail, choose ISO view. PRIMER creates a 

thumbnail for each INCLUDE file.



Splitting the Model into INCLUDE Files

A simpler method of moving Parts to a different INCLUDE file (with their nodes and elements) is to 

drag them in the Part Tree. Multiple parts can be selected by shift-click or CTRL-click.

While dragging, the cursor symbol changes when a valid “drop point” is reached. The parts will be put 

into the Include file that is under the cursor when the mouse button is released. 

Alternatively, select as before => right-click => Cut => select INCLUDE file, => right-click => Paste.

This process gives the same effect as Clipboard => Move to Include with option “Find Referenced 

Items”



Adding a New INCLUDE File

We will create a new INCLUDE file in which to put the Initial

Velocity definition.

1. Right-click off the Master Model. Select ADD NEW

CHILD, *INCLUDE.

2. Enter a name for the new INCLUDE init_vel.k, press

ADD.

3. PRIMER automatically makes the new INCLUDE file the

Current Layer (shown in this menu by the green stripe).



Adding a New INCLUDE File

Use Keyword=>INITIAL_VELOCITY to create an initial velocity for the whole 

model, VX=13500 as shown. 

Press CREATE and UPDATE. This data will be put in the new INCLUDE file 

init_vel.k, because this is the current layer.

Using the Include menu, right-click off init_vel.k, WRITE INCLUDE.  Use a 

text editor to check the contents of the file written out.



Adding Existing INCLUDE

Next we will add a barrier into the model. We have already seen how to do this by merging models; that method puts the barrier data into the master

model. Instead, we will use the Include menu to add the barrier as an INCLUDE file.

Again, we use ADD NEW CHILD to add an INCLUDE to the master model. This time, instead of typing a new filename, browse for

INCLUDE_FILES/LOADCASE/odb_rigid_2.key, press ADD.

When adding INCLUDE files by this method, PRIMER is able to resolve label clashes. Press FIX_CLASH – we can adjust the numbering later.

The barrier appears as a new INCLUDE in the model.



Numbering an INCLUDE File

• To Renumber an Include File, use Renumber Selection 

• Select Object Type INCLUDE FILE

• Select the include file odb_rigid_2



Numbering an INCLUDE File

• Set Renumber to Yes for all entity types. 

• Type in 1000000 for “start at”. PRIMER detects that a clash will occur with existing entities. Change “start-at” to 3000000 – now there are no 

clashes. (other ways are available to resolve numbering clashes, using the drop-down Action menu).

• Press APPLY.



Numbering an INCLUDE File

• An alternative method is to use “Renumber includes”

• This allows you to specify ID ranges for each include file



Numbering an INCLUDE File

• Two ranges can be set for each include

– One range for nodes/elements + some other types

– One range for all other labelled entities.

– Both ranges can be the same.

• Label ranges can typed in, or imported from a CSV

file.

• Label ranges are saved as comments to each

include file.

• The panel will tell you if you have entities within an

include file which is outside the specified range.

• Entities can be renumbered into range through this

panel.

• Ranges are also used during creation of entities

when assigning ID’s.

?



Replacing an INCLUDE File

As an example, we will now replace this barrier model with a different one that has already been renumbered and positioned.

Use the Include menu to remove the barrier (right click,  REPLACE INCLUDE). 

Browse for INCLUDE_FILES/LOADCASE/odb_rigid_moved.key



Other Functions in the INCLUDE Menu

• The Include menu is used to create and edit INCLUDE_TRANSFORM data.

• The INCLUDE structure of the model can be modified, e.g. flatten a multi-layer

include structure

• Label Ranges may be defined for each INCLUDE – an error check and autofix

is available to ensure that the contents of the INCLUDE obey the given

ranges; you can apply the given ranges from this menu

• There are facilities to associate a design-level (“version”) with an INCLUDE

file



Writing INCLUDE Files

• We have already seen how to write an INCLUDE file from the Include menu.

• Now try Model=>Write, opt for Select Files.

• Check the box for suspension2.key (you can check as many INCLUDE files as you wish.

• Option SUB-DIR means that PRIMER will create a new subdirectory, INCL, INCL_1, INCL_2 etc in which to put the requested INCLUDE files.

• Option RENAME means that PRIMER will write the INCLUDE file to the same directory that it came from. A red text box for the file name means that 

the original file will be overwritten – change the name before writing out.



Note about Windows /Unix Systems

• It is quite common for pre/post to be 

performed on Windows, but to run LS-DYNA 

on linux. PRIMER allows for this combination:

• Windows: S:\models\model1.key

• Unix:    /data/models/model1.key

• “Drive mappings” can be set up as preferences 

(e.g. S: = /data)

• Unix-style paths (forward-slash) can be written 

by setting Unix style on the Write menu – this 

can also be set as a preference



Contacts, Contact Penetration Checking and Fixing



Exercise: Create a Contact 

1. Click CONTACT. 

2. Click Create. 

3. The create contact window pops up. 

Primer’s create contact window makes it easier to 

create contacts. Note the keyword are written out 

in the correct formatting. 

Create a new contact

1

2

3



Exercise: Create a Contact 

4. Next, define the type of contact you want.  

5. There are many possibilities (discussed 

further in Introduction to LS-DYNA course). 

For this contact, select 

AUTOMATIC_SURFACE_TO_SURFACE

Create a new contact

5

4



Exercise: Create a Contact 

6. Click on the SSTYP (slave set type)

7. There are many possibilities (discussed 

further in Introduction to LS-DYNA course). 

8. For the first part of this exercise, select Part 

id

Create a new contact

8



9. Fill out the remainder of the input variables 

for master and slave side.

10. Enter any penalty stiffness factors, thickness 

values or thickness factors. 

11. Enter the coefficient of friction values for 

static and dynamic friction.

12. Click on Create contact.

13. Write out your model. 

Create a new contact

Exercise: Create a Contact 

9
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Exercise: Create a Contact 

14. Repeat the exercise by selecting a different 

slave set type. 

15. Try Shell Set, Node Set and Segment Set

Create a new contact

14



Exercise: Create a Contact 

16. Sets can be created directly from the SSID 

menu. 

17. Right click and click Create.

18. This takes you to the set creation Primer 

menu.

Create a new contact

18

17



Exercise: Create a Contact 

Sometimes you will need use a 

segment set to define your 

contact. Using segment sets 

is usually more robust. To 

create a segment set, you 

need to coat parts in 

segments. Primer helps you 

do this. 

19. Change SSTYP to 0.

20. Right click on SSID and 

create segment set.

21. In the create set_segment

menu, select Coat elements. 

22. Choose External faces and 

Coat Face. 

23. Click on the face of interest. 

24. Click Apply. 

25. Back in the create set menu, 

click Create. 

Create a new contact

19

20 21
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Penetration Checking

Delete the models from PRIMER.

Read joint_bpost.key.

Begin by looking at a cut-section. Use shortcut X

then N, pick a node, switch “negative action” to

“normal”. Drag the section through the model

(shortcut D, then use mouse). PRIMER draws cut

sections through shell elements using the true

thickness. Observe where the panels are

penetrating and where they are too close.

When you have finished dragging, shortcut Q

returns to Quickpick mode.

Parts too close 

(“Penetration”)

Intersecting parts 

(“Crossed edge”)



Penetration Checking

Turn off the cut section.

Start the Contact Penetration checker

from

Keyword=>Contact=>Sliding&Tied=>

Modify (select the Automatic Single

Surface contact) =>Pen Check



Penetration Checking

1. “Penetration” means that a node is too close to an element, i.e.

within the contact thickness defined by 0.5(t1+t2), where t1 and t2

are the contact thicknesses of the contacting elements

2. “Crossed edge” means an intersection of one element plane with

another

3. PRIMER understands the different methods of defining contact

thickness, e.g. SST on *CONTACT, or on *PART_CONTACT.

4. PRIMER tries to use the same equations as LS-DYNA to determine

penetrations.

Contact Penetrations:



Penetration Checking

Try the different plotting modes.

Crossed edges are shown by yellow lines on grey elements.

Penetrated elements are coloured according to penetration depth. The penetrating nodes are shown by coloured

crosses, with coloured arrows showing the “escape vector” – where the node would have to move to, in order to

eliminate the penetration.



Penetration Checking

The pairs of parts that interact (penetrations or crossed edges) are shown. To display just one of those pairs or

parts, click on it in the menu. Restore display of all parts using “Sel All”.



Contact Penetrations - Settings



Contact Penetrations - Settings

In the Settings panel, the different displays 

(penetrated elements, penetrating nodes, crossed 

edges) may be turned on or off, or labelled. Drawing 

the elements with their Contact Thickness can 

sometimes help to visualise why there is a 

penetration.

The coloured arrows show where the node would 

have to move to, in order to eliminate the 

penetration.



Try turning off Crossed edges, press UPDATE.

Before proceeding to the next step, turn the crossed edges back on, and turn off 

“As Thick”.

Contact Penetrations - Settings



Contact Penetrations - Settings

The LS-DYNA control flag IGNORE is recommended – this makes the contact 

algorithm tolerant to small penetrations. To find out whether any penetrations 

exceed a certain tolerance – say 0.2mm – input a minimum value in the Pen Check 

Panel. Update Plot. PRIMER now displays only penetrations greater than 0.2mm



Contact Penetration Ratio

To find out whether any penetrations exceed, say, 0.2 times the shell thickness, set the data component to “ratio thickness remaining”, and the value to

0.8 (i.e. PRIMER will display colours only where the remaining thickness, after the penetration is subtracted, is 0.8 or less times the thickness. Press SI

again to display.

Before proceeding to the next step, set the data component back to Penetration, and the limit value to 0.2.



Cross-edges Fixing 

Press FIX. We recommend to fix the crossed

edges first.

PRIMER offers the pairs of parts that are

intersecting. Click on the only pair. PRIMER

shows just these parts.

Zoom in on the affected region.



Cross-edges Fixing 

We must tell PRIMER which nodes are on the “wrong” side. Use

“ADD nodes to fix” to select the three nodes shown, APPLY to

confirm the node selection.

There is a choice of manual (e.g. dragging) or automatic methods to

calculate the movement of each node. Try the Auto fix method. Press

“Apply fix”.



Penetrations – Manual Fixing

Switch to Penetrating, ensure the menu is switched to Manual, press SI.

Although we have fixed the crossed edges, the same two parts are still penetrating. We will now fix these

penetrations manually.

Use “ADD nodes to fix” to select the nodes to be dragged. Try dragging using “normal to shell”, until these

penetrations disappear.

View from underneath

Pick nodes with 

coloured arrows

Pick this shell



Penetrations – Automatic Fixings

Unblank the whole model (shortcut U). We will fix the remaining penetrations using the Automatic method.

Switch to Automatic Fixing. Press Apply.

PRIMER moves the penetrating nodes iteratively to reduce the penetrations. In this model, all the penetrations are

fixed.

In more complex models, some penetrations may remain; these need to be fixed manually. Usually the reasons are

either (a) crossed edges have not been fixed or (b) since PRIMER moves only the penetrating nodes (shown with

coloured arrows), not the penetrated elements, this is not always enough to resolve complex multi-layer situations.



Penetrations: Crossed Edge Fixings

“Pick & propagate” allows user to pick one node; PRIMER then automatically selects all the other nodes that are on

the same side of the Crossed Edge. Selection can be adjusted using ADD, REM

Fixing the selected nodes is a separate operation. The usual methods are available, e.g. “Auto fix”, “Normal to

shell”, etc

Pick one node Other nodes are 

selected 

automatically

Try this on crossed_edge.key



Penetrations: Crossed Edge Fixings

auto

Pick one node

“Pick, propagate & fix” allows user to pick one node; the selection of other nodes that are on the same side of the

Crossed Edge, and the fixing, are both performed automatically in a single operation



Spotwelding

This section of the course is a reduced version of our 

separate Oasys PRIMER training course, “Spotwelds and 

Connections”



Creating Spotwelds

• Delete all models from PRIMER

• Read in biw_for_welding.key

• Make all the body panels 50% transparent (e.g. right-mouse-drag 

across=>transparency=>50%)

• Zoom in on the right-hand lower B-post: we will start by creating 

spotwelds on the forward flange.

• Switch on the element borders (shortcut Y)



Creating Spotwelds

• Tools=>Connection=>Create

• The Connections menu is used for spotwelds and other

connection types

• First we have to tell PRIMER which panels can be

considered for welding. This model consists only of body

panels so we can just select all the shell-element parts in

the model.

• Press “Select Candidate elems/part” , All, Apply Selection.

Or, just press “All”.



• Leave the spotweld type set to Beam.

• This model already contains an empty

Part ID for the beam spotwelds

(ELFORM=9, *MAT_SPOTWELD).

PRIMER automatically finds this and

uses it. If this part were not present in

the model, you would have to create

one first before creating the spotwelds.

• Try the “pick screen point” option

• Click on a point on the forward flange of
the lower B-post.

• A green spotweld appears.

• Rotate the view: PRIMER found 3
layers to be welded, so it created a
chain of 2 beams.

Creating Spotwelds



• Switch the element type to Hexa.

• Again, a suitable part is already present in the model so

PRIMER uses it.

• Click on the flange in several places: a solid spotweld appears

in each place.

• Also try 4-Hexa.

Creating Spotwelds



Autoweld

• Switch the creation method to Autoweld. With this option, PRIMER tries to create welds at a user-

defined pitch, using the free edges of the panels as a guide.

• This option is used when no information is available about the actual locations of the spotwelds.

• Set the “min run length” to 50, i.e. PRIMER will try to spotweld any flange longer than 50mm.

• Check that the weld pitch is 40mm.

• Press Apply.



Autoweld

• There will be places where PRIMER has not created welds (e.g. where the panel gaps are too large), so the model still needs to be checked carefully

when using this creation method!



Creating Spotwelds

• When creating spotwelds, PRIMER also creates connection entities. These are the

green or red circles, coloured according to status.

• If you wish, visibility of these can be switched off using the Entities panel.

• This entity visibility switch will automatically be switched on whenever new

spotwelds are created.



Adding a Tied Contact 

• After creating spotwelds, we need to create a tied contact to stick them to the panels.

• Press Contact, Create connection contact, Two contacts.

• PRIMER creates a *CONTACT_TIED_SURFACE_TO_SURFACE for solid elements, or a

*CONTACT_SPOTWELD for beam elements. It will also create parallel penalty based

contacts if any rigid constraint clash is detected.

• In this model, the body structure Part IDs are in the range 1,000,000 to 1,000,999. We

recommend to change the *SET_PART of the master side of the tied contact to

*SET_PART_GENERATE such that any body panels added later will automatically be

included in the tied contact.



Writing a Spotweld File 

• Dismiss the Spotweld Create menu (e.g. press ESC while the mouse is in that menu)

• To save the newly created spotwelds, we should either write out a keyword file, or write a spotweld file. The
spotweld file contains the coordinates of each spotweld, and which panels are connected. The same
spotwelds could be re-created in another similar model from the spotweld file.

• “spotweld file” = simple csv format, one line per weld.

• “PRIMER connection file” = xml-format, contains more information e.g. whether the welds are beam or hexa.

• Unigraphics (UG) format weld file is also available.

• We would recommend to choose a PRIMER Connection file, to avoid losing any information.

• Write a connections file named example1.xml.



Reading a Spotweld File

• Before reading the spotweld file, we will delete all the existing

spotwelds.

• Press Delete, leave the selector on “All connections”, Apply,

“Delete conx and FE”.

• Press Read, select file format as “spotweld file” and browse to

find the file sptwld.spt

• The file format is PRIMER Spotweld File.

• Press Apply



Reading a Spotweld File

• An image of the file contents appears

• “PRIMER spotweld file” format can be used for files written by other software – the meaning of each column may be controlled from the drop-down

menus. The limitation is that the file must have only one line per spotweld.

• Move the menu so you can see the vehicle.

• Press Apply.

Drop-down menu to 

change meaning of 

column of data



Reading a Spotweld File

• PRIMER creates the spotwelds (green symbols) where possible.

Bad welds are shown in red.

• A message appears stating how many spotwelds were successfully

created, and how many were not. Press Continue.

• Most spotweld files contain some errors. Fixing the errors can be a

time-consuming task. PRIMER automatically puts the bad welds into

the Connection Table.

• We will now use the table to fix some of the errors.



The Connection Table

• Try hovering over the Error and Details columns.

• Try sorting the table by clicking on the column headers.

• Try using the View button to change the contents of the table.

• Look at the options under “Action” – the most commonly used of these are also available by right-click on selected welds.

Select welds here, or by clicking 

in the table

Make the action happen using the Apply buttons, or 

by right-click on welds selected in the table



Using the Connection Table to Fix Bad Welds
• Try sorting the table by clicking on the column headers.

• Go back to sorting by ID (left-hand column).

• Select welds 3,4,18,19 & 20.

• Right-click in the blue area, click on “show conx and attached panels”



Fixing Errors

• The selected connections, and the panels referred to, are displayed.

• The error is clear – the right-hand A-post has been referenced instead of the left-hand one.

• Right-click on the data in Layer 1 (P10000001), drop down to “Select PID”, select part 10000000.



Fixing Errors
• The revised data is shown in red. 

• To update the connection data and remake the weld, right-click in the blue area, click on “Update & remake”.

• Right-click again, “Show conx & panels” – to check that the correct panels are now shown.



Bolt Connections 



Bolt Connections 

• Various bolt/joint connections can be created in PRIMER:



Other Connection Types - Adhesive

• Runs of solid adhesive can be created in PRIMER:



Other Connection Types - Adhesive
• Lines of spotwelds can be created in PRIMER:



More on Spotwelding

• In the separate course “spotwelds and connections”, we also cover:

• Spotweld file formats.

• More on checking and correcting errors in spotweld definitions.

• Reproject to new panel geometry.

• Creating and modifying bolts/adhesive.



Occupants

This section of the course is a reduced version of our 

separate Oasys PRIMER training course, “Seat and Dummy 

Positioning and Belt Fitting”



Occupants

• PRIMER has various tools available for creating/editing models containing occupants. Tools available include:

• Dummy positioning

• Seat squash

• Mechanisms (for example, seats)

• Seatbelt fitting

• Airbag folding



Occupants
• Seat mechanisms and dummies can be linked so that any seat movement will lead to the dummy moving as well.

Delete all models and read in dummy_seat.key. 

1. In the Tools menu, click Mechanism->Position.

2. Left mouse click on the seat and drag the mouse across the screen.

3. While moving the seat notice that the dummy also moves.

4. Notice the hands/feet are fixed.

Occupants



Occupants
• After the occupant has been moved, the belt can easily be refitted over the dummy in the new position.

From the last slide, leave the dummy in a position forward 

from the original. 

1. In the Tools menu, click Safety->Seatbelts.

2. Click on Auto-refit then Apply.

3. Notice the belt will refit around the dummy. If you 

get a message about labels, click SHIFT_OLD.

Occupants



Model Modified



Model Modified
• Often, it is useful to see differences between models

Delete all models and read in demo_car4.key. Also 

read in demo_car4_modified.key.

1. Go to Model->Modified

2. Select model 2 for the “Modified model”.

3. Select to compare to model 1.

4. Ensure that the Properties and Geometries

switches are on.

5. Click Apply.

Model Modified



Model Modified

• Differences between the two models are shown in a tree view.

• PRIMER gives you information about differences in keywords, as well as additions/subtractions of entities between models.



Model Modified 
• Various options are available when right mouse clicking on one of the differences:

• Details will print details of the differences found.



Modified Models

• Various options are available when right mouse clicking on one of the

differences:

• Keyword will display keyword panels highlighting the differences

between the two cards.



Find



Find

• The “Find” function can be used to easily find entities in the model, and see their surroundings.

Delete all models and read in 

demo_car4.key. 

1. In the Tools menu, click Find.

2. Select NODAL_RIGID_BODY 

in the selection menu. 

Choose the first one in the list 

(1000874).

3. PRIMER will sketch the 

location of the NRB with 

crosshairs.

4. Turn on Volume. PRIMER will 

show entities within a 

specified volume around the 

NRB.

Find



Mass Properties



Mass Properties

• The “Mass Properties” function can be used to calculate mass properties of selected entities.

1. In the Tools menu, click 

Mass Prop.

2. Select INCLUDE FILE in 

the selection menu. 

Choose 

(22) bonnet2.key.

3. Click CALCULATE. 

PRIMER will calculate 

mass properties of the 

include based on the 

settings on the panel, and 

report the result.

4. Various options are 

available for how to 

handle attached mass, 

and inertia calculations.

Mass Properties



Scripting



Why write scripts within PRIMER?

• Advantages of writing a JavaScript to create a new capability:

• Quick turnaround – don’t have to wait for new version of T/HIS, D3PLOT or PRIMER

• Can keep your application confidential

• Under your control – can do it yourself if you wish.

• Example applications (PRIMER):

• Creating a simple mesh, or test models with standard loading

• Data checking or correcting

• Geometric morphing functions

• Input or output translators, special-format spotweld or connections files

• Automating routine tasks

• Example applications (D3PLOT):

• Generating your own data components for plotting, calculated from any information already contained in the model or from external files



Scripting

• An example of a PRIMER script is to generate a simple mesh.

1. Delete all models within PRIMER.

2. Go to Tools->Script and use the file selector to select make_shell_mesh.js. Click Run.

3. A mesh should appear.

4. Open the file make_shell_mesh.js in a text editor and change some of the variables at the top. Rerun the 

script to see the difference.

Multi-Model Build



Parameters



*PARAMETER in PRIMER

• *PARAMETER cards allow you to specify parameter values that can then be referred to anywhere in the model.

• This allows you to change one PARAMETER rather than changing multiple fields, e.g. setting thickness on multiple section cards.

*PARAMETER

R GAUGE          5.2

*SECTION_SHELL

1         2       0.0         0       0.0       0.0         0         0

&GAUGE    &GAUGE    &GAUGE    &GAUGE 0.0       0.0       0.0         0

$

2         2       0.0         0       0.0       0.0         0         0

&GAUGE    &GAUGE    &GAUGE    &GAUGE 0.0       0.0       0.0         0



• *PARAMETER is supported in PRIMER.

• Type “&” in the input boxes and a popup will allow you to select/edit/create a *PARAMETER.

*PARAMETER in PRIMER

“P” button switches the display 

of parameters in the panel 

from the parameter name to 

the underlying values.



Functions not covered in detail in this course



Assign Mass
• Massing up an assembly:

Input Required Mass

Create Assembly

Distributed mass 

added using
*ELEMENT_MASS



Bill of Materials
• PRIMER can read any type of delimited file (e.g. CSV from Microsoft Excel

• User selects field type from popup menu (Model PID, thickness, material, element formulation, etc)

• Data is transferred into CAE model

• PRIMER can also write a Bill of Materials file 



Automatic Assembly and Loadcase Control

Automatic Model Assembly

PRIMER can assemble models from a Database 

of INCLUDE files. For each loadcase or model 

configuration, a template defines which 

INCLUDE files are selected.



Automatic Assembly and Loadcase Control

?
Database

The Database is a library of 

all possible INCLUDE files 



Dummy Positioning

• Dummy can be positioned by 

• Rotating joints

• Dragging parts, restraining other parts

• Typing desired coordinates for H-point or other reference points

• Positions saved to/from file 



Dummy Positioning

• Dummy can be positioned by 

• Rotating joints

• Dragging parts, restraining other parts

• Typing desired coordinates for H-point or other reference points

• Positions saved to/from file 



Seatbelt Fitting

1. Define belt 2. Define path 3. Mesh belt

4. Setup contact• Belt creation in 4 steps

• Once created slipring, pretensioner, retractor can be added from belt menu



Seatbelt Fitting

• PRIMER remembers the belt information at the end of the keyword files so the belt can be re-fitted in one operation if the dummy is moved.



Mechanisms

H-point

X1, Y1, Z1

H-point

X2, Y2, Z2

• A mechanism (for example, a seat) can be defined within PRIMER. The

mechanism consists of Assemblies (groups of parts) and joints (pin, hinge

or sliding).

• The mechanism can be positioned by dragging, or by typing in the desired

coordinates of “reference points”



Combined Mechanisms

• One mechanism may be linked to another, e.g. seat squab to dummy

pelvis. Then the dummy and seat can be dragged together in a single

action.



Seat Foam Compression

• Dummy has been positioned, penetrating the foam.

• “PRIMER” method depenetrates the top surface of the foam, and morphs the 

interior foam nodes to spread the strain evenly.

• “Dyna” method helps the user to set up an LS-DYNA analysis in which a rigid 

dummy compresses the seat foam until the correct H-point is achieved.



Instrument Panel Pendulum Impact

• Setup of models for ECER21.

• Both interactive and batch mode supported.

• Easy creation/modification of target points.

• Automated positioning and de-penetration.

• True and realigned approach angle supported.

• Data saved in model or written to csv target file.

• Multiple models (for multiple impact points) can be set up in 

a single operation 



Load Paths

*DATABASE_CROSS_SECTION’s can be grouped together in PRIMER to create load paths. These can be viewed and contoured within D3PLOT.



Mark-up Tools

• Various tools are available within PRIMER for zone markup, targeting and muti-model setup:

Pedestrian head/leg markup FMVSS226 (ejection mitigation) markup



Rigidify

• Rigidify is used to rigidify selected parts of the model.

• Example uses include replacing complex deformable meshes with rigidified representations to reduce runtime.

• Rigid constraint clashes, tied contacts etc. are all taken care of during the rigidification process.



Units

• Model units can be easily modified in PRIMER.

• If you change the units system, all appropriate fields are updated automatically to account for the change.



Meshing Tools

• Various basic meshing tools are available in PRIMER:

• Mesh surface drag tool to improve mesh quality



Meshing Tools

• Element mesh creation:

• Standard shapes:

• Plate

• Cylinder

• Block

• Sphere/Hemisphere

• Standard creation methods

• Area

• Extrude

• Offset

• Ruled

• Standard modification tools:

• Split

• Combine

• Align normals



Meshing Tools
• Coat Part – coat solids/shells with shells/segments:



Meshing Tools

• Create/remove holes in shell mesh:



Barrier Positioning Tool

The supported crash test protocols are listed here. Small changes to these crash types (e.g. impact velocity) can be made by the user and saved easily:

EuroNCAP:

Side Impact (Pole)

FMVSS 214P: Side 

Oblique Impact (Pole)

FMVSS, UN-ECE:

Frontal Impact (Rigid)

FMVSS 216A: 

Roof Crush

EuroNCAP, UN-ECE:

Side Impact (R-Point)

FMVSS 214D:

Angled Side Impact

IIHS:

Side Impact (IRD)

EuroNCAP, FMVSS, IIHS,

UN-ECE: Frontal Impact (ODB)

FMVSS 301R: 

Rear Impact 

(MDB)

IIHS: Frontal 

Small Overlap



Airbag Folding 

Select Parameters
PRIMER automatically 

creates unfolded bag

Circular

Star?

1. Automatically create ‘star’ or ‘circular’ type folded bag in 3 steps



Airbag Folding
2. Fold an existing mesh using PRIMER’s step-by-step functions

Import existing mesh

Define which parts the 

bag is comprised of

Begin Folding*

*If an existing mesh is used, the fold lines must be already defined



Airbag Folding
3. Use PRIMER’s mesh-free function to fold an existing airbag shape or automatically create a circular airbag

Mesh-free folding allows any airbag shape to be folded in any pattern.  PRIMER takes care of creating fold lines and aligning the mesh

PRIMER automatically 

re-meshes existing mesh Begin Folding airbag 

regardless of mesh

Import existing or auto-

create circular mesh



Mesh independent Folding Example

Unfolded BagUnfolded View



1st Fold: ForwardUnfolded View

Mesh independent Folding Example



2nd Fold: ReverseUnfolded View

Mesh independent Folding Example



Mesh independent Folding Example

3rd Fold: Forward SubsetUnfolded View



Mesh independent Folding Example

4th Fold: Reverse SubsetUnfolded View



Mesh independent Folding Example

5th Fold: ReverseUnfolded View



Unfolded View 6th Fold: Forward

Mesh independent Folding Example



Mesh independent Folding Example

7th Fold: Reverse SubsetUnfolded View



Mesh independent Folding Example

8th Fold: Forward SubsetUnfolded View



Mesh independent Folding Example

9th Fold: 90deg ReverseUnfolded View



Mesh independent Folding Example

10th Fold: 90deg ForwardUnfolded View



Mesh independent Folding Example

Unfolded View 11th Fold: 90deg Rev. Subset



Mesh independent Folding Example

Unfolded View 12th Fold: 90deg Fwd. Subset



Mesh independent Folding Example

13th Fold: 90deg ForwardUnfolded View



Mesh independent Folding Example

Unfolded View 14th Fold: 90deg Reverse



Mesh independent Folding Example

15th Fold: 90deg Fwd. SubsetUnfolded View



Mesh independent Folding Example

Unfolded View 15th Fold: 90deg Rev. Subset
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