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PRIMER - Shortcuts

• Press “?” to bring up the programmable Shortcuts menu.

• By right-clicking on and 

any of the keys it is 

possible to view and 

change the action as 

well as assign macros 

or JavaScript's to an 

empty key.
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PRIMER Shortcuts - Iconise

• Press “i” to iconize all open panels.
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PRIMER Shortcuts - Tidy

• Press “t” to tidy and iconize all open 

panels at the top left hand corner of the 

display window.
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PRIMER Shortcuts – Close Panels

• Press “c” to close all panels, or press “Esc” 

to close each panel one at a time.
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PRIMER Shortcuts – View Attached

• Press “j” to find and display entities which are 

attached to the displayed entities.
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PRIMER Shortcuts – Close Panels

• Press “u” to un-blank all parts.
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PRIMER Shortcuts – Entities

• Press “k” to view the default entities. • Press “e” to bring up the entities menu.
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PRIMER Shortcuts – Toggle Quick Picks

• Press “q” to toggle between the 

standard “Quick Pick” bar and the 

one driven by the Primer function.

• Most functions in Primer allow the user to 

pick parts or other entities to perform an 

action. In these cases the “Quick Pick” 

bar only allows the user to pick an entity of 

that type. 

• The status of the cross in 

each menu indicates which 

one is active.



Slide 12Back to Contents

PRIMER Shortcuts – Overlays

• Press “y” to cycle through the different overlays (None, Boundaries 

Only, All edges).
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PRIMER Shortcuts – Cut Sections

1. Press “n” to bring up the Cut Sections 

menu. By default it is ready to pick a 

node to cut through (in constant X).

2. Press “d” to activate the drag option (use 

mouse to drag).
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PRIMER Shortcuts – Measure

• Press “m” to bring up the Measure menu.

• By default it will be ready to pick two nodes.
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PRIMER – Panel Configuration

• The Panel Configuration Menu found under 

“Options”->”Panel behaviour” allows the user 

to set the location and behaviour of the pop-up 

panels in Primer. 

• For example, selecting “Abs right” forces all 

panels to open at the top right hand corner of the 

Primer window.
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PRIMER – Quick Pick

• By default the “quick pick” menu is set to “Blank”. A lot of users forget how many other actions 

can be performed by changing the action in the drop down menu.

• Select “Information” and then click on a part 

to get the a summary of its properties:

• This menu also appears when right-clicking on a 

part.
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PRIMER – Quick Pick

• Select “Label” and click on a part to display 

the part ID:

• Select “Keyword” and click on a part to open 

the part’s keyword editor:
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PRIMER – Quick Pick

• Select “Find” and change from “Part” to “Nodal Rigid 

Body”.

• Key in a NRB ID number to get a crosshair at the 

location of the object.

• By default the entity type is “Part” but this 

can also be changed.
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PRIMER – Find Tool

• Under the Tools menu is the function “Find”. This opens a 

menu that allows the user to find any object in the model 

and sketch it.

• The option to display “Only” the entity in question can be 

very useful as is the “Only + attached” option.

• In our demo, selecting the Nodal_RIGID_BODY 300011 

with the “Only” option results in:
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PRIMER – Find Tool

• Selecting a “Volume” of 50 displays 

the entities inside a cube with sides 

50, centred at the NRB.

• Selecting “Only + attached” displays 

the NRB and the entities attached to it.
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PRIMER – Mass Property Calculator 

• The Mass Property Calculator found as “Mass Prop” in the Tools 

section allows the user to select elements and obtain a report with the 

mass, centre of gravity and inertia of the selection. 

• It is also possible 

to blank any parts 

that are not of 

interest and 

obtain the report 

for just the Visible 

Elements. 
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PRIMER - Saving views

After blanking certain parts or elements, the blanking property status may be 

saved. The same blanking can be recovered later. “Property” includes 

blanking, colour, transparency, entity visibility status; optionally, it can also 

include viewing parameters

Save some blanking states, then toggle 

between them using the arrows.

“SP” means “Save Properties”
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PRIMER - Saving views

• Hover the mouse over this button, then click “Options”

• A menu appears, giving control of which properties should 

be recovered when the arrow button is pressed

• By default, the viewing angle and zoom are not 

recovered. Switch on recovery of view here

• The current blanking, colours, etc can be written to a file 

*.prp for use in future sessions of PRIMER. The same file 

is also compatible with D3PLOT
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PRIMER – Part Tree Assemblies

• The “Part Tree” can be 

arranged in different ways 

to help users find parts as 

quickly as possible.

• Two of the most useful are 

the “Include” option, which 

sorts the parts by the 

include file in which they 

are defined; and the 

“Assembly” option, which 

sorts the parts by user 

defined assemblies created 

in Primer.
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PRIMER – Part Tree Assemblies

• To view, edit or create new assemblies go to the “Part 

Tree” menu and click on “Assembly”.

• Right-clicking on the model to bring up the “Edit” menu.

• To add a new assembly, click on “Create Assembly”, give 

your assembly a name in the pop-up window. Then drag 

and drop, or cut and paste the parts you wish to add into 

the assembly.
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PRIMER - Part Tree Assemblies

• Most Tools in Primer use the object 

menu to pick which elements the 

action will be performed on. 

• Part Tree Assemblies created by the 

user are one of the categories 

available to users in the object 

menu.

• Actions can be performed on all the 

parts belonging to the Part Tree 

Assembly.
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PRIMER - Part Tree Assemblies

• Information for the assemblies created in 

Primer can be saved as comments in the 

keyword deck or in HM/ANSA format.

• This it done by going to “Model -> Write -> 

LS-Dyna output options”.

• Use the last drop down menu to chose the 

format in which the Part Tree Assemblies 

are written.
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PRIMER – Part Tree Contents

• Another useful function within the “Part Tree” 

menu is the “Contents” tree. 

• This organizes all the different objects by entity 

type, and can be grouped by which include file 

they are in by toggling on/off the “Include” button.

• Furthermore, by turning on the “List” button the 

bottom half of the menu will list all the objects 

found in the selection. Including options to Blank, 

Unblank, Only, Edit and Sketch.
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PRIMER – Object Menus

• Most actions in Primer involve using the Object 

menu to pick which entities the action will be 

performed on. 

• The “Filter” option in the Object menu allows the 

user to find parts faster, especially in bigger models.

• In the demo, selecting “Filter by MATERIAL type-> 

VISCOELASTIC” results in just 12 parts to pick 

from
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PRIMER – Object Menus

• Clicking on the red bar labelled “PART(s) (all models)” sorts the parts in the object menu by 

different quantities. 
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PRIMER – Object Menus

• The “Key_In” command opens a 

text box for the user to input a 

particular part number. 

• However, it is also possible to 

include a range, for example: 

1000-2000.

• Or key in “101?” to select all part 

IDs consisting of four numbers 

beginning with 101.

• Or key in “1*” to select all parts 

beginning with 1.
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PRIMER – Object Menus

• The options menu “Opt” can be useful 

for blanking and un-blanking selected 

parts.

• Also, adding or replacing on the 

clipboard the selected parts or removing 

the selected parts from the clipboard.
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• In the Model menu, select “Build” 

and then “Build from csv

targeting file” from the drop 

down menu. Press Apply.

• It’s possible to “Read CSV” file if 

one has already been made.

PRIMER – Model Building From CSV

• This function is used for 

impactor positioning in 

multiple locations on a  

model.

• Select the “Model” that 

is to be tested, and the 

“Impactor” file. 

• This will create a certain 

number of cases with 

the impactor set up at 

different locations.

• Select the output 

directory for all the new 

models.
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PRIMER – Model Building From CSV

• Insert the locations of the impactor and the name of the 

directory to be created.

• Go back to the previous menu and “Write a CSV” file for future 

use.

• Open this menu in order to “Edit the 

Loadcases”, from the previous menu 

“Model Building from CSV”.
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PRIMER – Dummies and Seats

• One mechanism may be linked to 

another, e.g. seat squab to dummy 

pelvis. Then the dummy and seat 

can be dragged together in a single 

action.

• Go into “Mechanism -> Position” 

and drag the seat to the desired 

location. If the dummy is “slaved” 

to the seat it will move with it.
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PRIMER – Dummies and Seats

• The Dummy can be “slaved” to the Seat assembly by going into “Mechanism->Modify->Edit Children”.

• This brings up the menu where the “Master” and “Slave” assemblies can be selected. It is possible to 

select which parts of the dummy are slaved to the seat assembly.
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PRIMER – Dummies and Seats

• In most cases after repositioning the seat and dummy it is necessary to re-fit the 

seatbelt.

• PRIMER remembers the belt information at the end of the keyword files so the belt 

can be re-fitted in one operation if the dummy is moved

• This can be done by going into “Occupant -> Seatbelts -> Auto-Refit” and selecting 

Apply if no further changes are to be made. 
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PRIMER - Assembly Replace

• Old meshes are removed, including any 

spotwelds and other connected items that are 

“internal” to the selected parts
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PRIMER - Assembly Replace

• New assembly, which can include its own 

spotwelds and other connected items, 

new parts, etc. The new assembly is 

connected to the rest of the structure 

using existing spotwelds
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PRIMER - Assembly Replace

Spotwelds “inside” the 

assembly are taken from 

the new mesh

Spotwelds “around the 

edges” of  the assembly are 

taken from the old model, 

and re-connected.

Old model with spotwelds New mesh of assembly, 

spotwelded, may have 

different number of parts

Old model with spotwelds

+ =
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PRIMER - Assembly Replace

Action for *PART data

• When replacing an assembly, if a part in the source model 

has the same label as a part in the assembly you are 

replacing in the target model, there are two options 

available for data on the *PART card:

• Retain target data – part will reference the section, 

material etc. that it references in the target model

• Set data from source – part will reference the 

section, material etc. that it references in the source 

model. With this option you can also choose to 

import the referenced section, material, section, 

hourglass and equation of state cards from the 

source model to the target model

• Note that if a part in the source model does not match the 

label of a part in the assembly you are replacing in the 

target model, all referenced data (section material etc.) will 

be copied across
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PRIMER - Assembly Replace

Spotwelds “inside” the assembly 

are taken from the new model

Spotwelds “around the edges” of  

the assembly are taken from the 

old model, and re-connected

Same capabilities as existing 

Part Replace: re-creating bolt 

connections, re-attaching 

entities to the new mesh, etc 

• New mesh assembly, 

replaced into old model
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PRIMER - Assembly Replace

• How to ensure that new parts are in the correct Part Sets for contact, initial velocity, etc?

• Method 1 - *SET_PART_LIST_GENERATE. 

– Incoming new parts are correctly numbered to fall within the ID range

Body structure Part IDs are 20000 to 

29999; SET_PART_LIST_GENERATE

references this ID range

New Part ID 24010 will 

automatically fall into the Part Set
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PRIMER - Assembly Replace

• How to ensure that new parts are in the correct Part Sets for contact, initial velocity, etc?

• Method 2 - *SET_PART_LIST. 

– If ALL the outgoing parts are in the set, then the incoming parts will all be placed into the set 

automatically

Part IDs are 24001 to 24005 

are all in *SET_PART_LIST

PRIMER will put new Part ID 

24010 into the Part Set
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PRIMER - Assembly Replace

• Re-connection of bolt connections at the boundary of the new mesh depends on the definition 

method. If the layer definition consists of Part IDs, the bolt will re-connect only to those Part IDs, 

not to the new parts

No connection 

to new red Part
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PRIMER - Assembly Replace

• If Part Set ID or Part Tree Assembly name is used in the bolt definition, 

and if the new parts are included in that set or assembly, then the bolt 

will re-connect to the new parts too

Bolt connects 

to new red Part
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PRIMER – Compare Models

• With two versions of a model open in the same Primer window, it is 

possible to compare the keyword files and find any differences 

between the two models.

• Go to Model ->Modified? and select one model as the Modified 

version and one as the comparing version. This can be a model 

already open, the original version of the current model, or another file 

which can be read in.

• Turn on the Geometries button if any changes in geometry are to be 

recorded. Then click on Apply.

• Primer will output a tree viewer listing all the differences.
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PRIMER – Compare Models

• In the Part category of the tree viewer, Primer 

differentiates between differences in the 

properties or geometry of parts.

• It also list any entities that are only present in one 

of the models. 

• When entities are present in the original model 

only, it is possible to copy them to the second 

model.

• Right clicking on any of the entity 

differences opens a menu with the 

option of opening the Keyword. 

• This opens a keyword for each model 

with the differences !
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PRIMER – Compare Models

• Another option available when right mouse clicking on one of the differences is:

– Checking and contouring geometric differences between parts.
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PRIMER – Compare Models

• In order to save only the include files with differences in them got to: Write 

-> LS-Dyna output options, then tick “Select files”.

• When saving the file a new window will appear for the user to select the 

includes to be written. 

Select “Find 

Modified” for a 

list of the include 

files which have 

changed. 
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PRIMER – Compare Models

• Another way to compare differences is to go into 

Part -> Compare and select the modified model.

• This brings up a table of all the model parts and their 

differences with the original model.

• The table can be sorted by column and more properties can 

be added by clicking on “View”. 
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PRIMER – Cross Sections

• Cross sections can be created normal to a feature line by selecting this option in the “Local 

System Type” drop down menu.

• This allows the user to select a point on the feature line (XCT,YCT,ZCT) and the size of the plane 

(LENL & LENM).

• It is also possible to select the part set that the cross section is applied to (PSID). 
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PRIMER – Cross Sections

• Turn on the Auto Create option and set the Offset to 50 (or desired amount). 

• Press “+” to create multiple cross sections along the feature line at a constant distance.
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PRIMER – Connections

• A useful feature of Primer connections is that a line of 

Spotwelds can be created along a free edge.

• Set the distance from the edge and the size and type of the 

Spotweld element.

• Pick the parts to be joined and two nodes defining the free 

edge. Then click Apply.

• The result is a line 

of Spotwelds such 

as in this example.
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PRIMER – Connections

• If one of the parts that were welded together needs to be 

replaced, first load the new version of the part.

• Go to Part -> Replace, select the old and new parts and make 

sure the “re-attach options” include “remake connections”.

• The Spotwelds are re-made by Primer so that they still follow the 

free edge defined earlier.
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PRIMER – Mesh Quality and Modifying

• A useful tool in Primer to make small changes to the 

mesh is “Drag Node”.

• This allows the user to move nodes along different 

directions, with the added feature of respecting or not 

any free edges.
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PRIMER – Mesh Quality and Modifying

• To visualize the quality of 

the elements turn on the 

“Quality” button.

• This plots the quality 

imperfection of each 

element by default.

• In order to change the plot 

click on “Settings”. This 

brings up the “Element 

Quality Settings” menu 

where the user can select 

what is visualized.

• Selecting the Failed Criteria 

box allows the user to only 

colour the elements which 

are failing given a user 

defined criteria.

• Click on “Element quality 

options” to specify the 

criteria.
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PRIMER – Mesh Quality and Modifying

• It’s useful to have the quality setting on when dragging nodes in order to visualize any 

improvements, given that the contour updates in real time.
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PRIMER - SPC display

Translational or rotational 

restraints applied by either 

*BOUNDARY_SPC or 

MAT_RIGID can be plotted in 

PRIMER. The colour indicates 

the degrees of freedom of the 

SPC.
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PRIMER - SPC display

For *MAT_RIGID, a larger circle is 

drawn at the Centre of Mass. This may 

be hidden inside the part; we 

recommend to draw in Line mode.
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Model check – selective by Include File

When I perform a Model Check, how can I stop Primer reporting errors in standard 

dummy models? 

How can I find errors in the Include file for which I am responsible?

Switching off the checking for 

an Include File means “do 

not check the entities in this 

Include File”. Entities in other 

Include files might still have 

errors caused by entities in 

the switched-off Include 

Files, and these errors would 

still be reported. 
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Model check – selective by Include File

$PR_SUPPRESS_INCLUDE_CHECK

Write out model

Comment at top of Include File

(same comment could be added by text-edit)
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Model check – suppress certain types of error

How can I stop Primer reporting a certain type of error?
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Model check – suppress certain types of error

1. Switch on “Tags”

2. Note the Tag for this type of error…
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Model check – suppress certain types of error

M_ST_24_07  WARNING  

M_ST_24_10  IGNORE

PART_122    ERROR

3. Create “error configuration file”

4. Set preference to refer to this file
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Entity numbering

My company has a numbering scheme defining the IDs for each Include File. 

What is the easiest way to implement that in Primer? 

• Example:

– Barrier: 1-999999

– Dummy (driver): 1000000-1999999

– Dummy (passenger): 2000000-2999999

– Engine: 5000000-5999999

– Suspension: 6000000-6999999

– Body: 10000000-19999999
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Include File numbering ranges

$PR_MIN_LABEL: 1000000

$PR_MAX_LABEL: 1999999

$PR_N_EL_MIN_LABEL: 1000000

$PR_N_EL_MAX_LABEL: 1999999
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PRIMER - Scripts

• Some PRIMER capabilities are issued in the form of 

scripts. 

• See Tools=>Scripts
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PRIMER - Interior Head Impact Mark-up (FMVSS201)

• Calculates impact points according to rules 

of FMVSS201

• Angles and velocity can be modified by the 

user

• Creates impact point file (csv format)
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PRIMER - Barrier positioning tool

• Crash Test Setup script for 

positioning the barrier and

applying initial conditions

• Includes the detailed rules for 

many crash test protocols
• Step 1 – select crash protocol
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PRIMER - Barrier positioning tool

The supported crash test protocols are listed here. Small changes to these crash types (e.g. 
impact velocity) can be made by the user and saved easily:

EuroNCAP:

Side Impact (Pole)

FMVSS 214P: Side 

Oblique Impact (Pole)

FMVSS, UN-ECE:

Frontal Impact (Rigid)

FMVSS 216A: 

Roof Crush

EuroNCAP, UN-ECE:

Side Impact (R-Point)

FMVSS 214D:

Angled Side Impact

IIHS:

Side Impact (IRD)

EuroNCAP, FMVSS, IIHS,

UN-ECE: Frontal Impact (ODB)

FMVSS 301R: 

Rear Impact 

(MDB)

IIHS: Frontal 

Small Overlap
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PRIMER - Ejection Mitigation (FMVSS 226)

• Calculates impact points according to rules of FMVSS 226.

• Multiple models can be built automatically.
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PRIMER - SPH Volume Creation Tool

• Script for creation of SPH elements within an enclosed volume.
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PRIMER - Preferences (oa_pref files)

• oa_pref files are text files saved on your system that contain preferences 

used by Oasys software.

• These are useful so you don’t have to change settings every time you open 

PRIMER/D3PLOT etc.

• The file will contain lines that look like this:

primer*display_factor:            1.40

primer*display_brightness:        1.00

primer*display_saturation:        1.00

primer*button_gradation:          0.00

primer*font_size:                 default

primer*font_type:                 helvetica

primer*background_colour:       WHITE
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PRIMER - Preferences (oa_pref files)

• Preferences can be set in PRIMER through the “Options” menu:
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PRIMER - Preferences (oa_pref files)

• Preferences can be changed in the preference panel which opens. The 

example below shows how to change the background colour of the graphics 
window.
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PRIMER - Preferences (oa_pref files)

• oa_pref files can be read from a number of locations

“System” or 

“Install” 

preferences

User preferences

PRIMER user 1 PRIMER user 2 PRIMER user 3

User preferencesUser preferences
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PRIMER - Preferences (oa_pref files)

• When opening the preference panel, you may get a message about modifying 

the install preferences – this is because preferences can be saved in a 
number of places:
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PRIMER - Preferences (oa_pref files)

• oa_pref files can be stored in 4 locations:

– OA_ADMIN – top level configuration – often the same as OA_INSTALL

– OA_INSTALL – Installation level (location of executables)

– HOME – users personal home area

– Current working directory (rarely used)

• Oasys software will read the oa_pref files in the order above. When modifying 

preferences from within the software, if you get the option shown on the 

previous slide, it is because you have permission to change the preferences 

stored in the installation area. If you do have permission and choose not to 

modify the installation preferences, any preference modifications will be 

saved in the HOME area.

• If you do not have permission to change installation preferences, any 

preference modifications will be saved in the HOME area.
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PRIMER – What’s New

• Don’t forget that every 

version of Primer comes 

with a PDF detailing all 

the new functions added 

in that version.
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